Jump to content

Custom Search

Welcome to the Ford Edge Forum


Sign In  Log in with Facebook

Create Account
Welcome to the Ford Edge Forum - the largest Ford Edge forum discussion board on the web. You must register to create new topics or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Benefits of membership:
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create a photo album and post images. . .and more!
Click here to signup now
 
Guest Message by DevFuse

Photo
- - - - -

Shift to Park Warning when it's in Park


  • Please log in to reply
133 replies to this topic

#121 OFFLINE   WWWPerfA_ZN0W

WWWPerfA_ZN0W

    Ford Edge Legal Resident

  • Edge Platinum Member
  • 8,865 posts
  • Region:U.S. Northeast
  • Location:Maryland
  • Edge's Year:Decline

Posted 29 November 2016 - 06:58 PM

Sorry to hear, Randy. If you are not far out of warranty, talk to Ford directly at their 1800 number, or on Twitter @fordservice I think. They may make a goodwill adjustment for you. Then get a Ford Premiumcare plan to cover future incidents. I assure you, the peace of mind will be well worth it. Buy the plan online for the best rates.







Lose this advertisement by becoming a member. Click here to create a free account.


#122 OFFLINE   WatercooledEdge

WatercooledEdge

    New Edge Member

  • Edge Member
  • 1 posts
  • Region:Canada Quebec
  • Location:Montreal
  • Edge's Year:2013

Posted 13 January 2017 - 05:31 PM

This thread seems to have died a few months back, but did changing the switch work fine? Is there anywhere online we can buy shifter assemblies or just through the dealer?

#123 OFFLINE   DD2000GT

DD2000GT

    New Edge Member

  • Edge Member
  • 4 posts
  • Region:Decline
  • Location:Texas
  • Edge's Year:Decline

Posted 16 January 2017 - 08:41 AM

I registered to this site specifically to post on this semi-common issue to help any like myself who research how to fix issues themselves. I can attest this issue can easily be fixed with just replacing a $5 microswitch and less than 1 hour of easy time. Thanks to the previous poster that posted the microswitch info, but I saw a few posts with the wrong parts being shown to fix this issue. You need a SPDT three lead switch with the posts on the left side. The CORRECT Omron switch part number is D2HW - BL201M - this version has three leads already in place for easy spicing. I got mine from Mouser Electronics for $5.02. If you want the version with the solder posts, the part number is D2HW - BL201H but you will probably need to remove a lot more stuff to get this resoldered. I went ahead and bought a few spares as well as I expect this to fail again at some point... Don't worry about getting one with a lever, as you will pull the lever off the old switch and put it on the new one.

 

The great part is you won't have to remove the shifter if you get the switch with the leads already attached. Start by setting the parking brake, then start your car and move the shifter into drive (you need to do this so the console cover can move back away from the dash face-plate), then turn the car back off. Remove the center console with the cup holders. Remove the two side trim pieces by pulling straight up. Then, remove the 6 screws holding this cover down under the trim pieces with a Torx T-20 bit. Now, separate the center console from the dash face-plate - this also pulls straight out (towards the shifter) and is kind of difficult so pull carefully but aggressively. Pull straight up on the console from the rear closest to the storage box and it will pop loose and up. You will not be able to pull it up much due to a few wires still attached to the console, but it is more than enough to get the job done. Working from the passenger side, locate the existing microswitch mounted to the shifter towards the front. Pry it away from the shifter using a thin blade flathead screwdriver and un-route the wiring so you can pull this switch out enough to work with it. I cut the leads off the old switch where it was soldered in place and I had enough wire sticking out that I could splice the new one in easily. NOTE - Leave just a little of the wire coloring on the old switch so you can match the wires up to the new switch leads as the colors are not the same. Take the lever off the old switch and press it into place on the new switch, then re-mount the new switch to the shifter by pressing the posts into the appropriate holes on the shifter base. NOTE - install the switch with the lever down and the leads on top. Put the console cover back into place just enough so you can operate the shifter. Start the car and test your splices before putting everything back in place in case you need to pull it back out and fix the wiring. After your sure everything is fine, put the console back together in reverse order you took it out. Then smile that you finally fixed this annoying problem for $5 and less than an hours work!

 

I hope I helped someone from either paying the crazy dealership price or buy a completely new shifter and spend much more time and effort taking things apart to do this.


  • evilkid500, WWWPerfA_ZN0W, omar302 and 2 others like this

#124 OFFLINE   WWWPerfA_ZN0W

WWWPerfA_ZN0W

    Ford Edge Legal Resident

  • Edge Platinum Member
  • 8,865 posts
  • Region:U.S. Northeast
  • Location:Maryland
  • Edge's Year:Decline

Posted 16 January 2017 - 09:08 AM

Thank you :thumbsup:  If you have any pics and could upload them, that'd be a bonus!



#125 OFFLINE   akirby

akirby

    Ford Edge Legal Resident

  • Moderator
  • 10,699 posts

Posted 16 January 2017 - 09:57 AM

Excellent!  Can you create a new topic with this info so I can put it in the appropriate forum and pin it?


  • WWWPerfA_ZN0W likes this

#126 OFFLINE   DD2000GT

DD2000GT

    New Edge Member

  • Edge Member
  • 4 posts
  • Region:Decline
  • Location:Texas
  • Edge's Year:Decline

Posted 16 January 2017 - 10:49 PM

Excellent!  Can you create a new topic with this info so I can put it in the appropriate forum and pin it?

As requested, posted it here: http://www.fordedgef...arning-message/


  • WWWPerfA_ZN0W likes this

#127 OFFLINE   DD2000GT

DD2000GT

    New Edge Member

  • Edge Member
  • 4 posts
  • Region:Decline
  • Location:Texas
  • Edge's Year:Decline

Posted 16 January 2017 - 10:50 PM

Thank you :thumbsup:  If you have any pics and could upload them, that'd be a bonus!

Sorry - no pics. If I would have been on my game I would have documented it better.


  • WWWPerfA_ZN0W likes this

#128 OFFLINE   Ciscoz

Ciscoz

    New Edge Member

  • Edge Member
  • 1 posts
  • Region:Canada Prairie Provinces
  • Location:Winnipeg
  • Edge's Year:2013

Posted 06 November 2017 - 02:36 PM

Thanks for all the great info on this issue gentlemen. I've been having this problem with my 2013 Edge Sport for a couple months now. I have an extended warranty so may let the dealership fix this, but am tempted to do the simple switch replacement myself if I can find a source for that OMRON switch in Canada, or via an online order. I tried to access the Mouser Electronics site thru the posted link but when I click on either the Canada or United States location option I am blocked from proceeding and get an "Access Denied" message. I'll try some other options to contact Mouser, or search for another supplier. If i do conduct the repair myself I'll take some photos of the process and try to upload to this site. Thanks again for the reference material, and especially to DD2000GT for the great write-up on his repair.



#129 OFFLINE   omar302

omar302

    Ford Edge Addict

  • Edge Platinum Member
  • 1,910 posts
  • Region:Middle East
  • Location:Qatar
  • Edge's Year:2016

Posted 06 November 2017 - 11:13 PM

Thanks for all the great info on this issue gentlemen. I've been having this problem with my 2013 Edge Sport for a couple months now. I have an extended warranty so may let the dealership fix this, but am tempted to do the simple switch replacement myself if I can find a source for that OMRON switch in Canada, or via an online order. I tried to access the Mouser Electronics site thru the posted link but when I click on either the Canada or United States location option I am blocked from proceeding and get an "Access Denied" message. I'll try some other options to contact Mouser, or search for another supplier. If i do conduct the repair myself I'll take some photos of the process and try to upload to this site. Thanks again for the reference material, and especially to DD2000GT for the great write-up on his repair.

 

You can find it elsewhere online. Here for example .


  • WWWPerfA_ZN0W likes this

#130 OFFLINE   gm1911

gm1911

    New Edge Member

  • Edge Member
  • 3 posts
  • Region:U.S. Mountain
  • Location:Idaho
  • Edge's Year:2013

Posted 11 February 2018 - 02:23 PM

They make more money selling you a new shifter, and the dealer makes money installing it.



#131 OFFLINE   omar302

omar302

    Ford Edge Addict

  • Edge Platinum Member
  • 1,910 posts
  • Region:Middle East
  • Location:Qatar
  • Edge's Year:2016

Posted 27 March 2018 - 03:07 AM

I just found TSB 17-2219 which supersedes TSB 15-0047, the main thing here is the availability of a Shifter Kit switch to fix this problem. The kit for the 2011-2014 Edge is GT4Z-3F988-B and costs only $16.23. That is a big a difference compared to changing the complete shifter.
 
Attached File  TSB 17-2219 Shifter not in Park.pdf   83.32KB   11 downloads


  • WWWPerfA_ZN0W and mrmagoo like this

#132 OFFLINE   WWWPerfA_ZN0W

WWWPerfA_ZN0W

    Ford Edge Legal Resident

  • Edge Platinum Member
  • 8,865 posts
  • Region:U.S. Northeast
  • Location:Maryland
  • Edge's Year:Decline

Posted 27 March 2018 - 08:27 AM

Nice, thanks for posting!



#133 OFFLINE   mrmagoo

mrmagoo

    New Edge Member

  • Edge Member
  • 2 posts
  • Region:Canada Ontario
  • Location:hamilton
  • Edge's Year:2016

Posted 30 April 2018 - 02:46 PM

thanks omar302......great info.....too bad for years owners of edges and mkx's have spent upwards of $700 to repair something that a $32 (CDN) part plus labour would fix....I just went to the dealership for this "shift to park" alert, showed them the bulletins including the Dec 2107 one describing the simple switch replacement and they argued with me that their technician has always replaced the shift module for the problem. I explained that in black and white from Ford, it says the switch is all that's required. my point was..."its the new way and a new part". the advisor said he was noting on the bill that I refused to replace the shift module for the problem. it was like talking to a brick....the dealership couldn't comprehend there was a fix for something they'd been doing a different more costly way for years. but, in the end I'm confident its fixed 


  • WWWPerfA_ZN0W and omar302 like this

#134 OFFLINE   mrmagoo

mrmagoo

    New Edge Member

  • Edge Member
  • 2 posts
  • Region:Canada Ontario
  • Location:hamilton
  • Edge's Year:2016

Posted 03 May 2018 - 11:52 AM

Omar302...I shared this info on the Lincoln MKX website cuz my vehicle is actually a 2013 MKX .....(gave you credit for your sleuthing)....I hope it saves everyone money going forward.
In my case, I hope the dealership sends me a satisfaction survey about the visit cuz they'll be getting an earful about the service departments attitude

Thanks agn
  • WWWPerfA_ZN0W and omar302 like this




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users