Jump to content

Custom Search

Welcome to the Ford Edge Forum


Sign In  Log in with Facebook

Create Account
Welcome to the Ford Edge Forum - the largest Ford Edge forum discussion board on the web. You must register to create new topics or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Benefits of membership:
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create a photo album and post images. . .and more!
Click here to signup now
 
Guest Message by DevFuse

The official Ford authorized Ford Edge Registry is now live. More here!


Photo
- - - - -

What to expect at 200,000+ miles

Suspension bearings tie rods lower control arms Ball joints struts Strut bearing mounts Rear shocks

  • Please log in to reply
477 replies to this topic

#461 OFFLINE   macbwt

macbwt

    Ford Edge Fanatic

  • Edge Platinum Member
  • 2,489 posts
  • Region:U.S. Mississippi Valley
  • Location:Davenport Iowa
  • Edge's Year:2011

Posted 10 August 2017 - 06:17 PM

Unless something breaks down on my Edge.  I have no maintenance scheduled nor do I have any work pending on my 2011 Ford Edge Lullubelle.  Nearing 205,000 miles and operating great with everything working.    Great car and running great. 


  • WWWPerfA_ZN0W likes this







Lose this advertisement by becoming a member. Click here to create a free account.


#462 OFFLINE   macbwt

macbwt

    Ford Edge Fanatic

  • Edge Platinum Member
  • 2,489 posts
  • Region:U.S. Mississippi Valley
  • Location:Davenport Iowa
  • Edge's Year:2011

Posted 21 August 2017 - 09:07 PM

It was going to happen and finally did LU was running rather sluggish at WOT and I checked the Filter Minder and it was at 80 percent. So I was only running 20 percent air flow.   I pulled out the AEM filter and cleaned it.  Got a bunch of mud out of it and have now let it dry and re-installed the filter. Let's see what happens tomorrow during the 400 miles I will put on it.   The AEM filter had 98,000 miles on it since it was installed and was never cleaned.


  • WWWPerfA_ZN0W likes this

#463 ONLINE   chefduane

chefduane

    Ford Edge Enthusiast

  • Edge Platinum Member
  • 501 posts
  • Region:U.S. Southern Plains
  • Location:Dallas, TX
  • Edge's Year:2011

Posted 21 August 2017 - 10:56 PM

I have a similar setup; AEM filter w/ the filter minder.  I don't intend to let it go that many miles but now I know how far it CAN go without a cleaning.  I'll probably clean it every other oil change or so.  I'm currently doing 5k oil changes so 10k-15k sounds about right.  It sure would be nice to get 150k-200k out of my Edge also!!


  • WWWPerfA_ZN0W and macbwt like this

#464 OFFLINE   macbwt

macbwt

    Ford Edge Fanatic

  • Edge Platinum Member
  • 2,489 posts
  • Region:U.S. Mississippi Valley
  • Location:Davenport Iowa
  • Edge's Year:2011

Posted 07 September 2017 - 04:25 PM

I finally cleaned the air filter after 98,000 miles. Good to go.


  • WWWPerfA_ZN0W likes this

#465 ONLINE   chefduane

chefduane

    Ford Edge Enthusiast

  • Edge Platinum Member
  • 501 posts
  • Region:U.S. Southern Plains
  • Location:Dallas, TX
  • Edge's Year:2011

Posted 07 September 2017 - 08:03 PM

Mac, new type of Filter Minder?  I have the one that lays flat on the airbox and has the dial type read out.  Is that one more accurate than the dial type?

 

PS:  You shoulda' bought the Lambo.


Edited by chefduane, 07 September 2017 - 08:08 PM.

  • WWWPerfA_ZN0W likes this

#466 OFFLINE   macbwt

macbwt

    Ford Edge Fanatic

  • Edge Platinum Member
  • 2,489 posts
  • Region:U.S. Mississippi Valley
  • Location:Davenport Iowa
  • Edge's Year:2011

Posted 09 September 2017 - 12:50 PM

Mac, new type of Filter Minder?  I have the one that lays flat on the airbox and has the dial type read out.  Is that one more accurate than the dial type?

 

PS:  You shoulda' bought the Lambo.

I have the dial type on my wife's Edge.  This one was installed by the Filter Minder corp on my Edge.  I am not aware of any measurement differences other then the difference in the designs they both do the same thing.


Edited by macbwt, 09 September 2017 - 12:51 PM.

  • WWWPerfA_ZN0W likes this

#467 OFFLINE   macbwt

macbwt

    Ford Edge Fanatic

  • Edge Platinum Member
  • 2,489 posts
  • Region:U.S. Mississippi Valley
  • Location:Davenport Iowa
  • Edge's Year:2011

Posted 10 September 2017 - 07:53 PM

Did a video today on another topic and recorded the cold start up of LU.  Got me some blue smoke at start up for a minute or so. HUmmmm


  • WWWPerfA_ZN0W likes this

#468 OFFLINE   enigma-2

enigma-2

    Ford Edge Fanatic

  • Edge Member
  • 2,327 posts
  • Region:U.S. Great Lakes
  • Location:Indiana
  • Edge's Year:2009

Posted 10 September 2017 - 08:42 PM

Ah ha, do I see a valve guide replacment video in the near future? lol
  • WWWPerfA_ZN0W and macbwt like this

#469 OFFLINE   macbwt

macbwt

    Ford Edge Fanatic

  • Edge Platinum Member
  • 2,489 posts
  • Region:U.S. Mississippi Valley
  • Location:Davenport Iowa
  • Edge's Year:2011

Posted 11 September 2017 - 07:00 PM

Not so quick.  Run her till she drops. Then make the decision on what direction to go.

Attached Files


  • WWWPerfA_ZN0W likes this

#470 OFFLINE   enigma-2

enigma-2

    Ford Edge Fanatic

  • Edge Member
  • 2,327 posts
  • Region:U.S. Great Lakes
  • Location:Indiana
  • Edge's Year:2009

Posted 11 September 2017 - 08:29 PM

Brutal ...
Does lulabelle have black leather strap on seat covers and vodka for coolant? lol

#471 OFFLINE   macbwt

macbwt

    Ford Edge Fanatic

  • Edge Platinum Member
  • 2,489 posts
  • Region:U.S. Mississippi Valley
  • Location:Davenport Iowa
  • Edge's Year:2011

Posted 12 September 2017 - 05:51 AM

Brutal ...
Does lulabelle have black leather strap on seat covers and vodka for coolant? lol

Hummm I am questioning her life choices. LOL


  • WWWPerfA_ZN0W likes this

#472 OFFLINE   Gbczyk84

Gbczyk84

    New Edge Member

  • Edge Member
  • 12 posts
  • Region:U.S. Northern Plains
  • Location:IL
  • Edge's Year:2011

Posted 12 September 2017 - 11:47 PM

Did a video today on another topic and recorded the cold start up of LU.  Got me some blue smoke at start up for a minute or so. HUmmmm

Had this happen on ours once. Also a 2011, had around 75K miles on it. Started with remote and got blue smoke for a few seconds.

Unrelated, but did spark plugs and recently the valve cover update since then.  Just under 90K miles now and running strong.


  • WWWPerfA_ZN0W and macbwt like this

#473 OFFLINE   pedro2u

pedro2u

    New Edge Member

  • Edge Platinum Member
  • 108 posts
  • Region:U.S. Northeast
  • Location:Beautiful NH USA
  • Edge's Year:2011

Posted 13 September 2017 - 06:54 AM

Gbczyk84 -   I've had my2011 Limited since 40K, now at 72K, so plugs soon.  Jjust looking to keep up with needed  updates and improvements   What is the valve cover update?
  • macbwt likes this

#474 OFFLINE   WWWPerfA_ZN0W

WWWPerfA_ZN0W

    Ford Edge Legal Resident

  • Edge Platinum Member
  • 8,021 posts
  • Region:U.S. Northeast
  • Location:Maryland
  • Edge's Year:Decline

Posted 13 September 2017 - 07:07 AM

http://www.fordedgef...ge-valve-cover/
  • macbwt likes this

#475 OFFLINE   pedro2u

pedro2u

    New Edge Member

  • Edge Platinum Member
  • 108 posts
  • Region:U.S. Northeast
  • Location:Beautiful NH USA
  • Edge's Year:2011

Posted 13 September 2017 - 07:20 AM

Thanks, great video.  Ford Quicklane has been doing my oil changes and vehicle inspection and hasn't mentioned this as an issue.  Does this happen in all vehicles?  I'll have to pull that apart this weekend and take a look.

 

Seems like a simple fix, and might as well do it while you're changing the plugs since it's already off (which is on my list already to do)


  • macbwt likes this

#476 OFFLINE   macbwt

macbwt

    Ford Edge Fanatic

  • Edge Platinum Member
  • 2,489 posts
  • Region:U.S. Mississippi Valley
  • Location:Davenport Iowa
  • Edge's Year:2011

Posted 14 September 2017 - 05:43 AM

I just purchased the updated valve cover and will be replacing the old one.  Let's see if this helps with the oil consumption.


  • WWWPerfA_ZN0W likes this

#477 OFFLINE   omar302

omar302

    Ford Edge Addict

  • Edge Platinum Member
  • 1,580 posts
  • Region:Middle East
  • Location:Qatar
  • Edge's Year:2011

Posted Yesterday, 09:58 AM

Anyone here with 200k+ miles got a badge from Ford?

https://twitter.com/...149175995781120
  • WWWPerfA_ZN0W likes this

#478 OFFLINE   macbwt

macbwt

    Ford Edge Fanatic

  • Edge Platinum Member
  • 2,489 posts
  • Region:U.S. Mississippi Valley
  • Location:Davenport Iowa
  • Edge's Year:2011

Posted Today, 04:47 AM

Anyone here with 200k+ miles got a badge from Ford?

https://twitter.com/...149175995781120

I have a 200K and 300K mile badge from Ford.


  • WWWPerfA_ZN0W and omar302 like this





Also tagged with one or more of these keywords: Suspension, bearings, tie rods, lower control arms, Ball joints, struts, Strut bearing mounts, Rear shocks

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users