Jump to content

Custom Search

Welcome to the Ford Edge Forum


Sign In  Log in with Facebook

Create Account
Welcome to the Ford Edge Forum - the largest Ford Edge forum discussion board on the web. You must register to create new topics or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Benefits of membership:
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create a photo album and post images. . .and more!
Click here to signup now
 
Guest Message by DevFuse

The official Ford authorized Ford Edge Registry is now live. More here!


Photo
- - - - -

2013 EDGE SPORT PULLING TO THE RIGHT


  • Please log in to reply
30 replies to this topic

#1 OFFLINE   motox63

motox63

    New Edge Member

  • Edge Member
  • 6 posts
  • Region:U.S. Southern Plains
  • Location:Texas
  • Edge's Year:2013

Posted 01 March 2014 - 02:15 PM

Hello All,

 

Just purchased a new 2013 Edge Sport a couple of weeks ago and there seems to be an issue with the steering.  It constantly pulls to the right and doesn't matter which road or lane I am driving in.  I have to keep steady pressure to the left on the steering wheel for it to drive straight.  Just got back from the dealership and they checked the alignment and tell me that everything is within Ford's specs, but their suspension and brake guy was not there to look into the issue further.  Service guy said that it could just be road pull, but that sounds like some BS.  I have an appointment to bring it back next weekend to have the suspension guy take a look.  Has anyone else had this problem?  What was the fix?  I've read some who say there was a TSB on the 2011 models, but surely they would have taken care of that problem by the time the 2013's were built?  My build date is November 2013 if that makes a difference.  Ordered a set of H&R springs that I want to have installed, but not going to mess with that until I am sure they can resolve the steering issue with factory setup.  Can anyone give their opinion of the H&R springs?  Ride quality, handling?

 

Thanks


Edited by motox63, 01 March 2014 - 02:16 PM.








Lose this advertisement by becoming a member. Click here to create a free account.


#2 OFFLINE   ls973800

ls973800

    Ford Edge Enthusiast

  • Edge Member
  • 1,027 posts
  • Region:U.S. Southern Plains
  • Location:Dallas, TX
  • Edge's Year:Decline

Posted 01 March 2014 - 07:07 PM

Any abnormal or unusual tire wear anywhere yet?  Are the tires all the same PSI (35 per the manual)?  You could try switching the tires from side to side (left front to right front, right front to left front) and see if the problem persists, disappears, or now pulls to the left.

 

Haven't heard too many complaints new Edge's pulling one way or the other.  Make sure the rear alignment is also checked when the suspension guy is back at the dealership.



#3 OFFLINE   omar302

omar302

    Ford Edge Addict

  • Edge Platinum Member
  • 1,632 posts
  • Region:Middle East
  • Location:Qatar
  • Edge's Year:2011

Posted 02 March 2014 - 12:21 AM

Here is the TSB for the Pull/Drift to right for the 2011 model.

 

Attached File  TSB 10-24-8_Drift Pull Right.pdf   52.02KB   101 downloads


  • WWWPerfA_ZN0W likes this

#4 OFFLINE   normcloutier

normcloutier

    Ford Edge Member

  • Edge Member
  • 422 posts
  • Location:Canada

Posted 02 March 2014 - 09:08 AM

I have a 13 SEL and have been dealing with this from day 1. Had 3 alignments done and it was finally determined to be a faulty tire.

I had 20k service done last month and the problem returned. Waiting to take my Edge back in to have it looked at.

#5 OFFLINE   Michael Sherrod

Michael Sherrod

    New Edge Member

  • Facebook Member
  • 58 posts

Posted 02 March 2014 - 12:56 PM

I have this problem too but they determined the was the crown of the roads...wouldn't do anything for me.

#6 OFFLINE   akirby

akirby

    Ford Edge Legal Resident

  • Moderator
  • 10,048 posts

Posted 02 March 2014 - 04:52 PM

It's easy to prove or disprove whether it's the crown of the road.  Check it in a flat parking lot, driving in both directions.  If it pulls to the right then it's either a tire or the suspension or the brakes.



#7 OFFLINE   normcloutier

normcloutier

    Ford Edge Member

  • Edge Member
  • 422 posts
  • Location:Canada

Posted 02 March 2014 - 05:25 PM

My dealer tried to tell me it was the crown as well. To which I commented that the problem still occurs even when driving on one way streets in the left lane that crowns to the left. I would call BS on that excuse.

#8 OFFLINE   Michael Sherrod

Michael Sherrod

    New Edge Member

  • Facebook Member
  • 58 posts

Posted 02 March 2014 - 08:08 PM

Did you bring it back and get it fixed?

My dealer tried to tell me it was the crown as well. To which I commented that the problem still occurs even when driving on one way streets in the left lane that crowns to the left. I would call BS on that excuse.



#9 OFFLINE   Michael Sherrod

Michael Sherrod

    New Edge Member

  • Facebook Member
  • 58 posts

Posted 02 March 2014 - 08:09 PM

Mine happens at 65+

It's easy to prove or disprove whether it's the crown of the road.  Check it in a flat parking lot, driving in both directions.  If it pulls to the right then it's either a tire or the suspension or the brakes.



#10 OFFLINE   normcloutier

normcloutier

    Ford Edge Member

  • Edge Member
  • 422 posts
  • Location:Canada

Posted 03 March 2014 - 09:30 AM

It's going back in this week.



#11 OFFLINE   FordService

FordService

    Ford Edge Member

  • Official Ford Motor Co.
  • 494 posts
  • Region:Decline
  • Location:Dearborn, MI
  • Edge's Year:Decline

Posted 03 March 2014 - 03:57 PM

Hello All,

 

Just purchased a new 2013 Edge Sport a couple of weeks ago and there seems to be an issue with the steering.  It constantly pulls to the right and doesn't matter which road or lane I am driving in.  I have to keep steady pressure to the left on the steering wheel for it to drive straight.  Just got back from the dealership and they checked the alignment and tell me that everything is within Ford's specs, but their suspension and brake guy was not there to look into the issue further.  Service guy said that it could just be road pull, but that sounds like some BS.  I have an appointment to bring it back next weekend to have the suspension guy take a look.  Has anyone else had this problem?  What was the fix?  I've read some who say there was a TSB on the 2011 models, but surely they would have taken care of that problem by the time the 2013's were built?  My build date is November 2013 if that makes a difference.  Ordered a set of H&R springs that I want to have installed, but not going to mess with that until I am sure they can resolve the steering issue with factory setup.  Can anyone give their opinion of the H&R springs?  Ride quality, handling?

 

Thanks

 

Hey motox63,

 

Congrats on your new Edge! I'm Todd, the official Ford rep around these parts. I'd like to put you in touch with your regional customer service manager; please send me a PM (private message) with your full name, best daytime phone number, VIN, mileage, and servicing dealership.

 

Todd


Edited by FordService, 03 March 2014 - 03:58 PM.


#12 OFFLINE   motox63

motox63

    New Edge Member

  • Edge Member
  • 6 posts
  • Region:U.S. Southern Plains
  • Location:Texas
  • Edge's Year:2013

Posted 03 March 2014 - 08:16 PM

Any abnormal or unusual tire wear anywhere yet?  Are the tires all the same PSI (35 per the manual)?  You could try switching the tires from side to side (left front to right front, right front to left front) and see if the problem persists, disappears, or now pulls to the left.

 

Haven't heard too many complaints new Edge's pulling one way or the other.  Make sure the rear alignment is also checked when the suspension guy is back at the dealership.

No unusual tire wear, It just turned 1,000 last weekend.



#13 OFFLINE   motox63

motox63

    New Edge Member

  • Edge Member
  • 6 posts
  • Region:U.S. Southern Plains
  • Location:Texas
  • Edge's Year:2013

Posted 03 March 2014 - 08:17 PM

Here is the TSB for the Pull/Drift to right for the 2011 model.

 

attachicon.gifTSB 10-24-8_Drift Pull Right.pdf

Thanks for the TSB, appreciate it.



#14 OFFLINE   motox63

motox63

    New Edge Member

  • Edge Member
  • 6 posts
  • Region:U.S. Southern Plains
  • Location:Texas
  • Edge's Year:2013

Posted 03 March 2014 - 08:18 PM

It's easy to prove or disprove whether it's the crown of the road.  Check it in a flat parking lot, driving in both directions.  If it pulls to the right then it's either a tire or the suspension or the brakes.

Good idea, thanks for the suggestion.



#15 OFFLINE   motox63

motox63

    New Edge Member

  • Edge Member
  • 6 posts
  • Region:U.S. Southern Plains
  • Location:Texas
  • Edge's Year:2013

Posted 03 March 2014 - 08:19 PM

 

Hey motox63,

 

Congrats on your new Edge! I'm Todd, the official Ford rep around these parts. I'd like to put you in touch with your regional customer service manager; please send me a PM (private message) with your full name, best daytime phone number, VIN, mileage, and servicing dealership.

 

Todd

Thanks Todd, I appreciate it.  I'll send PM, now that I have 5 posts.



#16 OFFLINE   AvBg2000

AvBg2000

    New Edge Member

  • Edge Member
  • 8 posts
  • Region:U.S. Northeast
  • Location:Brooklyn, NY
  • Edge's Year:2013

Posted 05 March 2014 - 10:47 AM

wow thought it was just mine. i've played with the tire pressures to try to correct it. didnt know it was a common problem 



#17 OFFLINE   motox63

motox63

    New Edge Member

  • Edge Member
  • 6 posts
  • Region:U.S. Southern Plains
  • Location:Texas
  • Edge's Year:2013

Posted 08 March 2014 - 10:15 PM

Back to the dealership today and although I don't think they understand the definition of "appointment", It's not pulling to the right anymore.  Invoice shows that they made some adjustments to the caster, camber, & toe-in.  Still don't understand how they can tell me everything was within specs last weekend and this weekend they needed to make adjustments.  Almost wondering if they adjusted it outside of specs this time around to correct the issue, I didn't get to see the print out or screen showing the new alignment specs.



#18 OFFLINE   Michael Sherrod

Michael Sherrod

    New Edge Member

  • Facebook Member
  • 58 posts

Posted 08 March 2014 - 11:20 PM

You should go back again and get, if any problems arise and they say it's because of the alignment you'll want to have proof showing them that it was their job. Mine is getting worse and worse so I'm going to bring it in everyday if I have to!

#19 OFFLINE   normcloutier

normcloutier

    Ford Edge Member

  • Edge Member
  • 422 posts
  • Location:Canada

Posted 19 March 2014 - 10:14 PM

I finally got my Edge in to the dealership today. Problem was another separated tire. That's the second one.

#20 OFFLINE   WWWPerfA_ZN0W

WWWPerfA_ZN0W

    Ford Edge Legal Resident

  • Edge Platinum Member
  • 8,147 posts
  • Region:U.S. Northeast
  • Location:Maryland
  • Edge's Year:Decline

Posted 19 March 2014 - 10:26 PM

What tires do you have, normc?  Scorpions?






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users