Jump to content

Custom Search

Welcome to the Ford Edge Forum


Sign In  Log in with Facebook

Create Account
Welcome to the Ford Edge Forum - the largest Ford Edge forum discussion board on the web. You must register to create new topics or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Benefits of membership:
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create a photo album and post images. . .and more!
Click here to signup now
 
Guest Message by DevFuse

The official Ford authorized Ford Edge Registry is now live. More here!


Photo
* * * * * 1 votes

Wipers won't turn off!

wipers

  • Please log in to reply
27 replies to this topic

#1 OFFLINE   Mark S Grantom

Mark S Grantom

    New Edge Member

  • Facebook Member
  • 1 posts
  • Region:U.S. Southern Atlantic
  • Location:Houston
  • Edge's Year:2011

Posted 07 March 2015 - 03:03 PM

I have a 2011 Ford Edge Limited.  It has been in the shop twice because the windshield wipers have a mind of their own.  These are the non-automatic wipers.  When I turn them OFF, they will continue to cycle as if they are on the low intermittent setting.  (about every 25 seconds)  The dealer replaced the steering column switch, which solved the problem for a while, but they just started coming back on again this week.  Does anybody have a suggestion on how to fix this problem?  Thanks


  • mac66 likes this







Lose this advertisement by becoming a member. Click here to create a free account.


#2 OFFLINE   boogity

boogity

    New Edge Member

  • Edge Member
  • 18 posts
  • Location:United States

Posted 08 March 2015 - 10:33 AM

I had the exact same problem.    I replaced the switch lever on the steering column and the problem was fixed.   The parts have a warranty,   get it replaced again.



#3 OFFLINE   FordService

FordService

    Ford Edge Member

  • Official Ford Motor Co.
  • 494 posts
  • Region:Decline
  • Location:Dearborn, MI
  • Edge's Year:Decline

Posted 11 March 2015 - 02:28 PM

I have a 2011 Ford Edge Limited.  It has been in the shop twice because the windshield wipers have a mind of their own.  These are the non-automatic wipers.  When I turn them OFF, they will continue to cycle as if they are on the low intermittent setting.  (about every 25 seconds)  The dealer replaced the steering column switch, which solved the problem for a while, but they just started coming back on again this week.  Does anybody have a suggestion on how to fix this problem?  Thanks

HI Mark,

 

Have you had a chance to visit your dealer on this? Please let me know, along with your mileage, and I'll see how to best assist.

 

Meagan



#4 OFFLINE   mikeytp1421

mikeytp1421

    New Edge Member

  • Edge Member
  • 1 posts
  • Region:U.S. Mississippi Valley
  • Location:St. Loyuis, mo
  • Edge's Year:2011

Posted 14 March 2015 - 07:33 AM

I have the same problem. Meagan are you with Ford? Because after the 10 or 11 times I've brought this car in for SYNC problems, the constant un-Ford like rattles and noises, and now this unsafe and out-of-warranty problem, I'm about to give up on this car. This is really unlike any Ford I've ever owned. 

 

Anybody have a cure or fix for this intermittent wiper issue?



#5 OFFLINE   shacho

shacho

    New Edge Member

  • Edge Member
  • 19 posts
  • Region:Decline
  • Location:alabama
  • Edge's Year:2011

Posted 21 April 2015 - 07:53 AM

I'm experiencing the same issues.  I recently went on travel and had the pleasure of driving two to three hours in rainy weather.  Anywho, when I selected the second or third notch on the lever, the wipers worked as advertised for about a minute and then the wipers would speed up extremely fast.  I rotated the switch lever on the steering column back to the first notch for the wipers to work as normal.  I'm suspecting the wiper switch is fault/intermitting.   Any suggestions and or recommendations would be greatly appreciate.  Thanks.



#6 OFFLINE   ls973800

ls973800

    Ford Edge Enthusiast

  • Edge Member
  • 1,027 posts
  • Region:U.S. Southern Plains
  • Location:Dallas, TX
  • Edge's Year:Decline

Posted 21 April 2015 - 09:41 AM

I'm experiencing the same issues.  I recently went on travel and had the pleasure of driving two to three hours in rainy weather.  Anywho, when I selected the second or third notch on the lever, the wipers worked as advertised for about a minute and then the wipers would speed up extremely fast.  I rotated the switch lever on the steering column back to the first notch for the wipers to work as normal.  I'm suspecting the wiper switch is fault/intermitting.   Any suggestions and or recommendations would be greatly appreciate.  Thanks.

 

Follow the suggestion in post #2



#7 OFFLINE   chocobear

chocobear

    New Edge Member

  • Edge Member
  • 6 posts
  • Region:U.S. Southern Atlantic
  • Location:Tampa
  • Edge's Year:2013

Posted 07 May 2015 - 01:55 PM

My 2013 Edge is experiencing the same wiper problems - will not shut-off until I shut off the engine.  My local Ford dealer says they can look into the problem for $100. per hour.  They don't have a clue why this is happening.  The wipers continue to run on the dry winshield - which almost caused an accident - this is a very dangerous failure - with Ford not willing to fix unless I pay for a huge amount of investigation time.

 

I have had Fords for many years - still have a Ranger as well.  I can't believe that I bought the very expensive Edge Limited - and Ford will not fix my problems - because I have 55k miles.

 

I think it is time to move to another auto manufacturer that understands computers and software.  My SYNC system is a real pain to work with.



#8 OFFLINE   FordService

FordService

    Ford Edge Member

  • Official Ford Motor Co.
  • 494 posts
  • Region:Decline
  • Location:Dearborn, MI
  • Edge's Year:Decline

Posted 08 May 2015 - 12:31 PM

My 2013 Edge is experiencing the same wiper problems - will not shut-off until I shut off the engine.  My local Ford dealer says they can look into the problem for $100. per hour.  They don't have a clue why this is happening.  The wipers continue to run on the dry winshield - which almost caused an accident - this is a very dangerous failure - with Ford not willing to fix unless I pay for a huge amount of investigation time.

 

I have had Fords for many years - still have a Ranger as well.  I can't believe that I bought the very expensive Edge Limited - and Ford will not fix my problems - because I have 55k miles.

 

I think it is time to move to another auto manufacturer that understands computers and software.  My SYNC system is a real pain to work with.

Hi chocobear,

 

Your dealer is a great first step in finding a diagnosis for your wipers. Did you go through with the diagnostic, or did you decline? I can check into some additional assistance.

 

Meagan



#9 OFFLINE   ktilford

ktilford

    New Edge Member

  • Edge Member
  • 3 posts
  • Region:U.S. Southern Atlantic
  • Location:Kevil KY
  • Edge's Year:2013

Posted 17 June 2015 - 08:51 AM

I too have a 2013 Edge with the intermittent wiper issue.  It is dangerous when the wipers continue to come on. I now have 40,000 miles and am out of warranty.  The dealer can check it at $90 an hour but it may not even be doing it when I take it as it is intermittent. Very frustrating when it is barely out of warranty on miles.  This is my second Edge and previously I owned GM products for over 20 years.  Not sure what to do from here.



#10 OFFLINE   omar302

omar302

    Ford Edge Addict

  • Edge Platinum Member
  • 1,632 posts
  • Region:Middle East
  • Location:Qatar
  • Edge's Year:2011

Posted 17 June 2015 - 10:23 AM

Before going to the dealer, I would suggest replacing the wiper switch as suggested in the 2nd post. The switch is only for ~$30.

http://m.ebay.com/itm/111697230173
  • ktilford likes this

#11 OFFLINE   ktilford

ktilford

    New Edge Member

  • Edge Member
  • 3 posts
  • Region:U.S. Southern Atlantic
  • Location:Kevil KY
  • Edge's Year:2013

Posted 17 June 2015 - 10:35 AM

omar302 Thank you so much for this link.  Definitely worth a try!



#12 OFFLINE   AndyinMN

AndyinMN

    New Edge Member

  • Edge Member
  • 5 posts
  • Region:U.S. Great Lakes
  • Location:Minnesota
  • Edge's Year:2011

Posted 14 October 2015 - 12:27 PM

I'm new to this forum but wanted to say that my wipers have started to do the same thing and not turn off.... very annoying...  We bought ours as certified pre-owned and opted for the extended bumper to bumper warranty, will this be covered by this warranty?  If not I see the part is Motorcraft SW-7037.  Will replacing this do the trick and make the wipers stop doing whatever they want?  How hard is to replace this switch, does anyone know is someone has done a write up on how to replace this?



#13 OFFLINE   WWWPerfA_ZN0W

WWWPerfA_ZN0W

    Ford Edge Legal Resident

  • Edge Platinum Member
  • 8,147 posts
  • Region:U.S. Northeast
  • Location:Maryland
  • Edge's Year:Decline

Posted 14 October 2015 - 01:16 PM

I don't see the MFS specifically listed in the CPO warranty, but if nothing else, you could approach it as being a safety concern.Attached File  CPO_Warranty.pdf   239.82KB   8 downloads

 

Not sure what an extended B2B warranty is.  Closest would be PremiumCare ESP, AFAIK.



#14 OFFLINE   ktilford

ktilford

    New Edge Member

  • Edge Member
  • 3 posts
  • Region:U.S. Southern Atlantic
  • Location:Kevil KY
  • Edge's Year:2013

Posted 14 October 2015 - 01:18 PM

My Edge was also a certified pre-owned but did not cover this repair under warranty. 

I did purchase the OEM part on ebay for around $30 and had my local repair guy replace it.  Problem solved for around $50.  I don't think it was a difficult repair but with an airbag I didn't want to attempt it.  



#15 OFFLINE   AndyinMN

AndyinMN

    New Edge Member

  • Edge Member
  • 5 posts
  • Region:U.S. Great Lakes
  • Location:Minnesota
  • Edge's Year:2011

Posted 14 October 2015 - 01:54 PM

I don't see the MFS specifically listed in the CPO warranty, but if nothing else, you could approach it as being a safety concern.attachicon.gifCPO_Warranty.pdf

 

Not sure what an extended B2B warranty is.  Closest would be PremiumCare ESP, AFAIK.

 

I believe it is the PremiumCare warranty we purchased or something similar. I will have to look at our paper work again. 



#16 OFFLINE   enigma-2

enigma-2

    Ford Edge Fanatic

  • Edge Member
  • 2,439 posts
  • Region:U.S. Great Lakes
  • Location:Indiana
  • Edge's Year:2009

Posted 16 October 2015 - 08:26 AM

"Switches, non-electrical mechanical" are specifically covered.

#17 OFFLINE   mohamadsofteng

mohamadsofteng

    New Edge Member

  • Edge Member
  • 6 posts
  • Region:Middle East
  • Location:arbil
  • Edge's Year:2011

Posted 18 January 2016 - 02:35 AM

Good morning everyone

 

for the ones that have this issue with their ford, mine is Ford Edge 2011 AWD SE, I got the same issue and got fixed by replacing the OEM part (the switch) which purchased on ebay, no need to go further details, just replace the switch by yours and that is it, costed 36 USD for me.



#18 OFFLINE   mohamadsofteng

mohamadsofteng

    New Edge Member

  • Edge Member
  • 6 posts
  • Region:Middle East
  • Location:arbil
  • Edge's Year:2011

Posted 18 January 2016 - 02:37 AM

Good morning everyone

 

for the ones that have this issue with their ford, mine is Ford Edge 2011 AWD SE, I got the same issue and got fixed by replacing the OEM part (the switch) which purchased on ebay, no need to go further details, just replace the switch by yours and that is it, costed 36 USD for me.

here is the ebay link that I bought the switch from:

 

http://www.ebay.com/...eFVTnA9&vxp=mtr


  • WWWPerfA_ZN0W likes this

#19 OFFLINE   wiperpro

wiperpro

    New Edge Member

  • Edge Member
  • 2 posts
  • Region:U.S. Northeast
  • Location:new hampshire
  • Edge's Year:2011

Posted 13 March 2016 - 01:47 PM

I have the same problem with my windshield wipers.  Try to shut them entirely off, but the slow intermittent cycle still stays on.  How annoying.  What is the fix.  Can I buy and part and replace it myself.  How have you all solved the problem. Thank you.,  



#20 OFFLINE   omar302

omar302

    Ford Edge Addict

  • Edge Platinum Member
  • 1,632 posts
  • Region:Middle East
  • Location:Qatar
  • Edge's Year:2011

Posted 13 March 2016 - 11:31 PM

I have the same problem with my windshield wipers.  Try to shut them entirely off, but the slow intermittent cycle still stays on.  How annoying.  What is the fix.  Can I buy and part and replace it myself.  How have you all solved the problem. Thank you.,


It seems you missed the post just above yours!





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users