Jump to content

Custom Search

Welcome to the Ford Edge Forum


Sign In  Log in with Facebook

Create Account
Welcome to the Ford Edge Forum - the largest Ford Edge forum discussion board on the web. You must register to create new topics or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Benefits of membership:
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create a photo album and post images. . .and more!
Click here to signup now
 
Guest Message by DevFuse

The official Ford authorized Ford Edge Registry is now live. More here!


Photo
* * * * - 1 votes

Car suddenly won't start - My DIY Mission to resolve

fuel pump electrical wiring starter alternator battery dead flywheel transmission

  • Please log in to reply
25 replies to this topic

#21 OFFLINE   mrtm2016

mrtm2016

    New Edge Member

  • Edge Member
  • 17 posts
  • Region:U.S. Southern Plains
  • Location:Texas
  • Edge's Year:2007

Posted 05 September 2016 - 01:25 AM

Okay. So I replaced the alternator, serpentine belt, and some of the rivets in the flywheel because I broke some with my hammer getting angry learning how to reinstall them...

 

I'll check with the multimeter and post it for you tomorrow.. if i remember correctly it was still reading 13.99 last I checked.









Lose this advertisement by becoming a member. Click here to create a free account.


#22 OFFLINE   WWWPerfA_ZN0W

WWWPerfA_ZN0W

    Ford Edge Legal Resident

  • Edge Platinum Member
  • 8,225 posts
  • Region:U.S. Northeast
  • Location:Maryland
  • Edge's Year:Decline

Posted 05 September 2016 - 06:45 AM

Flywheel?  What's that all about?



#23 OFFLINE   enigma-2

enigma-2

    Ford Edge Fanatic

  • Edge Member
  • 2,515 posts
  • Region:U.S. Great Lakes
  • Location:Indiana
  • Edge's Year:2009

Posted 05 September 2016 - 01:20 PM

Been following this thread, I may have missed it, but did you ever pull the codes? You will definitely get codes for a no-start, what were they?

#24 OFFLINE   macbwt

macbwt

    Ford Edge Fanatic

  • Edge Platinum Member
  • 2,567 posts
  • Region:U.S. Mississippi Valley
  • Location:Davenport Iowa
  • Edge's Year:2011

Posted 05 September 2016 - 06:23 PM

I am confused (officially) so you pulled the engine to change the serpentine belt and then beat on the fly wheel with a hammer and broke some rivets?  I might be wrong in my understanding. I am also going to say the fly wheel most likely has no rivets as it is most presumably bolted on to the engine.   This is going down hill fast I suggest contacting a knowledgeable mechanic friend to assist you.



#25 OFFLINE   fit1446

fit1446

    Ford Edge Member

  • Edge Member
  • 308 posts
  • Region:U.S. Mountain
  • Location:arizona
  • Edge's Year:2010

Posted 05 September 2016 - 07:18 PM


I'm having a hard time believing all this.
  • macbwt likes this

#26 OFFLINE   IWRBB

IWRBB

    New Edge Member

  • Edge Member
  • 238 posts
  • Region:Decline
  • Location:Ohio
  • Edge's Year:2010

Posted 06 September 2016 - 06:53 AM

I think he's talking about the plastic rivets in the wheel well liner- which he probably removed to do the alternator and belt.


  • fit1446 likes this





Also tagged with one or more of these keywords: fuel pump, electrical, wiring, starter, alternator, battery, dead, flywheel, transmission

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users