Jump to content

Custom Search

Welcome to the Ford Edge Forum


Sign In  Log in with Facebook

Create Account
Welcome to the Ford Edge Forum - the largest Ford Edge forum discussion board on the web. You must register to create new topics or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Benefits of membership:
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create a photo album and post images. . .and more!
Click here to signup now
 
Guest Message by DevFuse

The official Ford authorized Ford Edge Registry is now live. More here!


Photo
- - - - -

"Grabby" brakes...


  • Please log in to reply
21 replies to this topic

#21 OFFLINE   DougS

DougS

    New Edge Member

  • Edge Member
  • 43 posts
  • Region:U.S. Northeast
  • Location:Ohio
  • Edge's Year:2015

Posted 04 December 2016 - 02:56 PM

Yep, when I talked to the service manager on Friday, he wanted me to see how it does over the weekend, but so far it is still the same. I'll be calling him Monday to schedule it in.


Edited by DougS, 04 December 2016 - 02:57 PM.








Lose this advertisement by becoming a member. Click here to create a free account.


#22 OFFLINE   DougS

DougS

    New Edge Member

  • Edge Member
  • 43 posts
  • Region:U.S. Northeast
  • Location:Ohio
  • Edge's Year:2015

Posted 08 December 2016 - 02:29 PM

Well, I dropped off my Edge yesterday to the dealer, and he called me a little bit ago and said they confirmed the hard pedal this morning. They checked out everything and could not find an issue, so they are ordering another new brake booster. Maybe I should of just put up with the grabby brakes throughout my 3 year lease, it has already been over a year. Hopefully this doesn't become an ongoing issue. :(






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users