Jump to content

Custom Search

Welcome to the Ford Edge Forum


Sign In  Log in with Facebook

Create Account
Welcome to the Ford Edge Forum - the largest Ford Edge forum discussion board on the web. You must register to create new topics or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Benefits of membership:
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create a photo album and post images. . .and more!
Click here to signup now
 
Guest Message by DevFuse

The official Ford authorized Ford Edge Registry is now live. More here!


Photo
- - - - -

2010 Edge electrical issues.

seat mirror battery

  • Please log in to reply
2 replies to this topic

#1 OFFLINE   Phillip Thirion

Phillip Thirion

    New Edge Member

  • Facebook Member
  • 1 posts

Posted 03 October 2016 - 02:12 PM

I have a 2010 Edge Limited. The night before last I drove around with no issues, nor have I had any electrical issues in the past. Yesterday my wife and her friend go to the store, and my wife tells me it strained a little to start, like a low battery. Last night I tried to start, and it would not start at all, just clicks. I pushed it out of the garage and jumped it off, drove to the back yard to my shop and let it run for about 30 min. In this time I hooked up my little computer and it was showing no codes saying any problems. I then noticed that the drivers seat was not working and neither were the power mirrors. Everything else seams to be working normal. I backed it back into her garage and parked it overnight. This morning I started it up, drove to to the store and got a new battery. (testing showed it was bad). I swapped battery, left it unhooked fore about 5 min. Still same thing.

 

So battery keeps draining (slowly), drivers power seat not working, as well as the memory controls, and power mirrors not working. I am going to look at it more this evening, but does anyone have any ideas?

 

Thanks,

Phillip









Lose this advertisement by becoming a member. Click here to create a free account.


#2 OFFLINE   akirby

akirby

    Ford Edge Legal Resident

  • Moderator
  • 10,141 posts

Posted 03 October 2016 - 03:07 PM

Did you check the fuses?



#3 OFFLINE   enigma-2

enigma-2

    Ford Edge Fanatic

  • Edge Member
  • 2,515 posts
  • Region:U.S. Great Lakes
  • Location:Indiana
  • Edge's Year:2009

Posted 03 October 2016 - 04:05 PM

Did you have the alternator checked? Good battery can't stay charged with a bad alternator or regulator.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users