Jump to content

Custom Search

Welcome to the Ford Edge Forum


Sign In  Log in with Facebook

Create Account
Welcome to the Ford Edge Forum - the largest Ford Edge forum discussion board on the web. You must register to create new topics or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Benefits of membership:
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create a photo album and post images. . .and more!
Click here to signup now
 
Guest Message by DevFuse

The official Ford authorized Ford Edge Registry is now live. More here!


Photo
- - - - -

2011 ford edge sport 3.7l


  • Please log in to reply
No replies to this topic

#1 OFFLINE   Mangoman

Mangoman

    New Edge Member

  • Edge Member
  • 2 posts
  • Region:Canada Prairie Provinces
  • Location:Calgary
  • Edge's Year:2011

Posted 20 January 2017 - 11:26 AM

I am having headlight issues. First the driver side bulb went out and I'm thinking about changing over to hids. I've order the new lights should be here soon. But as I was waiting for the lights to arrive the one light that was working has started to turn on and off by it self. Switching from high beam to low beam. I am getting a light on my dashboard when the light kicks on n off. What is the problem?
  • dieselnewt likes this







Lose this advertisement by becoming a member. Click here to create a free account.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users