Jump to content

Custom Search

Photo
- - - - -

Titanium 2016 - Interior quesiton


  • Please log in to reply
13 replies to this topic

#1 t0lkman

t0lkman

    New Edge Member

  • Edge Member
  • 185 posts
  • Region:U.S. Pacific Coast
  • Location:San Jose
  • Edge's Year:None

Posted 26 March 2017 - 02:19 AM

1) Do you also all have different shade of the plastic trim color?

2) Is the cover where the USB connectors also not aligned properly? (see attachments)

 

 

 

P.S. Can you please post yours?

Attached Files


Edited by t0lkman, 26 March 2017 - 02:19 AM.








Lose this advertisement by becoming a member. Click here to create a free account.


#2 Burrcold

Burrcold

    Ford Edge Member

  • Edge Platinum Member
  • 418 posts
  • Region:Canada Ontario
  • Location:Toronto
  • Edge's Year:2016

Posted 26 March 2017 - 06:03 AM

I've seen that on almost every Edge (Titanium or Sport) in varying degrees of color mismatch and alignment. Mine is actually pretty good, but it looks like you got one on the poor end of the scale. I do find that pictures show the problem even more (kind of like mismatch color on various panels of the exterior).

#3 gary255

gary255

    New Edge Member

  • Edge Member
  • 12 posts
  • Region:U.S. Great Lakes
  • Location:Michigan
  • Edge's Year:2016

Posted 26 March 2017 - 07:25 AM

My cover alignment is the same. Must be the norm.



#4 haedgy

haedgy

    New Edge Member

  • Edge Member
  • 86 posts
  • Region:U.S. Pacific Coast
  • Location:Bay Area
  • Edge's Year:2016

Posted 26 March 2017 - 08:50 AM

Think it's the norm, mine is similar don't really notice it as an issue. I have a feeling the way it opens if it was even with the top it may not open correctly. Could just be the way it is who knows.

As long as it doesn't rattle which I hear is a problem with the center console in various areas.



#5 t0lkman

t0lkman

    New Edge Member

  • Edge Member
  • 185 posts
  • Region:U.S. Pacific Coast
  • Location:San Jose
  • Edge's Year:None

Posted 26 March 2017 - 02:58 PM

Thanks for the responses, yes, it doesn't rattle.

 

Can you please post pictrures when you have a chance?



#6 Burrcold

Burrcold

    Ford Edge Member

  • Edge Platinum Member
  • 418 posts
  • Region:Canada Ontario
  • Location:Toronto
  • Edge's Year:2016

Posted 27 March 2017 - 09:06 AM

Here is mine.  Again I don't think any of them are perfect, but the coloring and alignment is really hit or miss (I don't think mine is too bad considering).

 

 

Attached Files


  • PaulSchott and t0lkman like this

#7 PaulSchott

PaulSchott

    Ford Edge Member

  • Edge Member
  • 415 posts
  • Region:U.S. Northeast
  • Location:Connecticut
  • Edge's Year:2007

Posted 27 March 2017 - 07:06 PM

yours looks good compared to 10kman's



#8 t0lkman

t0lkman

    New Edge Member

  • Edge Member
  • 185 posts
  • Region:U.S. Pacific Coast
  • Location:San Jose
  • Edge's Year:None

Posted 27 March 2017 - 10:24 PM

Do you think the dealer would agree to fix/replace it?



#9 t0lkman

t0lkman

    New Edge Member

  • Edge Member
  • 185 posts
  • Region:U.S. Pacific Coast
  • Location:San Jose
  • Edge's Year:None

Posted 28 March 2017 - 12:43 AM

Any one else can post few more photos?



#10 Burrcold

Burrcold

    Ford Edge Member

  • Edge Platinum Member
  • 418 posts
  • Region:Canada Ontario
  • Location:Toronto
  • Edge's Year:2016

Posted 28 March 2017 - 06:12 AM

Just google pictures. Here's one from an Edge that's for sale.

new-and-used-auto-new-2016-ford-edge-128
  • t0lkman likes this

#11 Burrcold

Burrcold

    Ford Edge Member

  • Edge Platinum Member
  • 418 posts
  • Region:Canada Ontario
  • Location:Toronto
  • Edge's Year:2016

Posted 28 March 2017 - 06:18 AM

Here's one where the color seems okay but the fit is bad.

automobiles-new-2017-ford-edge-1399067-c
  • t0lkman likes this

#12 Burrcold

Burrcold

    Ford Edge Member

  • Edge Platinum Member
  • 418 posts
  • Region:Canada Ontario
  • Location:Toronto
  • Edge's Year:2016

Posted 28 March 2017 - 06:22 AM

Good fit but bad color match. See it's very hit or miss. Unfortunately it looks like you got hit with both issues. Just bring it in and show them pictures and ask for a replacement.

2016-Ford-EDGE-AWD-Titanium-1.jpg
  • t0lkman likes this

#13 2FAST4U

2FAST4U

    New Edge Member

  • Edge Member
  • 142 posts
  • Region:Canada Quebec
  • Location:Saint-Eustache
  • Edge's Year:2016

Posted 08 February 2018 - 10:38 PM

1) Do you also all have different shade of the plastic trim color?

2) Is the cover where the USB connectors also not aligned properly? (see attachments)

 

 

 

P.S. Can you please post yours?

 

The alignment of the USB door is good in my '16 Titanium but there was indeed a slight difference in color between the console panels so I bought and installed some gloss black covers ( should've been factory installed, BTW…) which perfectly match the lower part of the console. Not only it looks better, but it solved the unmatching color problem.  :idea:

 

Claude. ;)



#14 Further North

Further North

    New Edge Member

  • Edge Member
  • 51 posts
  • Region:U.S. Great Lakes
  • Location:NW WI
  • Edge's Year:2016

Posted 11 April 2018 - 09:30 PM

In the world of color, anything under a Delta Error of 2.0 (normally shown as 2.0 ΔE) is commercially acceptable...what we're seeing here (allowing for different digital cameras) is well inside that.  Pastels and greys show variation more than other colors...

 

There ain't no such thing as perfect color match and anyone who thinks there is, isn't living in the real world.  Grays are particularly hard to match; as a neutral color, even the slightest difference in shade jumps out at us, and even subtle differences well under 2.0 ΔE can be seen by people with normal color vision.

 

...that's the long way of saying I'd be surprised if Ford did anything about this.  As a printer, I would not.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users