Jump to content

Custom Search

Welcome to the Ford Edge Forum


Sign In  Log in with Facebook

Create Account
Welcome to the Ford Edge Forum - the largest Ford Edge forum discussion board on the web. You must register to create new topics or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Benefits of membership:
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create a photo album and post images. . .and more!
Click here to signup now
 
Guest Message by DevFuse

The official Ford authorized Ford Edge Registry is now live. More here!


Photo
- - - - -

Forced 08 Edge Vista roof closed uhoh!


  • Please log in to reply
2 replies to this topic

#1 OFFLINE   Dutchharleygirl67

Dutchharleygirl67

    New Edge Member

  • Edge Member
  • 1 posts
  • Region:U.S. Southern Plains
  • Location:Texas
  • Edge's Year:2008

Posted 18 April 2017 - 11:37 AM

Hello all!
Wish I would have read how fast Vista roof is supposed to open so I could have addressed problem earlier.
I was driving and came upon severe weather. Tried to close Vista roof it wouldn't close. Torrential downpour so while holding close button I forced it with other hand to close (sorta) it closed the gap but is not down in the sealed position. How can I fix this? Praying I didn't completely mess it up.







Lose this advertisement by becoming a member. Click here to create a free account.


#2 OFFLINE   fit1446

fit1446

    Ford Edge Member

  • Edge Member
  • 308 posts
  • Region:U.S. Mountain
  • Location:arizona
  • Edge's Year:2010

Posted 18 April 2017 - 12:09 PM

Hello all!
Wish I would have read how fast Vista roof is supposed to open so I could have addressed problem earlier.
I was driving and came upon severe weather. Tried to close Vista roof it wouldn't close. Torrential downpour so while holding close button I forced it with other hand to close (sorta) it closed the gap but is not down in the sealed position. How can I fix this? Praying I didn't completely mess it up.

 

you need to open the glass back all the way,clean and lube tracks.i personally at this point would remove the glass.i have done this personally several times on my gen 1.if you need help..bill trammel has a fb group called mactforedge. he has made several videos on youtube one of which is on removing the vista glass and cleaning all parts and lubing. then u need to re initialize to set correctly in track.


  • WWWPerfA_ZN0W likes this

#3 OFFLINE   autom8r

autom8r

    New Edge Member

  • Edge Platinum Member
  • 278 posts
  • Region:U.S. Pacific Coast
  • Location:The 'OC'
  • Edge's Year:2008

Posted 18 April 2017 - 08:02 PM

This solution worked for mine.

 

http://www.fordedgef...nitialize +roof

 

 

 


  • WWWPerfA_ZN0W likes this




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users