Jump to content

Custom Search

Welcome to the Ford Edge Forum


Sign In  Log in with Facebook

Create Account
Welcome to the Ford Edge Forum - the largest Ford Edge forum discussion board on the web. You must register to create new topics or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Benefits of membership:
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create a photo album and post images. . .and more!
Click here to signup now
 
Guest Message by DevFuse

The official Ford authorized Ford Edge Registry is now live. More here!


Photo
- - - - -

Exhaust Smell in Cabin


  • Please log in to reply
3 replies to this topic

#1 OFFLINE   ezndo

ezndo

    New Edge Member

  • Edge Member
  • 21 posts
  • Region:Decline
  • Location:In front of you
  • Edge's Year:Decline

Posted 16 July 2017 - 02:00 PM

2016 Edge Sport - only get the smell under hard acceleration when in recirculation mode which is typical of the TSB. Dealer fix is to remove rear bumper and rear spoiler then epoxy all the seams plus reprogram PCM to turn off recirculation automatically for 10 secs after hard acceleration. Anyone done it yet and if so, happy?







Lose this advertisement by becoming a member. Click here to create a free account.


#2 OFFLINE   edge_st

edge_st

    New Edge Member

  • Edge Member
  • 21 posts
  • Region:Decline
  • Location:IA
  • Edge's Year:Decline

Posted 01 August 2017 - 09:47 AM

Can you please tell the TSB number for this?

#3 OFFLINE   clegg78

clegg78

    New Edge Member

  • Edge Member
  • 13 posts
  • Region:Decline
  • Location:Denver, CO
  • Edge's Year:2017

Posted 23 August 2017 - 12:18 AM

I am also having this issue with our new 2017... havent taken it to the dealer yet as most of what I read sound like hack fixes. 



#4 OFFLINE   akirby

akirby

    Ford Edge Legal Resident

  • Moderator
  • 9,969 posts

Posted 23 August 2017 - 08:38 AM

I don't have an exhaust smell but it does sound like there is an exhaust leak when the engine is cold.   Will have the dealer look at it on the next service.


  • WWWPerfA_ZN0W likes this




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users