Jump to content

Custom Search

Welcome to the Ford Edge Forum


Sign In  Log in with Facebook

Create Account
Welcome to the Ford Edge Forum - the largest Ford Edge forum discussion board on the web. You must register to create new topics or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Benefits of membership:
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create a photo album and post images. . .and more!
Click here to signup now
 
Guest Message by DevFuse

The official Ford authorized Ford Edge Registry is now live. More here!


Photo
- - - - -

Broken Wiper Motor 1,700 miles


  • Please log in to reply
2 replies to this topic

#1 OFFLINE   ezndo

ezndo

    New Edge Member

  • Edge Member
  • 23 posts
  • Region:Decline
  • Location:In front of you
  • Edge's Year:Decline

Posted 11 October 2017 - 04:36 PM

Anyone else have this? 2016 Sport. To top it off, this wiper motor was replaced according to my paperwork 2 months and 300 mi ago. Car has been in storage since then, so never bothered to see if it was replaced, never had occasion to use wipers either. Noticed movement in the mount when I was washing car yesterday. I'm sure the dealer will blame it on me when I go in next week.

Attached Files









Lose this advertisement by becoming a member. Click here to create a free account.


#2 OFFLINE   omar302

omar302

    Ford Edge Addict

  • Edge Platinum Member
  • 1,632 posts
  • Region:Middle East
  • Location:Qatar
  • Edge's Year:2011

Posted 11 October 2017 - 10:53 PM

Just take it back to the dealer & tell them the wipers are not working properly. Don't point to the broken motor, let them just fix it.


  • WWWPerfA_ZN0W likes this

#3 OFFLINE   ezndo

ezndo

    New Edge Member

  • Edge Member
  • 23 posts
  • Region:Decline
  • Location:In front of you
  • Edge's Year:Decline

Posted 12 October 2017 - 07:01 AM

Did that already. Paperwork from that appointment states both wiper arms and both wiper motors were replaced. There is no way they replaced the broken motor at that appointment because wipers haven't been used since that motor was "replaced".




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users