Jump to content

Custom Search

Photo
- - - - -

engine swap ford edge


  • Please log in to reply
3 replies to this topic

#1 colorado

colorado

    New Edge Member

  • Edge Member
  • 8 posts
  • Region:Canada Atlantic Provinces
  • Location:memramcook
  • Edge's Year:2008

Posted 01 December 2017 - 11:11 PM

ok, decided to change my engine because my phaser where damage and the engine got 334000 km on it. the problem is that i notice that the engine they sold me is from a ford taurus 2010, look the same but no oil cooler on engine and wiring is different. they told me it the same thing. so if i remove my original wiring and put it on the engine without the oil cooler and just bypass the 2 oil cooler hose. would that work. right now both engine are on the floor. hope it would work. thanks for any help









Lose this advertisement by becoming a member. Click here to create a free account.


#2 WWWPerfA_ZN0W

WWWPerfA_ZN0W

    Ford Edge Legal Resident

  • Edge Platinum Member
  • 8,934 posts
  • Region:U.S. Northeast
  • Location:Maryland
  • Edge's Year:Decline

Posted 03 December 2017 - 06:35 AM

Yes, it should work if you transfer over the wiring, and bypass the oil cooler.  You can get the appropriate non-cooler adapter for your Edge if you so wish.  Also confirm that there is only 1 VCT solenoid per bank, indicating it is a VCT and not a TiVCT engine.

 

How many miles on the "new" engine?  You might consider changing the plugs, PCV valve at a minimum while you have it on the floor/stand.  With enough mileage, I would replace the water pump and possibly the timing components before installation.


  • onyxbfly and Mikula like this

#3 Waldo

Waldo

    Ford Edge Enthusiast

  • Edge Member
  • 1,031 posts

Posted 04 December 2017 - 09:35 AM

I agree it should be the same thing.  Taurus didn't get the TiVCT update until the 2013 model year.  You should be able to move your oil cooler to the new engine as well.


  • WWWPerfA_ZN0W likes this

#4 colorado

colorado

    New Edge Member

  • Edge Member
  • 8 posts
  • Region:Canada Atlantic Provinces
  • Location:memramcook
  • Edge's Year:2008

Posted 05 December 2017 - 02:13 PM

for the oil cooler, the other engine has a 3 bolt attachment instead of a 1 bolt like my edge. also, my engine is in the car, when i came to installed the alternator, it look crooked when i look at the engine, tried many thing to make it straight but no luck, the belt look a little bit off too, that alternator only goes in one way, no play for adjustment. any idea what going on. thank guys, appreciate the help.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users