Jump to content

Custom Search

Welcome to the Ford Edge Forum


Sign In  Log in with Facebook

Create Account
Welcome to the Ford Edge Forum - the largest Ford Edge forum discussion board on the web. You must register to create new topics or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Benefits of membership:
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create a photo album and post images. . .and more!
Click here to signup now
 
Guest Message by DevFuse

Check out the Ford Edge ST Forum Here
 


Photo
- - - - -

Official Release of V3.0 for SYNC3 Has Begun


  • Please log in to reply
70 replies to this topic

#1 ONLINE   jmr061

jmr061

    Ford Edge Member

  • Edge Member
  • 354 posts
  • Region:U.S. Great Lakes
  • Location:Upper Midwest
  • Edge's Year:2016

Posted 18 March 2018 - 04:44 PM

Check your owner site to see if you have an update pending.  Not all vehicles may have it yet.









Lose this advertisement by becoming a member. Click here to create a free account.


#2 OFFLINE   bamabob

bamabob

    New Edge Member

  • Edge Member
  • 49 posts
  • Region:U.S. Southern Atlantic
  • Location:Alabama
  • Edge's Year:2016

Posted 18 March 2018 - 06:03 PM

Thanks, looks like it's available for my Edge.  I'd like to know what is different, sometimes if it aint' broke don't fix it.  My sync V 2.2 is running pretty good and doing what I need.  I think I'll wait until we get some feedback.  Ford owner site not very specific about what the update does.

 

img0_7.jpg



#3 OFFLINE   ben senise

ben senise

    New Edge Member

  • Edge Member
  • 163 posts
  • Region:Canada British Columbia
  • Location:Victoria, BC
  • Edge's Year:2016

Posted 18 March 2018 - 07:10 PM

interesting. the unofficial zip file i downloaded a while back was JL1T-14G381-AJ. The one available to me on the ford website is now JL3T-14G381-AJ. I wonder how much of a difference there is.

 

thanks jmr061



#4 ONLINE   jmr061

jmr061

    Ford Edge Member

  • Edge Member
  • 354 posts
  • Region:U.S. Great Lakes
  • Location:Upper Midwest
  • Edge's Year:2016

Posted 18 March 2018 - 07:18 PM

interesting. the unofficial zip file i downloaded a while back was JL1T-14G381-AJ. The one available to me on the ford website is now JL3T-14G381-AJ. I wonder how much of a difference there is.

 

thanks jmr061

JL1T was V2.3



#5 ONLINE   jmr061

jmr061

    Ford Edge Member

  • Edge Member
  • 354 posts
  • Region:U.S. Great Lakes
  • Location:Upper Midwest
  • Edge's Year:2016

Posted 18 March 2018 - 07:37 PM

Also are you sure its JL3T you are seeing for 3.0 and not JR3T?



#6 OFFLINE   onyxbfly

onyxbfly

    New Edge Member

  • Edge Member
  • 227 posts
  • Region:U.S. Northeast
  • Location:Somewhere between 1s and 0s
  • Edge's Year:2017

Posted 19 March 2018 - 05:03 AM

I'm glad they are doing direct updates via usb. I could not get sync to update with wifi at all. It would start then fail.. Ironically enough the only update that was available was 2.3.  Hopefully I'll be able to get 3.0 sooner or later. 


  • WWWPerfA_ZN0W likes this

#7 OFFLINE   ben senise

ben senise

    New Edge Member

  • Edge Member
  • 163 posts
  • Region:Canada British Columbia
  • Location:Victoria, BC
  • Edge's Year:2016

Posted 19 March 2018 - 10:36 AM

JL1T was V2.3

 

ah. i may have made a mistake. don't know why i have the 2.3 update zip file on my PC. thanks for letting me know.



#8 OFFLINE   RetiredgE

RetiredgE

    New Edge Member

  • Edge Member
  • 22 posts
  • Region:U.S. Southern Atlantic
  • Location:United States
  • Edge's Year:2016

Posted 19 March 2018 - 10:41 AM

And I had already updated to 3.0, v18025 from an earlier post and when I downloaded the "official" 3.0 from Ford Owner site, went to update and system told me I already had the most current version. So, nothing changed from earlier? Interesting.



#9 OFFLINE   lildisco

lildisco

    Ford Edge Member

  • Edge Member
  • 325 posts
  • Region:U.S. Great Lakes
  • Location:Clevelandish
  • Edge's Year:2016

Posted 19 March 2018 - 11:01 AM

Owner.ford.com shows Sync V3.0 available for download

Attached Files


  • WWWPerfA_ZN0W likes this

#10 OFFLINE   1004ron

1004ron

    New Edge Member

  • Edge Member
  • 218 posts
  • Region:Decline
  • Location:Louisville, KY
  • Edge's Year:2017

Posted 19 March 2018 - 02:46 PM

 

 

What's included in this update?
JR3T-14G381-AL SYNC3 v3.0

 

This software release is the latest update in our continued efforts to improve system performance, device connectivity, and the overall SYNC experience.

This software contains all previous enhancements, so there is no need to install any other updates. The installation of this update will take up to 60 minutes to complete. DO NOT remove your USB drive or turn off your vehicle. You must wait until Installation Complete is displayed on the center screen before removing your drive or turning your vehicle off.

While the update is loading, SYNC will not recognize your mobile phone or media device. Be sure your vehicle engine is running (not in accessory mode) throughout the entire installation process. Although your vehicle must be in park when you initiate the installation process, once the download process has begun, you may drive your vehicle.

 

 

For the 2.3 update I left my engine running - this requirement is crazy, and I'll give it a try with just the ignition on.



#11 OFFLINE   bamabob

bamabob

    New Edge Member

  • Edge Member
  • 49 posts
  • Region:U.S. Southern Atlantic
  • Location:Alabama
  • Edge's Year:2016

Posted 19 March 2018 - 03:01 PM

I checked this morning to see what version I have and it showed 2.2.  I then clicked on "check for updates" and a bar showed an update in progress, around 20% complete.  I guess it's updating automatically while by vehicle is parked at work.  It's connected to my workplace wifi.  I checked it later and now it's showing around 80% complete.  Don't know what version it's updating to, I assume V 3.0



#12 OFFLINE   Quila

Quila

    New Edge Member

  • Edge Member
  • 46 posts
  • Region:Canada British Columbia
  • Location:Vancouver
  • Edge's Year:2016

Posted 19 March 2018 - 03:09 PM

 

For the 2.3 update I left my engine running - this requirement is crazy, and I'll give it a try with just the ignition on.

 

I think the reason they say to leave the engine running is that the accessory power will not stay on for 30 minutes without the engine running.  If Sync3 shuts down during an update, that could result in a botched update.  You can still drive while the update is in progress, it just needs to be in park to start the update.  Once the update is started, you can drive the vehicle.  Ideally, start the update just before a 30+ minute drive.



#13 OFFLINE   bamabob

bamabob

    New Edge Member

  • Edge Member
  • 49 posts
  • Region:U.S. Southern Atlantic
  • Location:Alabama
  • Edge's Year:2016

Posted 19 March 2018 - 05:41 PM

Well, my update completed via Wifi, version 2.3.  I guess updates via wifi are delayed as opposed to USB updates.



#14 OFFLINE   t0lkman

t0lkman

    New Edge Member

  • Edge Member
  • 167 posts
  • Region:U.S. Pacific Coast
  • Location:San Jose
  • Edge's Year:None

Posted 19 March 2018 - 07:30 PM

I used 8gb flash drive.. and it's already 70 minutes being updated... I'm not sure it's stuck or there any progress... just keep waiting



#15 OFFLINE   1004ron

1004ron

    New Edge Member

  • Edge Member
  • 218 posts
  • Region:Decline
  • Location:Louisville, KY
  • Edge's Year:2017

Posted 19 March 2018 - 07:56 PM

I just updated mine using a 4GB USB stick - it took 25 minutes and I just kept the engine idling with my garage door open.

 

I cant detect any changes.


Edited by 1004ron, 19 March 2018 - 08:01 PM.


#16 OFFLINE   t0lkman

t0lkman

    New Edge Member

  • Edge Member
  • 167 posts
  • Region:U.S. Pacific Coast
  • Location:San Jose
  • Edge's Year:None

Posted 19 March 2018 - 08:19 PM

8gb flash drive - took 90 minutes ;[

 

did you notice any interesting new change/update?



#17 OFFLINE   pintokid

pintokid

    New Edge Member

  • Edge Member
  • 23 posts
  • Region:U.S. Southern Atlantic
  • Location:Apex, NC
  • Edge's Year:2017

Posted 20 March 2018 - 11:53 AM

I downloaded the 3.0 update but I can't get the car to recognize the USB stick. I have formatted it every way I could think and nothing at all. I'll stop at the store and get a new one later. Funny, but the 2.3 update went on like a charm, but using a different USB stick.



#18 ONLINE   jmr061

jmr061

    Ford Edge Member

  • Edge Member
  • 354 posts
  • Region:U.S. Great Lakes
  • Location:Upper Midwest
  • Edge's Year:2016

Posted 20 March 2018 - 11:55 AM

It can take 10 mins or a bit more before the update actually begins.

#19 OFFLINE   FordGuy1

FordGuy1

    New Edge Member

  • Edge Member
  • 48 posts
  • Region:U.S. Southern Atlantic
  • Location:SC
  • Edge's Year:2017

Posted 20 March 2018 - 12:07 PM

Updated my 2017 Ford Edge Titanium today to revision V3.0 using a USB stick. Installation took about 18 minutes.

 

Fixed - When using a USB to play MP3 the display of source's now shows the actual USB name instead of the long multi character name.

             The indexing seemed a lot faster and upon several restarts the music played starting where it left off.

 

UnFixed - It still takes about 12 minutes to reindex the USB each time there is a restart even though the USB plays the songs OK. I have the same type USB and exact number of songs and playlists on my 2014 Ford Taurus with Sync2 MFT and it only takes about 1 minute for the reindex upon a restart. (3600 songs)



#20 OFFLINE   1004ron

1004ron

    New Edge Member

  • Edge Member
  • 218 posts
  • Region:Decline
  • Location:Louisville, KY
  • Edge's Year:2017

Posted 20 March 2018 - 01:30 PM

The only thing I detect different is the WifI notice on every start - I'll just go and disable WiFi in the settings.

Attached Files


Edited by 1004ron, 20 March 2018 - 01:32 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users