Jump to content

Custom Search

Welcome to the Ford Edge Forum


Sign In  Log in with Facebook

Create Account
Welcome to the Ford Edge Forum - the largest Ford Edge forum discussion board on the web. You must register to create new topics or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Benefits of membership:
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create a photo album and post images. . .and more!
Click here to signup now
 
Guest Message by DevFuse

Check out the Ford Edge ST Forum Here
 


Photo
- - - - -

2012 Edge SEL Wipers Not Turning Off Right Away...


Best Answer goslats , 21 May 2018 - 06:25 PM

Oh Yeah,   issue resolved.  And got to say this is truly a GREAT board!   I go on other boards for many DIY and other stuff, and this board does truly get to the point to help troubleshoot the problem and resolve it.   Thank you folks!

Go to the full post


  • Please log in to reply
7 replies to this topic

#1 OFFLINE   goslats

goslats

    New Edge Member

  • Edge Member
  • 45 posts
  • Region:U.S. Southern Atlantic
  • Location:Orlando
  • Edge's Year:2012

Posted 14 May 2018 - 05:58 PM

  Like the title says ...the wipers turned to "Off" will stay on most of the time.  If we wiggle, turn to high and the off or sometimes hit the washer button and then off it will turn of, but getting worse.  I'm pretty sure it's a contact in the control.  Anybody have a clue as to what to do?  Thanks









Lose this advertisement by becoming a member. Click here to create a free account.


#2 OFFLINE   omar302

omar302

    Ford Edge Addict

  • Edge Platinum Member
  • 1,882 posts
  • Region:Middle East
  • Location:Qatar
  • Edge's Year:2016

Posted 14 May 2018 - 11:12 PM

Change the wiper switch (stalk). It is quite easy & relatively cheap (~$30).

 

This thread has good info. Search YouTube & you'll probably find a how to video. Videos for the Ford Explorer (2011-2015) are similar to the Edge. Also the procedure is similar to replacing the Turn Signal switch.


  • WWWPerfA_ZN0W likes this

#3 OFFLINE   goslats

goslats

    New Edge Member

  • Edge Member
  • 45 posts
  • Region:U.S. Southern Atlantic
  • Location:Orlando
  • Edge's Year:2012

Posted 15 May 2018 - 03:50 PM

Thanks.  That thread says it all.  I cant figure out what all these tell me though.  Not sure which one to look for..

Mine is a 2012 Edge SLE...I think  LOL

manual tilt column.   Is the "speed sensitive....intermittent...variable speed?  

 

 

 

 

17A553 (SW-6963)

Window Wiper Switch

With Manual Tilt/Slide Stg Column ; Speed Sensitive Windscreen Wipers; Black

Vehicle Build Date before: 5/31/2013

 

17A553 (SW-6964)

Window Wiper Switch

With Manual Tilt/Slide Stg Column ; Rain Sensitive Windshield Wipers; Black

or

With Power Tilt/Telescopic Strg Column

 

17A553 (SW-7037)

Window Wiper Switch

With Manual Tilt/Slide Stg Column ; Speed Sensitive Windscreen Wipers; Black

Vehicle Build Date after: 6/1/2013



#4 OFFLINE   WWWPerfA_ZN0W

WWWPerfA_ZN0W

    Ford Edge Legal Resident

  • Edge Platinum Member
  • 8,792 posts
  • Region:U.S. Northeast
  • Location:Maryland
  • Edge's Year:Decline

Posted 15 May 2018 - 05:55 PM

If you have rain sensing wipers, you want SW6964.  Otherwise you want SW6963.



#5 OFFLINE   goslats

goslats

    New Edge Member

  • Edge Member
  • 45 posts
  • Region:U.S. Southern Atlantic
  • Location:Orlando
  • Edge's Year:2012

Posted 16 May 2018 - 07:53 AM

Ok....Got it Thanks!



#6 OFFLINE   goslats

goslats

    New Edge Member

  • Edge Member
  • 45 posts
  • Region:U.S. Southern Atlantic
  • Location:Orlando
  • Edge's Year:2012

Posted 17 May 2018 - 04:16 PM

Thanks everybody.  Changed it today and only took 10-15 minutes.  


  • WWWPerfA_ZN0W likes this

#7 OFFLINE   WWWPerfA_ZN0W

WWWPerfA_ZN0W

    Ford Edge Legal Resident

  • Edge Platinum Member
  • 8,792 posts
  • Region:U.S. Northeast
  • Location:Maryland
  • Edge's Year:Decline

Posted 18 May 2018 - 06:54 AM

Let us know if it resolves the issue :)



#8 OFFLINE   goslats

goslats

    New Edge Member

  • Edge Member
  • 45 posts
  • Region:U.S. Southern Atlantic
  • Location:Orlando
  • Edge's Year:2012

Posted 21 May 2018 - 06:25 PM   Best Answer

Oh Yeah,   issue resolved.  And got to say this is truly a GREAT board!   I go on other boards for many DIY and other stuff, and this board does truly get to the point to help troubleshoot the problem and resolve it.   Thank you folks!


  • WWWPerfA_ZN0W likes this




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users