Jump to content

Custom Search

Welcome to the Ford Edge Forum


Sign In  Log in with Facebook

Create Account
Welcome to the Ford Edge Forum - the largest Ford Edge forum discussion board on the web. You must register to create new topics or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Benefits of membership:
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create a photo album and post images. . .and more!
Click here to signup now
 
Guest Message by DevFuse

Photo
- - - - -

Liftgate Weatherstrip Defects?


  • Please log in to reply
7 replies to this topic

#1 ONLINE   omar302

omar302

    Ford Edge Addict

  • Edge Platinum Member
  • 1,906 posts
  • Region:Middle East
  • Location:Qatar
  • Edge's Year:2016

Posted 12 June 2018 - 08:33 AM

Could someone with a 2015+ Edge confirm if this is normal or not? The weatherstrip for the lift gate has 2 places were it seems like a small piece is cut off. This is on the outer edge. Please see the photos. 1 cut is at the bottom right the other is at the left tailight.

Attached Files









Lose this advertisement by becoming a member. Click here to create a free account.


#2 OFFLINE   enigma-2

enigma-2

    Ford Edge Fanatic

  • Edge Member
  • 3,071 posts
  • Region:U.S. Great Lakes
  • Location:Indiana
  • Edge's Year:2009

Posted 12 June 2018 - 06:01 PM

What possible purpose would it serve? Just judging by looking at the photos, it looks like it was ripped out.

#3 OFFLINE   lildisco

lildisco

    Ford Edge Member

  • Edge Member
  • 342 posts
  • Region:U.S. Great Lakes
  • Location:Clevelandish
  • Edge's Year:2016

Posted 12 June 2018 - 06:29 PM

I'd say normal. 2016 SEL

Attached Files


  • WWWPerfA_ZN0W and omar302 like this

#4 ONLINE   omar302

omar302

    Ford Edge Addict

  • Edge Platinum Member
  • 1,906 posts
  • Region:Middle East
  • Location:Qatar
  • Edge's Year:2016

Posted 13 June 2018 - 03:58 AM

@lildisco
Thanks for the pictures, do you get the exhaust odor under hard acceleration with climate on recirculating?

Also, it seems the cut-offs on your liftgate are symmetrical on both sides? Location is not very clear on the first pic.

Can someone else confirm? Especially on a year other than 2016? Maybe a bad batch?

Edited by omar302, 13 June 2018 - 04:29 AM.


#5 OFFLINE   lildisco

lildisco

    Ford Edge Member

  • Edge Member
  • 342 posts
  • Region:U.S. Great Lakes
  • Location:Clevelandish
  • Edge's Year:2016

Posted 13 June 2018 - 06:07 AM

Never get exhaust smell inside on any acceleration & recirculating. 1st pic is drivers side 2nd is passenger side. Both are approximately same location on each side of the hatch
  • omar302 likes this

#6 OFFLINE   enigma-2

enigma-2

    Ford Edge Fanatic

  • Edge Member
  • 3,071 posts
  • Region:U.S. Great Lakes
  • Location:Indiana
  • Edge's Year:2009

Posted 13 June 2018 - 02:21 PM

I'd say normal. 2016 SEL

Thats surprising. What purpose, drain slots?

#7 OFFLINE   ONEDGE16

ONEDGE16

    New Edge Member

  • Edge Member
  • 97 posts
  • Region:Canada Ontario
  • Location:Toronto
  • Edge's Year:2016

Posted 13 June 2018 - 04:12 PM

@lildisco
Thanks for the pictures, do you get the exhaust odor under hard acceleration with climate on recirculating?

Also, it seems the cut-offs on your liftgate are symmetrical on both sides? Location is not very clear on the first pic.

Can someone else confirm? Especially on a year other than 2016? Maybe a bad batch?


Omar,

There's a TSB for the exhaust smell. Detail can be found on this thread

http://www.fordedgef...recirculation-m
  • WWWPerfA_ZN0W and omar302 like this

#8 ONLINE   omar302

omar302

    Ford Edge Addict

  • Edge Platinum Member
  • 1,906 posts
  • Region:Middle East
  • Location:Qatar
  • Edge's Year:2016

Posted 13 June 2018 - 05:03 PM

Omar,

There's a TSB for the exhaust smell. Detail can be found on this thread

http://www.fordedgef...recirculation-m


I already took it in for it, but the odor is still there. Our dealer is not a competent one, but we don't any other one here, so I have no other choice.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users