Jump to content

Search the Community

Showing results for tags '2017 edge'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Ford Edge Forum
    • Welcome Forum!
    • Forum Help & Site Suggestions
  • Ford Edge Social Forum
    • Lounge
    • Articles, News & Reviews
    • Buying, Leasing & Ordering
    • Dealership & Vendor Experiences
    • Competing Crossovers & Vehicles
    • Facebook Pages
    • Multimedia
    • Owner Impressions
    • Super News Ticker
  • Ford Edge Lincoln MKX Modification and Technical Discussion
    • Accessories & Modifications
    • Ford Edge & MKX Member Builds
    • Alarms, Keyless Entry, Locks & Remote Start
    • Appearance - Detailing, Wash & Wax
    • Audio, Backup, Navigation & SYNC
    • Brakes, Chassis & Suspension
    • Cargo, Hauling, Roof Racks & Towing
    • Exterior & Body
    • Glass, Lenses, Lighting, Mirrors, Sunroof (BAMR), Wipers
    • Interior, A.C., Heat, Interior Trim
    • Recalls, TSBs & Warranty
    • Wheels & Tires
    • Ford Sync Specific Forum
  • Ford Edge & Lincoln MKX: Powertrain
    • 3.5L and 3.7L
    • EcoBoost
    • Edge RS
    • Edge ST
    • All Wheel Drive (AWD)
    • Transaxle (FWD)
  • Ford Edge, MKX Nautilus Model Year Specific
    • 2015+ Edge & MKX Generation II
    • 2007-2014 Edge & MKX Generation I
  • Classifieds
    • Classifieds
  • Test Forum
    • TEST FORUM
  • Ford Edge & Lincoln MKX: Interior
  • Ford Edge & Lincoln MKX: Recalls, TSBs & Warranty

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Found 2 results

  1. Ok, long story short, I had rat damage to my engine. Took it to a dealer and they ultimately had to pull the engine out (to replace the firewall insulation). Worst dealer ever. They damaged my custom front Ford emblem (scratched), didn't properly attach the radiator hose to the reservoir (blew off 5 minutes after leaving the dealer). They had to re-splice wire harnesses, which they didn't do correctly (triggered about 20 sensor failures and shorted the battery). And finally, after picking it up the wipers have a HORRID squeaking/chopping effect. They literally "skip/chop" over the window, leaving splatter all over and they obviously don't remove everything. This is all an insurance job so we ultimately took it to a new shop to fix what the dealer screwed up. They inspected the wipers but said they didn't see anything wrong and they mentioned that the steel the arms are made of is incredibly strong and you would see clear signs of damage if they had been tweaked. I tend to agree but here we are. I bought brand-new blades (rain-x best model) and at first it was fine but after a week, the problem returned. They come with some type of conditioner, I think, so they don't dry out or whatever. Anyway, today the shop I'm working with put on yet another new pair of blades. Issue persists. So, my question is - is there any type of adjustments that can be done? This shop mentioned they played with the "tension" on the arms (this was on my first visit) but no help there. It almost seems like they don't cycle as far in the up-swing as they should (stop at the top is about 3 inches from the edge of the window. Would it be worth a try to remove the arm, rotate it slightly, and put it back on? If it isn't in the proper location when you put it on, could that cause excessive squeaking? Thanks in advance!
  2. In looking for aftermarket upgrades for intake and exhaust, there is hardly anything available for the Edge Sport 2.7 Twin turbo yet the F-150 2.7 Twin turbo has an incredible amount of choices...Can anyone tell me why there is so little for the Edge Sport?
×