Jump to content

Search the Community

Showing results for tags 'AC hose'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Ford Edge Forum
    • Welcome Forum!
    • Forum Help & Site Suggestions
  • Ford Edge Social Forum
    • Lounge
    • Articles, News & Reviews
    • Buying, Leasing & Ordering
    • Dealership & Vendor Experiences
    • Competing Crossovers & Vehicles
    • Facebook Pages
    • Multimedia
    • Owner Impressions
    • Super News Ticker
  • Ford Edge Lincoln MKX Modification and Technical Discussion
    • Accessories & Modifications
    • Ford Edge & MKX Member Builds
    • Alarms, Keyless Entry, Locks & Remote Start
    • Appearance - Detailing, Wash & Wax
    • Audio, Backup, Navigation & SYNC
    • Brakes, Chassis & Suspension
    • Cargo, Hauling, Roof Racks & Towing
    • Exterior & Body
    • Glass, Lenses, Lighting, Mirrors, Sunroof (BAMR), Wipers
    • Interior, A.C., Heat, Interior Trim
    • Recalls, TSBs & Warranty
    • Wheels & Tires
    • Ford Sync Specific Forum
  • Ford Edge & Lincoln MKX: Powertrain
    • 3.5L and 3.7L
    • EcoBoost
    • Edge RS
    • Edge ST
    • All Wheel Drive (AWD)
    • Transaxle (FWD)
  • Ford Edge, MKX Nautilus Model Year Specific
    • 2015+ Edge & MKX Generation II
    • 2007-2014 Edge & MKX Generation I
  • Classifieds
    • Classifieds
  • Test Forum
    • TEST FORUM
  • Ford Edge & Lincoln MKX: Interior
  • Ford Edge & Lincoln MKX: Recalls, TSBs & Warranty

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Found 1 result

  1. I have been a solid Toyota owner (and fan) and I just switched to American cars because the hubby works for Ford now. I leased a new 2015 Ford Edge. It has only been 2 weeks since I got it. But Ford already let me down big time. On my way home yesterday, I noticed that the driver floor was wet. I got out of the car, took the rubber mat off and the floor mat. When I flipped the floor mat to its side, there was a steady stream of water for a good 10 minutes. Then I tried to get as much water from the floor as I can (by using a rag and dab it on the carpet) but it is still wet... and dirty musty water too. What could be wrong? A friend said that it could be a missing floor grommet. My husband said that it could be the AC house that was accidentally re-directed to the inside (but I haven't been using the AC lately though). I told my husband to take it back to the dealership and switch for another one because the car smells musty now and I don't want to risk any molds growing under there (my family and I have allergies). Does anybody have an idea on what it could be? Thanks.
×