Jump to content

Search the Community

Showing results for tags 'Check Engine'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Ford Edge Forum
    • Welcome Forum!
    • Forum Help & Site Suggestions
  • Ford Edge Social Forum
    • Lounge
    • Articles, News & Reviews
    • Buying, Leasing & Ordering
    • Dealership & Vendor Experiences
    • Competing Crossovers & Vehicles
    • Facebook Pages
    • Multimedia
    • Owner Impressions
    • Super News Ticker
  • Ford Edge Lincoln MKX Modification and Technical Discussion
    • Accessories & Modifications
    • Ford Edge & MKX Member Builds
    • Alarms, Keyless Entry, Locks & Remote Start
    • Appearance - Detailing, Wash & Wax
    • Audio, Backup, Navigation & SYNC
    • Brakes, Chassis & Suspension
    • Cargo, Hauling, Roof Racks & Towing
    • Exterior & Body
    • Glass, Lenses, Lighting, Mirrors, Sunroof (BAMR), Wipers
    • Interior, A.C., Heat, Interior Trim
    • Recalls, TSBs & Warranty
    • Wheels & Tires
    • Ford Sync Specific Forum
  • Ford Edge & Lincoln MKX: Powertrain
    • 3.5L and 3.7L
    • EcoBoost
    • Edge RS
    • Edge ST
    • All Wheel Drive (AWD)
    • Transaxle (FWD)
  • Ford Edge, MKX Nautilus Model Year Specific
    • 2015+ Edge & MKX Generation II
    • 2007-2014 Edge & MKX Generation I
  • Classifieds
    • Classifieds
  • Test Forum
    • TEST FORUM
  • Ford Edge & Lincoln MKX: Interior
  • Ford Edge & Lincoln MKX: Recalls, TSBs & Warranty

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Found 2 results

  1. selfmade6288

    Diagnostic/Technician Help Needed

    2010 Edge LIMITED, 120K+/-, owned for <30days. Have driven about 1k miles since purchase. Check Engine light has come on, showed 4 Codes: P0451 U0253 B2290 B1318 2 nights ago I drove <20miles during HEAVY rain, Edge was NOT driven through high water, but there were 3-4 places where water splashed/sprayed up while crossing. (Never heard that ominous of water beating undercarriage!) Parked having no issues. *May be unrelated: Opened remote start fob to change battery, seen the 1pc metal contact was loose on 1 side, put metal back into place, reassembled. (Brand unknown) Yesterday morning was cold maybe 20 degrees Used "repaired" fob to remote start. Rear Brake Aid On/Off & Driver Door Adjar were both lit up. Brake notification went out after taking off, Door note stayed on and int. lights were all on. (Opened/closed all doors 2x). After 4hrs Door notification was gone. This morning CEL was lit. Had codes read *see above*. Have been searching for info related to codes, possible trouble shooting ideas, how to determine which part is throwing which code, HOW TO FIX? Please let me know what will repair all this. Thanks Matt
  2. Edge e DJ

    Check Engine Light Ecoboost 2.0

    Anyone else have this issue? It seems as though I have been plagued by continuous problems on my 2013 Edge Ecoboost. All have been covered by warranty so far, but that will eventually end. The most recent problems I have had were with the Check Engine light. I brought it to the dealer, they ran the diagnostics, and confirmed the O2 sensor in Back 1 Block 1 needed to be replaced. About a month later, the CEL cam on again. Once again brought it to the dealer, they ran the diagnostics, and determined that 4 injectors needed to be replaced. Both of these were done under the Power Train and Emisions warranty, but I am a bit concerned. Should I have noticed if the injectors were faulty? Would the engine not be mis-firing or blowing smoke? None of this was evident. Just the sad little orange light on the dash. Am I worrying about nothing? Did I buy a Lemon? Any suggestions would be helpful!
×