Jump to content

Search the Community

Showing results for tags 'Dead battery'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Ford Edge Forum
    • Welcome Forum!
    • Forum Help & Site Suggestions
  • Ford Edge Social Forum
    • Lounge
    • Articles, News & Reviews
    • Buying, Leasing & Ordering
    • Dealership & Vendor Experiences
    • Competing Crossovers & Vehicles
    • Facebook Pages
    • Multimedia
    • Owner Impressions
    • Super News Ticker
  • Ford Edge Lincoln MKX Modification and Technical Discussion
    • Accessories & Modifications
    • Ford Edge & MKX Member Builds
    • Alarms, Keyless Entry, Locks & Remote Start
    • Appearance - Detailing, Wash & Wax
    • Audio, Backup, Navigation & SYNC
    • Brakes, Chassis & Suspension
    • Cargo, Hauling, Roof Racks & Towing
    • Exterior & Body
    • Glass, Lenses, Lighting, Mirrors, Sunroof (BAMR), Wipers
    • Interior, A.C., Heat, Interior Trim
    • Recalls, TSBs & Warranty
    • Wheels & Tires
    • Ford Sync Specific Forum
  • Ford Edge & Lincoln MKX: Powertrain
    • 3.5L and 3.7L
    • EcoBoost
    • Edge RS
    • Edge ST
    • All Wheel Drive (AWD)
    • Transaxle (FWD)
  • Ford Edge, MKX Nautilus Model Year Specific
    • 2015+ Edge & MKX Generation II
    • 2007-2014 Edge & MKX Generation I
  • Classifieds
    • Classifieds
  • Test Forum
    • TEST FORUM
  • Ford Edge & Lincoln MKX: Interior
  • Ford Edge & Lincoln MKX: Recalls, TSBs & Warranty

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Found 7 results

  1. I bought a 2018 AWD V6 Edge three weeks ago. Earlier this week, at 850 miles, I parked the vehicle on Sunday after a four hour drive and left it until Monday night. I opened it to get something out and locked it. On Tuesday night I went to open the car and the battery was completely dead. I was unable to use the key fob or Keyless Entry to open the car, so the tow truck driver had to use the "real" key to open the door. He jump started the Edge and it started right up, but the clock, date, radio stations, etc. were all reset to factory settings. I drove it 50 miles to the nearest Ford dealer who did a complete check of the electrical system: battery check, check for shorts, etc. They said they could find no codes or anything to explain why the battery went dead: no shorts, battery good, etc. They said I must have left a door open or something, but I know I didn't, and anyway, I thought the electrical system would shut off anything automatically after 10-45 minutes. So, does anyone have an idea what I should do next? My wife doesn't want to drive the car if the battery can go dead in 24-48 hours with no identifiable cause. My local dealer is reluctant to run diagnostics since they say the warranty does not cover it if the car isn't broken. p.s. if I am posting in the wrong forum, let me know and I'll repost correctly. Thanks.
  2. I purchased a used 2011 Edge SEL 100K (but miles never scared me because I am pretty mechanical). I am feeling buyers remorse HARD! After test driving and no issues, just one thing after another now. I have had the car 35 days. I have already grounded the wire inside the Driver's door so that the Door Ajar issue is just eliminated. . The ISSUE: Dead battery this morning. Jumped it and let it run for about 10 min. (didn't know about the "Battery reset" this morning). Flash forward to 6pm Wife calls and says the interior lights are coming on as well as the tail lights,puddle lights, dash, center console, and the doors unlocked. Then all the lights would all go out randomly, or stay on for over an hour. Did the whole ordeal for the learn function (whatever the actual function was, I did it right, no more battery saver). Then drove for about 30 min. I no longer see the Battery save mode BUT I am still getting the lights and unlocking issue. . at first the I thought the original dead battery was from "not in park" issue. But we never got the warning "shift to park". The P would just not light up. And a couple finger bangs on the button fixed that. Thoughts please on main culprits? What could cause the lights to come on and unlock the doors? OH! I also noticed while in that dark with the lights off and doors locked the dash (speedo) would flicker and make a arcing sound but very very faint. . I just noticed the light on again and went out. wiggled and pushed and pulled the fuse box connectors that I could reach,blew compressed air in and around all the fuses twice. Seems a little dirty in there for a fuse box. I opened the drivers door all the way then closed and locked it up with the FOB and haven't seen the lights come back on in 2hrs. ODD!
  3. So, 2013 Ford Edge AWD - wife's car. She works for an airline, so the car is frequently parked at JFK for a few days, and she often comes back in during the evening. Back in 2015 we chased a chronic dead battery issue, put in a new battery and still would turn up dead, with nothing having been left on, etc. Ended up replacing the BCM, kinda pricey with labor, but seemed to do the trick. Last night get a call from my wife, she's in the desolate crew parking lot, dead battery on the Ford, nothing was left on, and to make matters worse, she was parked head-in with cars on either side of her, and she couldn't get the car into neutral to roll it back for her jumper cables to reach the good Samaritan's car. She's no dummy, but said it just wouldn't shift with the key twisted, and there was enough juice to light the dome light. Had to run AAA out there with their long jumpers. What the hell is it with Ford Edges and whacky battery drains? Not knocking the car on the whole, but I have zero tolerance for a spontaneously unreliable car for her (for me too I guess). Is it likely the BCM again, or is there another well-known issue causing the battery drain? And why the heck wasn't she able to put the car into neutral?
  4. The lights on my 2014 Edge with 10K miles sometimes will not go off. I drive the car, auto lights come on, day or night. Stop car and turn off and lock. Lights stay on sometimes for hours. Sometimes will operate correctly. Turn off light switch manually has no effect, lights still stay on. Once had to disconnect the battery for lights to go off. This has been happening since the veh had 2K miles. Secondly, the car can be sitting for hours, with no one around it and the headlights will come on. Stay on for minutes or hours, then go off. Last check with Ford Hotline states no known issues. Additional. Heater/AC fan loses memory. Set the night before so veh will warm up remotely and no fan. Additional. Had key on to listen to radio, one door open. 20 minutes later message on display shut radio down to save battry. Tried to start car, battery dead. Yes, the car is going back to the dealer and they can keep it until it is fixed or replaced.
  5. MARA

    2011 Edge battery

    Cannot leave vehicle in garage for 6-7 days without battery going dead. Leave radio on for 15 minutes, without vehicle running, dead battery. At every service - battery is green/good & CCA meets or exceeds specs. 33 ,000 miles, serviced at 30,000 & 33,000 miles. Any ideas on what is drawing the battery down is appreciated
  6. I just purchased a new Edge specifically for towing behing a motor home. With less than 600miles on the car, I left for a trip. I followed book instructions exactly and have towed other vehicles for over 200,000 miles without an incident. I have towed a vehicle for days behind the motor home and never experienced a dead battery. When I arrived at my destination, the battery was totally dead and I had to call AAA to start. When I returned home a week later, I once again was greeted with a totally dead battery. I have experienced the tailgate opening 3 times while unattended, the parking lights coming on a half dozen times for no apparant reason, the radio being dead one day and ok the next, the car recognizing my key and unlocking the door for me only to sound the alarm when I opened the door, and the automatic day/night mirror deciding it was night time in the middle of the day. The Dealer believes that the "odd stuff" that has been going on all relates to when the battery went completely dead. That effects the computer and strange things can happen. At this time, the car has been at the dealer the past 10 days with no cure yet in sight. We have determined (Dealer and myself) that the battery drain is coming from putting the car in the Accessory position in preparation for towing. Initial battery drain runs about 6 amps/hour and long term drain (after initial hour) is running about 3 amps/hour. This is enough to totally drain the battery in no time at all. For those RVers who consider towing an Edge, I would recommend that you have the Dealer test the car you are purchasing for excessive battery drain when in Accessory position. We checked one other new Edge with the same accessories on the car as mine and it too had the same excessive drain. I have contacted Ford and am awaiting for a solution. UPDATE: Just received information from Ford Dealer that the drain of 6 amp and 3amps on the battery in the accessory position is the standard draw for the Edge. That means that anyone wanting to tow the Edge behind an RV can expect the battery to go dead in about 8 hours. I am now being told that I should stop the vehicle every 2-3 hours, start the car, go through the gears, and run it for around 10 minutes. REDICULOUS. Do not purchase an Edge until Ford corrects the problem if you plan to tow it behind an RV. My research has indicated that the amperage draw should not exceed .5 Amps even on the new, computer driven autos.
  7. hey guys, long time lurker first time poster. got a bit of a problem with my wife's 08 edge limited after a new battery was installed. i have a few dash lights that are on and won't go away. i haven't had it scanned or taken it to the dealer yet, as i don't think it needs that just yet. plus i'm mechanicaly inclined enough to try and figure this out. or maybe i'm too cheap lol . but on to the problem. it had a shifting flare going from first to second gear for a while, but after a 10 miles it seemed to fix it. so that's not the biggest deal. nav system thinks we are going south when we are going north, need help with this! how to fix it. dash lights that are on all the time, emergency brake, wrench light, abs, traction control. need help on this!! thanks in advance you guys!!
×