Jump to content

Search the Community

Showing results for tags 'Edge'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Ford Edge Forum
    • Welcome Forum!
    • Forum Help & Site Suggestions
  • Ford Edge Social Forum
    • Lounge
    • Articles, News & Reviews
    • Buying, Leasing & Ordering
    • Dealership & Vendor Experiences
    • Competing Crossovers & Vehicles
    • Facebook Pages
    • Multimedia
    • Owner Impressions
    • Super News Ticker
  • Ford Edge Lincoln MKX Modification and Technical Discussion
    • Accessories & Modifications
    • Ford Edge & MKX Member Builds
    • Alarms, Keyless Entry, Locks & Remote Start
    • Appearance - Detailing, Wash & Wax
    • Audio, Backup, Navigation & SYNC
    • Brakes, Chassis & Suspension
    • Cargo, Hauling, Roof Racks & Towing
    • Exterior & Body
    • Glass, Lenses, Lighting, Mirrors, Sunroof (BAMR), Wipers
    • Interior, A.C., Heat, Interior Trim
    • Recalls, TSBs & Warranty
    • Wheels & Tires
    • Ford Sync Specific Forum
  • Ford Edge & Lincoln MKX: Powertrain
    • 3.5L and 3.7L
    • EcoBoost
    • Edge RS
    • Edge ST
    • All Wheel Drive (AWD)
    • Transaxle (FWD)
  • Ford Edge, MKX Nautilus Model Year Specific
    • 2015+ Edge & MKX Generation II
    • 2007-2014 Edge & MKX Generation I
  • Classifieds
    • Classifieds
  • Test Forum
    • TEST FORUM
  • Ford Edge & Lincoln MKX: Interior
  • Ford Edge & Lincoln MKX: Recalls, TSBs & Warranty

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Found 207 results

  1. Hey guys, Keep in mind I'm no mechanic. This post is to add search results to the internet for someone like me who couldn't find the things I wanted. The A/C on my 2008 ford edge has always been horrible since I purchased it in 2010 and possibly even declining ever since then.. Within the last few weeks: When making a turn splashing noise from glovebox. Ac blower fan very noisy. Water leaking on passenger side into floorboard. I started off by removing the glove box and the cover beneath it(snap screws). Found a napkin sucked to the intake where the RECYCLE AIR vent opens. Oh dear, I see where this is going. Then I removed the blower fan. 3 screws and unplug the electrical plug (easy job). Water the color of pepsi leaked out of it like crazy as I pulled it off. Ran my hand around the inside of where the fan sat thinking I'd find some material. Nothing. Next move was I knew A/Cs sweat water and that must be what the deal was. I got on the interwebs and searched for words I could think of relating to a/cs and found the condenser being the part that sweats, I started to look for the drain plug on my ford edge under the hood. WRONG lol Id only be so lucky. I even went as far as driving it up on ramps and could not find the drain. Apparently it's there but behind something that has to be removed. BLAH I thought ok maybe the clog lies within the drain pan and I can attack it there. Instead of laying under a car on ramps I had no idea if they would give and the car crush me. I started looking around to remove it. NO GO. Next was find where the hose drains from the pan to under the car BINGO. I found it on a diagram here on the web. It's under the carpet right next to where your foot rests on the gas pedal. Pulled the hose off the white plastic connector. No water came out..Hrmph well well I was right the clog was in the pan. I thought oh damn there is something sucked in there that came from the glovebox and I'm screwed. I Saw some guys on youtube use a compressor to blow theirs clean(from the outside of the car). Not having a compressor the next best thing I could think of was to use my mini shopvac and reverse the hose to blow. I chose to blow back towards the drain pan because what if there is a huge napkin in there and If I use suck it will lodge it even further in the hose. Used my hand to make the seal from the shopcav attachment to seal it to the hose line. Blew for 10 secs removed nothing happened. Blew again for about 10 secs and boom water started gushing out. I bet there was 1/2 gallon of water that came out. I had a large bowl ready to catch most of it. The rest hit the floor, oh well I have a shopvac. :P Put everything back together. Watched under the car to see if it was leaking. All good now. I will never know what the blockage was. Was it a napkin, receipt or outdoor debris?? Who cares it's draining now and The A/C is colder than it has ever has been! Happens again I'll repeat. The blower fan is ruined though and forever noisy. Replacements are $50 online. I guess I'll rock it till the wheels fall off and am forced to replace it. Jerry Oh P.S., I think that water has been backed up for years breaking down whatever process happens making the air cold. It really is colder than it has ever been. (insert technical reason here)
  2. Greetings folks, 2009 edge with intermittent charging issue • Two different new (not used) alternators have been installed by licensed shop in the last 3 weeks. Still have the intermittent charging issue The original alternator burned up on it while driving it and lost all power at the gas station I pulled in to. It ran until I shut it off and then nothing when trying to start it back up. • The only issue I have is the intermittent charging issue when the dash battery light comes on. Check engine light has never came on. Battery test perfect and is only about 11 months old. Voltage is right where it needs to be on both the battery and alternator when it's charging correctly. It can sit for as much as 15 or so minutes idling and charge perfect but then all of a sudden the battery light comes on and it's no longer charging. Whether it's sitting and idling or going down the road, it has this problem. All wiring and fuses have been checked but there were no issues. All wires connections were clean and in good shape. Feel free to ask for any additional details or I will add to this if something else comes to mind that I may have forgotten to mention. Could this possibly be a PCM / ECM issue? Anyone? Thank you in advance Randy
  3. I have a 2017 Ford Edge with a little over 80,000 miles on it and I live in northern New England where calcium chloride is commonly used on the winter roads. That aside this spring I was changing switching over to my summer tires. I use a hydraulic floor jack which has about a 2" diameter disk with notches to prevent slipping. As I was jacking up the passenger rear wheel side (jack between the arrows) all of a sudden the car dropped the half to three fourths of an inch. I thought the jack had gone up through the rocker panel but fortunately it did not. Instead the lip of the seem just bent over. I was able to continue jacking and finishing the task at hand. Okay, now to my concerns/questions. a) how solid is the rocker panel at these jacking points? b) should I continue using the rocker panel point? c) does anyone know of or recommend alternative jacking points that would be safe? I have read through several earlier posts/strings about jacking. Some recommend using a something similar to a hockey puck or a grooved piece of wood or a commercial version. At this point the damage is done although it may be worth while using such devices might save the other three jacking points. Would be happy to hear what folks have to say and any helpful thoughts will be much appreciated. I tried to upload a picture two pictures but then realized the two combined were too large. I deleted the first picture thinking the second one was more important but now the system won't let me upload any. I will either try to do an edit after posting OR do a reply to myself so anyone interested can see the seam folded over.
  4. I have a problem with the drivers side front door won't open any of the windows. The passenger front door can open/close the window. Additionally the power sunroof is not working either. I read about the pin issue within the front drivers door/chassis connector and there does seem to be an issue for when i push on the wires the passenger window control will intermittently work. I found these schematics for the power windows and sunroof. Can you think of a scenario where the front drivers side door connect could be effecting the sunroof? Thanks for any help in advance! bb6e8bf1-3c1b-4726-9b87-ed339c58dacf_eee1.pdf f03efd88-348c-46df-b94d-23f77d16b500_eee.pdf dff28163-8233-4437-91de-5cbab20f4dce_Sunroof___Moonroof__Diagrams__Electrical.pdf
  5. I discovered over the last couple of days that my navigation system says I have no GPS, I can not call out or answer calls verbally on my phone. Also the "Audio button" on bottom left of screen does not respond. There may be other symptoms I have yet to discover but that is enough for the moment. I checked/tested fuse # 32 (10 amp) in the passenger compartment fuse panel under the dash and that appears to be okay. I have done a master reset to no avail. This all started when last week the electric cooler fan would not shut off when I shut the car off. I got caught downtown with a dead battery and a good Samaritan gave me jump start with one of those new little jump start batteries.. Since it was late at night when I got home and the fan wanted to keep running I disconnected the battery over night and charged it up. I swapped out Relay #39 in the engine compartment fuse box and that solved that problem. NOW I have the problem described in the first paragraph. Can one or more folks give me some ideas as what to check next? I was sure it was the fuse # 32 (10 amp) but it looked both good and tested good. Any help will be much appreciated.
  6. Hello ford owners, I have this issue that started 2 weeks ago, when starting my car while cold and has been sitting for ~6 hours or more I get this loud screeching metal grinding kind of noise. the car is Ford edge 2013 with the Duratec 3.5L, it has 240k Km on the clock. these two videos can explain the noise heard. I don't think it's the starter because it only happens when the car is cold. it might be one of the pulleys, probably the alternator ? would appreciate any suggestions. thanks.
  7. Asking $16,500 Location: Tampa, FL Not your average grocery getter! Fully loaded, garage kept, 450HP daily driven sleeper. This vehicle has been meticulously maintained both inside and out, with documentation to show all oil changes, and other maintenance. Recently completed Chemical Guys paint correction and sealant. Highlights: 450HP 12.5 ET Quarter Mile Time 128k Highway miles Great condition Daily driver Garage kept 1 owner Clean title in hand Panoramic sunroof Heated and cooled seats 21" wheels with Michelin Pilot Sport 4S tires Ceramic tint on all windows and sunroof Modifications: (3) ZFG Racing Tunes - Daily 93 Octane - Race E50 - Race Full E85 HP Tuner - MPVI 2 Hardware BNR Hybrid Turbos Custom Catted Down Pipes Custom Dual Exhaust H&R Lowering Springs XDI High Pressure Fuel Pump Ultimate Performance Intercooler Ultimate Performance Engine Mount Ram Fab Custom Charge Pipe Custom Intake Drilled and Slotted Rotors Stainless Steel Brake Lines New Struts Accel Coil Packs Livernois Custom Gapped Plugs Royal Purple Fluids for: - Engine - Transmission - PTU - Rear
  8. Hello Everyone, I recently picked up a 2014 Edge in January and have about 2,500 miles on the vehicle. Since I picked up this vehicle in the winter, I've had to use the defrost system to clear the front windshield and side windows. Unfortunately the system has not worked properly and I decided to see if time would fix it. It is not mid-March and since the weather is nearing 32F, I've noticed that the defrost system works great above freezing. I believe that the A/C unit is not turning on above freezing as the air temperature inside the vehicle becomes colder when the thermometer reads above 32-33 degrees Fahrenheit. But then once again the temperature drops below 32-33F outside, and the defrost stops working (no more "dry" air) and the windshield and side windows frost up very fast, literally within a matter of seconds. (I'd love to video record this but as you know, it's very dangerous while driving). So basically, do any of you have this problem or know if it is a known issue with Ford? I will be taking it to a dealership very soon as it is a very serious driving hazard. On many occasions I've had to pull over and towel off the inside glass surfaces simply to continue driving. I've tried every A/C, Temp, fan speed combination and they all seem to have minimal effects. I've manually turned the A/C button on (the Edge is the first vehicle I've owned when you hit the defrost button that the A/C "light" doesn't turn on) along with the defrost and that has no effect when the outside temperature is below 32F. This is a very frustrating issue as everything else on the Edge has been great. Thank you in advance!
  9. KamSTeDge

    2022 Edge ST, does this look right?

    Just had the Borla cat back installed on my 2022 Ford Edge ST, sounds absolutely awesome. But it looks to me like the 2 rear mufflers hang too low, Borla says it looks normal. I think it looks a little ugly to be honest. Any recommendations on what can be done to raise them? Pictures attached
  10. mpalmer3111

    Virginia 2016 Edge Sport

    Sup! Edge Sport Owner and Tuner here.
  11. Teach92

    2022 Ford Edge ST line

    New Edge owner here - 2022 Edge ST line. Lovely driver, nice power. Pleased so far.
  12. I apologize if this topic already exists on this forum--please redirect me if needed. Searched but didn't come across one. I have a 2020 Edge ST with 30K miles. Five months ago during a road trip I began to notice a subtle lag/jolt and wood-like 'thunk/knock' when coasting between 10 and 15 MPH and gently pressing the gas to maintain speed (10-15 MPH). Occurred only in this range--low RPM, low speed. As the months have gone by, this issue persisted--I've developed the ability to trigger it consistently--at low speed/RPM. The last few weeks the issue (lag/jolt and thunk/knock) now appears occasionally when rolling to a stop--occurs about a half second before a full stop. Also appears occasionally in the 35 MPH range. I took the ST into a Ford dealership two weeks ago and was referred to their service advisor who was said to have considerable transmission experience. He had the transmission software reset and asked me to drive the car normally for several days and see what develops. Unfortunately, the issue remains. He asked me to bring the car back if things didn't change, so I intend to see him later this week. Anyone have any thoughts/ideas/recommendations? Many Thanks!
  13. Hi All, Few days back I opened the rear driver door for dampening and saw that the tweeter wasn't connected. I never sat in the rear seats so never noticed this but found this very disappointing as you can tell that something is not right when you hear song in the back seat. I am not sure how this is even possible but does anyone have any suggestions for this? Thanks!
  14. Hi gents! I am writing from Sao Paulo/Brazil (anyone here? 😄); Ford Edge AWD 3.5L V6 happy user (so far), the 2014 model that supposedly was imported from Canada. I had a problem (wife 😂, what else?) with the driver turn signal (mirror stripe) in the past, original one, and today it is almost dead with only 3-4 working LEDs. Prices in Brazil are an absurd and I tried to look outside, even a dynamic LED system, but I have not found nothing; neither dynamic nor traditional. Only 2015 or newer models replacements. My questions are: should a 2015 (or newer) model work in the 2014 one? does it exists a compatible model from Focus, any Ford pickup, Fusion, Explorer... that I could use? Thanks everyone who make this forum great!
  15. I've had a 2011 Edge LTD with the Sony system in it since Summer 2011 and Sync has always been mediocre at best. I flashed it with 3.10 a year or two back which improved things but the last 6 months it has just been dying randomly for no reason. Usually it comes back a day or two later and all is well but this time it died and wont come back. I pulled the battery cable overnight with no success. I'm not sure if its the screen or module that tanked. I have access to forscan but haven't gone out yet to see if it sees the module. I checked the fuse and its fine. Does anyone have any forscan tips? I'm game to piece together sync 3 for it should my module be gone but I don't want to throw away good money either. Any help would be appreciated.
  16. gravnick

    Hill Climb Assist Disabled

    Hey folks Iv'e been having issues with my 2015 Ford Edge 3.5L AWD. Every once in a while I get a pop up on the screen saying "Hill Climb Assist has been Disabled" when this happens the vehicle has trouble accelerating. It goes away when I cycle the key. I myself would normally live with it but my wife drives the vehicle with my kids and it is unsafe. Does anybody know what it may be? the dealership has been unhelpful diagnosing.
  17. Hey guys, new here but wanted to see if anyone else is having the same issues I am having. My wheels have less than 60K miles but are starting to peel. I wanted to see if anyone else is/has experienced this issue and if so what is the best way to correct this issue. I know I am way past warranty so reaching out to Ford is not even a thought. I really appreciate the help.
  18. I had a Mustang GT, with Sync 3. When I would receive a text message, I could press the listen button to listen to the message. Once the message finished playing, the window would go away on the display. With the 2020 Ford EDGE ST, that does not seem to be the case. Despite listening to the message, the notification remains on the Sync 3 display. Then I have to close it, by clicking close. Does this happen to you, too?
  19. My Ford Edge was built in March 2011 and it's been 10 years and 2 months when the brake booster went out, whereas the brake booster warranty is for 10 years. Ford won't help. I called customer service. Additionally, ever since picking up my Edge from Mark Thomas Ford dealership repair shop for having both catalytic converters and spark plugs replaced, my Edge makes a high pitch whining noise like a turbo would, when exceeding roughly 3k RPMs. Doesn't make the noise when revving it while in park. Some say it could be the main crank bearing, some say other bearings such as water pump or alternator or ac compressor. My thought was transmission. Who knows!? Could "Large Leak Evap Emission" code related? Code P0455 135K miles.
  20. Hey everyone, I think the speaker that does the fake engine noise is blown (tho idk) already. When I put the car into "S" mode there is a constant whooshing noise coming from what sounds like the left A-pillar. Turn off "S" mode and it goes away. I guess it could be the intentional sound but I have no idea what noise they possibly could have been trying to imitate lol. The noise happens when the car is stopped idling at a light as well as one the move. I'm sure if I bring it to the dealer for this issue they'll say they can't replicate it, is there a way I can deactive the fake engine noise?
  21. WWWPerfA_ZN0W

    SSM 46412 - PTU Idler Gear

    February 27, 2017 MANUFACTURER COMMUNICATION NUMBER: SSM 46412 - PTU Components: POWER TRAIN, EQUIPMENT NHTSA ID Number: 10095858 Manufacturer Communication Number: SSM 46412 Summary SOME 2007-2016 EDGE/MKX/FLEX/MKT/MKZ/MKS/TAURUS/TAURUS POLICE/EXPLORER/EXPLORER POLICE EQUIPPED WITH ALL WHEEL DRIVE (AWD) AND BUILT ON OR BEFORE 30-JUN-2016 MAY EXHIBIT A TICKING AND/OR KNOCKING NOISE COMING FROM THE DRIVELINE AREA. TO IDENTIFY THIS NOISE, REFER TO WORKSHOP MANUAL (WSM), SECTION 100-04, AND FOLLOW THE SYMPTOM CHART. IF THE SOURCE OF THE NOISE IS IDENTIFIED AS THE PTU AND/OR INTERNAL TO THE PTU, DISASSEMBLE PTU ASSEMBLY. REFER TO UPDATED WSM, SECTION 308-07. IF THE PTU IS DETERMINED TO BE REPAIRABLE, UTILIZE KIT GB5Z-7P258-A (PTU Idler Gear Repair Kit, about $315) AND THE INCLUDED INSTRUCTION SHEET. FOR CLAIMING, USE CAUSAL PART 7P258 AND APPLICABLE LABOR OPERATIONS IN SECTION 07 OF THE SERVICE LABOR TIME STANDARDS (SLTS) MANUAL. 77 Associated Products Vehicles MAKE MODEL YEAR FORD EDGE 2007-2016 FORD EXPLORER 2007-2016 FORD FLEX 2009-2016 FORD TAURUS 2007-2016 FORD TAURUS POLICE INTERCEPTOR 2013-2015 LINCOLN MKS 2009-2016 LINCOLN MKT 2009-2016 LINCOLN MKX 2007-2016 LINCOLN MKZ 2007-2016
  22. edge2013own99

    Trouble turning on after refuel

    I have a 2013 Ford Edge Limited with around 100k kms on it, and it seems to be running fine. Though after refuelling, the car has trouble starting up, when turning on the car, the dash will come on but the wheel will remain frozen (as in I can't turn it), after attempting to turn on the car 2-3 times, it will eventually hit a turn on where you will hear the engine cranking for 15-20 seconds and it turns on normally after this. The issue then disappears till next refuel. Any advice is appreciated.
  23. I just called the parts dept at my local ford dealer looking for Parking Brake shoes for my 2013 edge. The associate on the phone informed me that the 2013 edge uses the regular brake caliper and pads for the parking function. Can anyone confirm this me? Cant find anything to corroborate this after multiple google searches. Google has returned actual parts that fit that description. Thanks in advance
×