Jump to content

Search the Community

Showing results for tags 'a/c'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Ford Edge Forum
    • Welcome Forum!
    • Forum Help & Site Suggestions
  • Ford Edge Social Forum
    • Lounge
    • Articles, News & Reviews
    • Buying, Leasing & Ordering
    • Dealership & Vendor Experiences
    • Competing Crossovers & Vehicles
    • Facebook Pages
    • Multimedia
    • Owner Impressions
    • Super News Ticker
  • Ford Edge Lincoln MKX Modification and Technical Discussion
    • Accessories & Modifications
    • Ford Edge & MKX Member Builds
    • Alarms, Keyless Entry, Locks & Remote Start
    • Appearance - Detailing, Wash & Wax
    • Audio, Backup, Navigation & SYNC
    • Brakes, Chassis & Suspension
    • Cargo, Hauling, Roof Racks & Towing
    • Exterior & Body
    • Glass, Lenses, Lighting, Mirrors, Sunroof (BAMR), Wipers
    • Interior, A.C., Heat, Interior Trim
    • Recalls, TSBs & Warranty
    • Wheels & Tires
    • Ford Sync Specific Forum
  • Ford Edge & Lincoln MKX: Powertrain
    • 3.5L and 3.7L
    • EcoBoost
    • Edge RS
    • Edge ST
    • All Wheel Drive (AWD)
    • Transaxle (FWD)
  • Ford Edge, MKX Nautilus Model Year Specific
    • 2015+ Edge & MKX Generation II
    • 2007-2014 Edge & MKX Generation I
  • Classifieds
    • Classifieds
  • Test Forum
    • TEST FORUM
  • Ford Edge & Lincoln MKX: Interior
  • Ford Edge & Lincoln MKX: Recalls, TSBs & Warranty

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Found 7 results

  1. Hello Everyone, I recently picked up a 2014 Edge in January and have about 2,500 miles on the vehicle. Since I picked up this vehicle in the winter, I've had to use the defrost system to clear the front windshield and side windows. Unfortunately the system has not worked properly and I decided to see if time would fix it. It is not mid-March and since the weather is nearing 32F, I've noticed that the defrost system works great above freezing. I believe that the A/C unit is not turning on above freezing as the air temperature inside the vehicle becomes colder when the thermometer reads above 32-33 degrees Fahrenheit. But then once again the temperature drops below 32-33F outside, and the defrost stops working (no more "dry" air) and the windshield and side windows frost up very fast, literally within a matter of seconds. (I'd love to video record this but as you know, it's very dangerous while driving). So basically, do any of you have this problem or know if it is a known issue with Ford? I will be taking it to a dealership very soon as it is a very serious driving hazard. On many occasions I've had to pull over and towel off the inside glass surfaces simply to continue driving. I've tried every A/C, Temp, fan speed combination and they all seem to have minimal effects. I've manually turned the A/C button on (the Edge is the first vehicle I've owned when you hit the defrost button that the A/C "light" doesn't turn on) along with the defrost and that has no effect when the outside temperature is below 32F. This is a very frustrating issue as everything else on the Edge has been great. Thank you in advance!
  2. Hello! Ford Edge Titanium 2016 AT 2.0 diesel bi-turbo engine: Ambient Air Temperature (AAT) indication on the dashboard is very wrong. Indicates -40C or any other very low temperature indication, considering that there are about -1C. Also when warmer, the difference is significant. This wrong indication alters the a/c, considering that it dictates the functioning regime. Also the engine auto-off is not working, because the cars "knows" that the ambient temperature is -40C !!! Went to dealer three times and still not found the problem. Replaced the sensor and still the same crazy indication. If someone has/had the same problem please let me know, including the solution . Thanks!
  3. Hey guys, Keep in mind I'm no mechanic. This post is to add search results to the internet for someone like me who couldn't find the things I wanted. The A/C on my 2008 ford edge has always been horrible since I purchased it in 2010 and possibly even declining ever since then.. Within the last few weeks: When making a turn splashing noise from glovebox. Ac blower fan very noisy. Water leaking on passenger side into floorboard. I started off by removing the glove box and the cover beneath it(snap screws). Found a napkin sucked to the intake where the RECYCLE AIR vent opens. Oh dear, I see where this is going. Then I removed the blower fan. 3 screws and unplug the electrical plug (easy job). Water the color of pepsi leaked out of it like crazy as I pulled it off. Ran my hand around the inside of where the fan sat thinking I'd find some material. Nothing. Next move was I knew A/Cs sweat water and that must be what the deal was. I got on the interwebs and searched for words I could think of relating to a/cs and found the condenser being the part that sweats, I started to look for the drain plug on my ford edge under the hood. WRONG lol Id only be so lucky. I even went as far as driving it up on ramps and could not find the drain. Apparently it's there but behind something that has to be removed. BLAH I thought ok maybe the clog lies within the drain pan and I can attack it there. Instead of laying under a car on ramps I had no idea if they would give and the car crush me. I started looking around to remove it. NO GO. Next was find where the hose drains from the pan to under the car BINGO. I found it on a diagram here on the web. It's under the carpet right next to where your foot rests on the gas pedal. Pulled the hose off the white plastic connector. No water came out..Hrmph well well I was right the clog was in the pan. I thought oh damn there is something sucked in there that came from the glovebox and I'm screwed. I Saw some guys on youtube use a compressor to blow theirs clean(from the outside of the car). Not having a compressor the next best thing I could think of was to use my mini shopvac and reverse the hose to blow. I chose to blow back towards the drain pan because what if there is a huge napkin in there and If I use suck it will lodge it even further in the hose. Used my hand to make the seal from the shopcav attachment to seal it to the hose line. Blew for 10 secs removed nothing happened. Blew again for about 10 secs and boom water started gushing out. I bet there was 1/2 gallon of water that came out. I had a large bowl ready to catch most of it. The rest hit the floor, oh well I have a shopvac. :P Put everything back together. Watched under the car to see if it was leaking. All good now. I will never know what the blockage was. Was it a napkin, receipt or outdoor debris?? Who cares it's draining now and The A/C is colder than it has ever has been! Happens again I'll repeat. The blower fan is ruined though and forever noisy. Replacements are $50 online. I guess I'll rock it till the wheels fall off and am forced to replace it. Jerry Oh P.S., I think that water has been backed up for years breaking down whatever process happens making the air cold. It really is colder than it has ever been. (insert technical reason here)
  4. 2014 Ford Edge SEL. When changing the heater A/C temperature, there is a big variation in the temperature of air delivered thru the vents on both driver and passenger sides. Example: Increase temperature 2 degrees and the air temp increases 6 degrees then drops back 8 degrees, and then moves up a few degrees. This wide spread plus or minus degree changes cannot be normal. There are times when the air blowing thru the vents is much colder than the temp set.
  5. Hi, can anyone tell me, where the the air entry for the A/C is? Is it in the engine bay? where exactly? Thank you.
  6. I have an 08 Limited I bought used. Great vehicle, very clean and I am impressed with it. A few months ago I cleaned up the in cab air filter (couldn’t find one locally other than the dealer) and everything worked fine. A month or so later I noticed the fan wasn’t on no matter what speed I put it on (it has climate control). Started to work on its own during that drive and just forgot about looking at it. Happened a few more times since then and always came on within 10-15 minutes so it was more of a nuisance than a failure. This past week the car sat at the airport outside parking and now the fan doesn’t come on no matter how long I drive it. I haven’t looked at anything yet but I am hoping for some advice and guidance before I start looking. OBTW: Off topic I recently replaced my windshield wipers with Rain-X replacement blades… I highly recommend them. Little pricy but worth it. Thanks, Rick
  7. full_jingbang

    "DUAL" Button in A/C

    Guys, I want to know the exact WORK of the button "DUAL" in A/C. I cannot understand from manual. When I press it, it just shows both (Driver & Passenger) side temperature.
×