Jump to content

Search the Community

Showing results for tags 'apim'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Ford Edge Forum
    • Welcome Forum!
    • Forum Help & Site Suggestions
  • Ford Edge Social Forum
    • Lounge
    • Articles, News & Reviews
    • Buying, Leasing & Ordering
    • Dealership & Vendor Experiences
    • Competing Crossovers & Vehicles
    • Facebook Pages
    • Multimedia
    • Owner Impressions
    • Super News Ticker
  • Ford Edge Lincoln MKX Modification and Technical Discussion
    • Accessories & Modifications
    • Ford Edge & MKX Member Builds
    • Alarms, Keyless Entry, Locks & Remote Start
    • Appearance - Detailing, Wash & Wax
    • Audio, Backup, Navigation & SYNC
    • Brakes, Chassis & Suspension
    • Cargo, Hauling, Roof Racks & Towing
    • Exterior & Body
    • Glass, Lenses, Lighting, Mirrors, Sunroof (BAMR), Wipers
    • Interior, A.C., Heat, Interior Trim
    • Recalls, TSBs & Warranty
    • Wheels & Tires
    • Ford Sync Specific Forum
  • Ford Edge & Lincoln MKX: Powertrain
    • 3.5L and 3.7L
    • EcoBoost
    • Edge RS
    • Edge ST
    • All Wheel Drive (AWD)
    • Transaxle (FWD)
  • Ford Edge, MKX Nautilus Model Year Specific
    • 2015+ Edge & MKX Generation II
    • 2007-2014 Edge & MKX Generation I
  • Classifieds
    • Classifieds
  • Test Forum
    • TEST FORUM
  • Ford Edge & Lincoln MKX: Interior
  • Ford Edge & Lincoln MKX: Recalls, TSBs & Warranty

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Found 4 results

  1. Hello, I saw another forum post about this topic but unfortunately it has not been active for multiple years. I have a 2011 Ford Edge SEL and unfortunately have been plagued with the black display screen. From what I have read it sounds like I have (like everyone else) a bad APIM. I was wondering if anyone had any idea on suggestions for an economical replacement or repair for this issue. I am also interested in purchasing or trading if anyone has a replacement that is on this forum (please let me know if not allowed and will edit post). Also if anyone can provide links or model numbers for a direct replacement. Thank you for all of your help in advance! 2011 Ford Edge SEL Vin: 2FMDK4JC8BBA94640 8 inch screen with Navigation
  2. Just purchased a 2011 Ford Edge Sport. Unfortunately, due to the age of the vehicle Ford is no longer honoring the recall for the APIM. I am wanting to purchase a "new" APIM. I want the most recent revision of the APIM that Ford has released. Details of my vehicle. 2011 Sport FWD with heated seats, Sony, HD, Sirius, dual zone, ambient lighting, back up camera, and a Nav APIM. Thanks, Scott
  3. So.... my 4 month old 2016 Edge SEL is back at the dealership for "computer gremlins, round 2". 3 weeks after purchase the two small screens in the instrument cluster came up with diagonal white lines through the graphics. This came and went over the 2 days till I could get it into the shop, luckily I had taken pics. I also told them that my clock would not stay on 24 hour time, every time you shut the truck off it reset. Lastly, my driver's seatbelt locked in the fully retracted position the night before service so I couldn't put the seatbelt on. Dealer replaced the seatbelt, replaced the entire instrument cluster, and flashed the software "fixing" my clock. Clock still won't keep 24 hour time, but due to other issues with this dealer we won't bring my truck or boyfriend's 2016 F-250 back to them. I figured I'd live with the clock until it was oil change time. 2 weeks ago I am on the highway when a graphic of the top view of the truck pops up on the nav screen covering my whole screen... Screen is frozen, button to turn radio off doesn't work, steering wheel controls do nothing. Finally touching the screen brings it back to the home screen. Later that night the radio decides it's going to start randomly scrolling through presets! No response from the touch screen again, use the control knob to turn the radio off. Wait a few min, turn it back on, still scrolling. Disgusted, I pull over and shut the truck off. Wait 2 min or so and restart and everything is fine. Radio does this 2 more times, and once on bluetooth streaming music it decides to fast-forward through songs. Finally, 2 days ago the touch screen freezes again, and the control knob does nothing - can't change volume, turn on or off, just stuck. Pull over, restart truck, still stuck. Turn truck off, go into gas station to get coffee, start truck, everything is fine! In speaking to the service manager this morning he says to me "I think that's why they called it an Edge - it'll drive you over the edge!". Great. I asked if he was seeing these issues a lot: "Oh yeah, it's bad. I'm surprised Ford hasn't recalled the APIM yet. We've done quite a few now on the '16s." Anyone else out there seeing this kind of thing and/or had to have APIM or cluster replaced??? Thanks!
  4. Thought I would add a video for those who are not sure if their APIM is broke or just a software issue. Mine is defiantly broke. It started once in while but is off more than it is on. To Ford's credit they are replacing it and updating the software sometime this week. No radio, no back up camera, but I do have active warning still working. The heat and AC still work, but you have no idea how fast the fan is running unless you listen for it. Many user interfaces are relieant on the APIM to work inside the Edge. Now waiting with anticipation for the new install and great working car that is fun to drive.
×