Jump to content

Search the Community

Showing results for tags 'bearing'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Ford Edge Forum
    • Welcome Forum!
    • Forum Help & Site Suggestions
  • Ford Edge Social Forum
    • Lounge
    • Articles, News & Reviews
    • Buying, Leasing & Ordering
    • Dealership & Vendor Experiences
    • Competing Crossovers & Vehicles
    • Facebook Pages
    • Multimedia
    • Owner Impressions
    • Super News Ticker
  • Ford Edge Lincoln MKX Modification and Technical Discussion
    • Accessories & Modifications
    • Ford Edge & MKX Member Builds
    • Alarms, Keyless Entry, Locks & Remote Start
    • Appearance - Detailing, Wash & Wax
    • Audio, Backup, Navigation & SYNC
    • Brakes, Chassis & Suspension
    • Cargo, Hauling, Roof Racks & Towing
    • Exterior & Body
    • Glass, Lenses, Lighting, Mirrors, Sunroof (BAMR), Wipers
    • Interior, A.C., Heat, Interior Trim
    • Recalls, TSBs & Warranty
    • Wheels & Tires
    • Ford Sync Specific Forum
  • Ford Edge & Lincoln MKX: Powertrain
    • 3.5L and 3.7L
    • EcoBoost
    • Edge RS
    • Edge ST
    • All Wheel Drive (AWD)
    • Transaxle (FWD)
  • Ford Edge, MKX Nautilus Model Year Specific
    • 2015+ Edge & MKX Generation II
    • 2007-2014 Edge & MKX Generation I
  • Classifieds
    • Classifieds
  • Test Forum
    • TEST FORUM
  • Ford Edge & Lincoln MKX: Interior
  • Ford Edge & Lincoln MKX: Recalls, TSBs & Warranty

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Found 3 results

  1. Does anyone have the Torque Specs for the Rear Wheel Hub Nut on an 2007 FWD Edge? I've gotta replace the pass side wheel hub tomorrow. Also, is the nut a 32mm socket?
  2. Does anyone know if there is a decent Aftermarket Rear Wheel Hub Assembly for an 07 Edge FWD? Timken, SKF, Moog ect. ?....
  3. sorry if this was posted somewhere else. anyway there is a rattle when starting off slow. its coming from the rear passenger wheel area. As the car starts out the clunking gets faster and it doesn't stay consistent with the spin of the tires just a gradual rattle. After 40-45 MPH it stops as if centrifugal force causes it to stop. It rattles and clunks when going over bumps and railroad tracks. It's a metallic rattle. I've looked underneath the car and to me it looked fine. The car steers fine and does not vibrate at all. It doesn't rattle in reverse or braking unless you hit a bump. Any help is useful thank you.
×