Jump to content

Search the Community

Showing results for tags 'climate control'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Ford Edge Forum
    • Welcome Forum!
    • Forum Help & Site Suggestions
  • Ford Edge Social Forum
    • Lounge
    • Articles, News & Reviews
    • Buying, Leasing & Ordering
    • Dealership & Vendor Experiences
    • Competing Crossovers & Vehicles
    • Facebook Pages
    • Multimedia
    • Owner Impressions
    • Super News Ticker
  • Ford Edge Lincoln MKX Modification and Technical Discussion
    • Accessories & Modifications
    • Ford Edge & MKX Member Builds
    • Alarms, Keyless Entry, Locks & Remote Start
    • Appearance - Detailing, Wash & Wax
    • Audio, Backup, Navigation & SYNC
    • Brakes, Chassis & Suspension
    • Cargo, Hauling, Roof Racks & Towing
    • Exterior & Body
    • Glass, Lenses, Lighting, Mirrors, Sunroof (BAMR), Wipers
    • Interior, A.C., Heat, Interior Trim
    • Recalls, TSBs & Warranty
    • Wheels & Tires
    • Ford Sync Specific Forum
  • Ford Edge & Lincoln MKX: Powertrain
    • 3.5L and 3.7L
    • EcoBoost
    • Edge RS
    • Edge ST
    • All Wheel Drive (AWD)
    • Transaxle (FWD)
  • Ford Edge, MKX Nautilus Model Year Specific
    • 2015+ Edge & MKX Generation II
    • 2007-2014 Edge & MKX Generation I
  • Classifieds
    • Classifieds
  • Test Forum
    • TEST FORUM
  • Ford Edge & Lincoln MKX: Interior
  • Ford Edge & Lincoln MKX: Recalls, TSBs & Warranty

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Found 5 results

  1. I was hoping someone may have had a similar problem or recommend what to investigate. When I start the car up after it has been sitting a while the passenger side climate control temperature quickly lowers itself from its initial setting (maybe 73) to LO. I can press the temperature and Dual setting buttons and it does not stop unless I press the climate control OFF. The driver side is fine. If the car is warm and restarted I do not see the problem. Thanks.
  2. Hello All, I have a 2011 Ford Edge and the climate control is not working at all via the touch screen. The control panel below my touch screen works, so I can turn the climate control on from there but the buttons within the climate control section of the touch screen do not work at all. So I cannot change what vents the air is coming out of and my heated seats will not turn on. The other odd thing is when I touch the screen the animation showing the button depressing happens, so I feel like the input is being recieved but no output is happening. Everything else on my screen works completely fine, steering wheel controls, I can blue tooth my phone, listen to music, make/accept calls. I have FORscan and went ahead and performed a self test on the following modules: APIM - PASS FCIM - PASS IPC - PASS HVAC - PASS I also performed module resets on: APIM - Success with no errors FCIM - Success with no errors IPC - Success with no errors HVAC - Success with no errors Body Control Module - Success with no errors I purchased a dealer service manual but wanted to post this problem here, I did try to search this issue but came up dry. Please let me know your thoughts or other trouble shooting steps that I may have missed. Thanks, Joe
  3. Just had maintenance last day of warranty today. The Service advisor used to be a mechanic and knows everything? I'm using the Auto Climate Control feature [which I used to be able to turn off.. but stays on and cannot be turned off] and have the cabin temp at 24c with outside ambient temp at 16c. The AC comes on and will not turn off. I'm actually asking for a little heat yet get cold air. The guy tells me to turn the AC off. Ok, got that part but where's the Auto feature? The manual - Climate Control Auto will adjust the cabin temp to whatever temp is set by turning the AC on or off as required. Am I missing something? Just new to the forum today, but have browsed topics before. I must say, this is a great place for Edge owners. Thanks for your input. -z
  4. Dear Community, Notice today that the rear air flow out of the center armrest/storage area thing was no more than a wisper. Wondering if anyone else has experienced this, and or a way to increase flow to rear vents Thanks Nate
  5. Hi, Am a new 2013 Ford Edge Limited Edition owner. I have had no problems with my car since December 2013 when I got it. Recently I noticed the passenger air vent was blowing hot air whenever I put on the air-conditioner. Could advise on what would have gone wrong? Charles, Thanks.
×