Jump to content

Search the Community

Showing results for tags 'clutch'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Ford Edge Forum
    • Welcome Forum!
    • Forum Help & Site Suggestions
  • Ford Edge Social Forum
    • Lounge
    • Articles, News & Reviews
    • Buying, Leasing & Ordering
    • Dealership & Vendor Experiences
    • Competing Crossovers & Vehicles
    • Facebook Pages
    • Multimedia
    • Owner Impressions
    • Super News Ticker
  • Ford Edge Lincoln MKX Modification and Technical Discussion
    • Accessories & Modifications
    • Ford Edge & MKX Member Builds
    • Alarms, Keyless Entry, Locks & Remote Start
    • Appearance - Detailing, Wash & Wax
    • Audio, Backup, Navigation & SYNC
    • Brakes, Chassis & Suspension
    • Cargo, Hauling, Roof Racks & Towing
    • Exterior & Body
    • Glass, Lenses, Lighting, Mirrors, Sunroof (BAMR), Wipers
    • Interior, A.C., Heat, Interior Trim
    • Recalls, TSBs & Warranty
    • Wheels & Tires
    • Ford Sync Specific Forum
  • Ford Edge & Lincoln MKX: Powertrain
    • 3.5L and 3.7L
    • EcoBoost
    • Edge RS
    • Edge ST
    • All Wheel Drive (AWD)
    • Transaxle (FWD)
  • Ford Edge, MKX Nautilus Model Year Specific
    • 2015+ Edge & MKX Generation II
    • 2007-2014 Edge & MKX Generation I
  • Classifieds
    • Classifieds
  • Test Forum
    • TEST FORUM
  • Ford Edge & Lincoln MKX: Interior
  • Ford Edge & Lincoln MKX: Recalls, TSBs & Warranty

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Found 2 results

  1. So I got a 2008 Ford Edge given to me by my work to use as a work truck. I live in Maui and have no cold air coming out the vents. Both The high side and low side are charged, don’t see any leaks on the condenser or the lines. The blower motor works and the blend doors cycle properly. The ac clutch turns on when engaged but doesn’t release unless turned off. The line that runs over the motor doesn’t get cold to the touch but it’s cooler then the the rest of the motor. The other line gets so hot it singed my finger when checking it. Any ideas as to what it could be? Checked the fuses swapped a relay and nothing seems to change. Any help would be greatly appreciated because it’s hot as the day is long out here and I need to get some cool air.
  2. SB-10053412-4688 Manufacturer Communication Number: ASI-32238 Summary FORD/LINCOLN: SOME VEHICLES MAY EXPERIENCE, A SLIPPAGE DURING SHIFTING OR POSSIBLE CLUTCH DAMAGE MIGHT HAVE HYDRAULIC FLUID LEAK IN VALVE BODY. MODELS 2013 EDGE, MKX, FLEX, TAURUS, MKT, MKS, MKZ. SB-10053412-4688 SOME 2013MY VEHICLES MAY EXPERIENCE, A SLIPPAGE DURING SHIFTING OR POSSIBLE CLUTCH DAMAGE - HYDRAULIC FLUID LEAK IN VALVE BODY.pdf
×