Jump to content

Search the Community

Showing results for tags 'dash'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Ford Edge Forum
    • Welcome Forum!
    • Forum Help & Site Suggestions
  • Ford Edge Social Forum
    • Lounge
    • Articles, News & Reviews
    • Buying, Leasing & Ordering
    • Dealership & Vendor Experiences
    • Competing Crossovers & Vehicles
    • Facebook Pages
    • Multimedia
    • Owner Impressions
    • Super News Ticker
  • Ford Edge Lincoln MKX Modification and Technical Discussion
    • Accessories & Modifications
    • Ford Edge & MKX Member Builds
    • Alarms, Keyless Entry, Locks & Remote Start
    • Appearance - Detailing, Wash & Wax
    • Audio, Backup, Navigation & SYNC
    • Brakes, Chassis & Suspension
    • Cargo, Hauling, Roof Racks & Towing
    • Exterior & Body
    • Glass, Lenses, Lighting, Mirrors, Sunroof (BAMR), Wipers
    • Interior, A.C., Heat, Interior Trim
    • Recalls, TSBs & Warranty
    • Wheels & Tires
    • Ford Sync Specific Forum
  • Ford Edge & Lincoln MKX: Powertrain
    • 3.5L and 3.7L
    • EcoBoost
    • Edge RS
    • Edge ST
    • All Wheel Drive (AWD)
    • Transaxle (FWD)
  • Ford Edge, MKX Nautilus Model Year Specific
    • 2015+ Edge & MKX Generation II
    • 2007-2014 Edge & MKX Generation I
  • Classifieds
    • Classifieds
  • Test Forum
    • TEST FORUM
  • Ford Edge & Lincoln MKX: Interior
  • Ford Edge & Lincoln MKX: Recalls, TSBs & Warranty

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Found 4 results

  1. around 20 & 140 mph on the speedometer the lighting is lower than the rest of the gauge. do I have a burned out bulb(s) or is this how it is on everyones? 2015 SEL
  2. Our 2013 Edge Limited 3.5L (with Dual Control Heater) is developing a squeak from the dash area. The sound is hard to describe but it sounds like a rubber vacuum actuator opening or closing and the rubber squeaks. EEEEKKK is what it sounds like. It was infrequent but now happens enough that my wife is starting to notice it. It is strange in that it can happen right after we shut off the car and we are still sitting inside. We also notice it at idle or when driving slow, on the highway the road noise would probably drown this out. I see that many folks are replacing the blend door actuator, which is what I suspect but has anyone had one that makes noise? Of course, when I remove the lower dash panel and listen for it it does not seem to make the noise. Thanks in advance for any help.
  3. I purchased a used 2011 Edge SEL 100K (but miles never scared me because I am pretty mechanical). I am feeling buyers remorse HARD! After test driving and no issues, just one thing after another now. I have had the car 35 days. I have already grounded the wire inside the Driver's door so that the Door Ajar issue is just eliminated. . The ISSUE: Dead battery this morning. Jumped it and let it run for about 10 min. (didn't know about the "Battery reset" this morning). Flash forward to 6pm Wife calls and says the interior lights are coming on as well as the tail lights,puddle lights, dash, center console, and the doors unlocked. Then all the lights would all go out randomly, or stay on for over an hour. Did the whole ordeal for the learn function (whatever the actual function was, I did it right, no more battery saver). Then drove for about 30 min. I no longer see the Battery save mode BUT I am still getting the lights and unlocking issue. . at first the I thought the original dead battery was from "not in park" issue. But we never got the warning "shift to park". The P would just not light up. And a couple finger bangs on the button fixed that. Thoughts please on main culprits? What could cause the lights to come on and unlock the doors? OH! I also noticed while in that dark with the lights off and doors locked the dash (speedo) would flicker and make a arcing sound but very very faint. . I just noticed the light on again and went out. wiggled and pushed and pulled the fuse box connectors that I could reach,blew compressed air in and around all the fuses twice. Seems a little dirty in there for a fuse box. I opened the drivers door all the way then closed and locked it up with the FOB and haven't seen the lights come back on in 2hrs. ODD!
  4. Anyone else have this happen? Recently had my 2013 Edge Limited in for the 3rd time to try and resolve an ambient lighting issue. They replaced the APIM, which did not solve the ambient lighting issue and now my dash does this when I receive a text message. Just wondering if this has happened to anyone else? Also, along with this issue the easy exit seat no longers works. Supposedly after the APIM was replaced they "tested" everything and it was fine.
×