Jump to content

Search the Community

Showing results for tags 'fuse'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Ford Edge Forum
    • Welcome Forum!
    • Forum Help & Site Suggestions
  • Ford Edge Social Forum
    • Lounge
    • Articles, News & Reviews
    • Buying, Leasing & Ordering
    • Dealership & Vendor Experiences
    • Competing Crossovers & Vehicles
    • Facebook Pages
    • Multimedia
    • Owner Impressions
    • Super News Ticker
  • Ford Edge Lincoln MKX Modification and Technical Discussion
    • Accessories & Modifications
    • Ford Edge & MKX Member Builds
    • Alarms, Keyless Entry, Locks & Remote Start
    • Appearance - Detailing, Wash & Wax
    • Audio, Backup, Navigation & SYNC
    • Brakes, Chassis & Suspension
    • Cargo, Hauling, Roof Racks & Towing
    • Exterior & Body
    • Glass, Lenses, Lighting, Mirrors, Sunroof (BAMR), Wipers
    • Interior, A.C., Heat, Interior Trim
    • Recalls, TSBs & Warranty
    • Wheels & Tires
    • Ford Sync Specific Forum
  • Ford Edge & Lincoln MKX: Powertrain
    • 3.5L and 3.7L
    • EcoBoost
    • Edge RS
    • Edge ST
    • All Wheel Drive (AWD)
    • Transaxle (FWD)
  • Ford Edge, MKX Nautilus Model Year Specific
    • 2015+ Edge & MKX Generation II
    • 2007-2014 Edge & MKX Generation I
  • Classifieds
    • Classifieds
  • Test Forum
    • TEST FORUM
  • Ford Edge & Lincoln MKX: Interior
  • Ford Edge & Lincoln MKX: Recalls, TSBs & Warranty

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Found 6 results

  1. Its been 3 days since my sync3 has been completely blacked out. Initially there were issues with connecting phone via bluetooth. After rebooting my phone, it got reconnected to SYNC however SYNC blanked out in few minutes and then never turned on. Currently my radio, navigation, bluetooth everything is not working. I tried pressing the power and tune+ buttons at the same time for few minutes, but nothing happened. I also tried removing the fuse, turned the car on for few minutes, then turned it back off, put the fuse back in. However no help. Please suggest any alternative method to resolve this issue, or is my module dead? I am thinking of showing it to a dealer, however my car is past the warranty. Any idea how much would the dealer charge for consultation and repair work? I am currently driving a 2012 Ford Focus SEL.
  2. Hi All, Firstly, thanks for all your diligent work on this forum, it's incredible. I recently replaced my: inner & outer tie rods, sway bar link, and both rear wheel bearing hubs on my 2008 Ford Edge AWD Limited, mostly thanks to forums and Youtube. Thanks! Now I'm stuck on trying to figure out why my fuse for the power seat and exterior power mirrors keeps blowing out. I've changed it like 3 times. They work for a few days, then blow out without me touching anything. One day they just stop working. I've removed the panel covering the wires looking for a short on the way to the seat, looked under the seat, and pulled up the switch for the mirrors and can't find a short anywhere. The fuse is " #12, 7.5 Exterior rear view mirror switch, Driver Seat Module (DSM), Left power seat switch " in the smart junction box. If anyone can help solve this mystery I will be forever grateful. My wife can't drive my Edge without me replacing the fuse so she can move the seat forward. Cheers, Luke
  3. I recently bought a 2007 ford edge with the 3.5L. It had a tail light out but I didn't think anything of it. Went to change the bulb and realized it was still good. checked the fuses and all were good. Come to find out the center wire for the brake light and turn signal was not getting power. the running lights work but the turn signals and brake light for the left rear corner does not. The dash indicator for the turn signal lights up and flashes fast when turning left. The front blinkers both work on both sides. I checked continuity from the light socket to the cabin fuse box and it runs true all the way. I gave the wire 12 volts and the light illuminates then. Are the cabin fuse boxes known to go out every once in a while? Not sure what else it would be. I also have continuity between the blinker switch left into the cabin fuse box as well.
  4. Hi All, While inflating the tyres of my MKX 2009, I blew the fuse of the cigarette lighter plug in the dashboard (photo below). Where is the fuse located exactly and what's the replacement model/specs? The digital tyre compressor is working fine in the other outlets. Cheers.
  5. 2010 Edge Sport. On Sunday woke up to my battery being dead. Boosted from my wife's car & on with my day. The next time i tried to open sunshade or operate glass since the boost...NOTHING First instinct was fuse...so i saw in the box located under the hood that fuse 18 is for the roof...checked it, looked fine, swapped it with another 20A fuse there....still nothing so not the fuse This morning on my way to work I keep playing around with the switches to see if its just a temporary thing. I was able to tilt the glass & return it....but then nothing again & sunshade did nothing. Is there a reset of some type? Another fuse I'm not aware of? The roof closed somewhat slower than new the last little while, but I've not hear ANY noises that would indicate motor/gear failure. Plus i'm assuming they operate on different motors (sunshade vs glass) Any thoughts or DYI recommendations???
  6. lwalcott

    2008 cruise control fuse

    I have a 2008 Limited. The cruise control has quit working. When I push the button the light does not come on. I thought maybe the fuse was blown but I cannot find one. I have looked in the manual and there is not one listed. Does anyone know where or if there is one. Also any other ideas would be apreciated as far as the cruise control not working.
×