Jump to content

Search the Community

Showing results for tags 'lost power'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Ford Edge Forum
    • Welcome Forum!
    • Forum Help & Site Suggestions
  • Ford Edge Social Forum
    • Lounge
    • Articles, News & Reviews
    • Buying, Leasing & Ordering
    • Dealership & Vendor Experiences
    • Competing Crossovers & Vehicles
    • Facebook Pages
    • Multimedia
    • Owner Impressions
    • Super News Ticker
  • Ford Edge Lincoln MKX Modification and Technical Discussion
    • Accessories & Modifications
    • Ford Edge & MKX Member Builds
    • Alarms, Keyless Entry, Locks & Remote Start
    • Appearance - Detailing, Wash & Wax
    • Audio, Backup, Navigation & SYNC
    • Brakes, Chassis & Suspension
    • Cargo, Hauling, Roof Racks & Towing
    • Exterior & Body
    • Glass, Lenses, Lighting, Mirrors, Sunroof (BAMR), Wipers
    • Interior, A.C., Heat, Interior Trim
    • Recalls, TSBs & Warranty
    • Wheels & Tires
    • Ford Sync Specific Forum
  • Ford Edge & Lincoln MKX: Powertrain
    • 3.5L and 3.7L
    • EcoBoost
    • Edge RS
    • Edge ST
    • All Wheel Drive (AWD)
    • Transaxle (FWD)
  • Ford Edge, MKX Nautilus Model Year Specific
    • 2015+ Edge & MKX Generation II
    • 2007-2014 Edge & MKX Generation I
  • Classifieds
    • Classifieds
  • Test Forum
    • TEST FORUM
  • Ford Edge & Lincoln MKX: Interior
  • Ford Edge & Lincoln MKX: Recalls, TSBs & Warranty

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Found 1 result

  1. I have a 2015 Edge 3.5L. We previously experienced the loss of power / stall issue (see http://www.fordedgeforum.com/topic/19171-edge-loss-of-power-stalling/).Dealership had the vehicle for about a week addressing this issue and a couple of other items. On Tuesday evening this week, our Edge stalled again--the first time since the PCM flash. This time, we were driving and the vehicle stalled. We were able to stop safely, and the vehicle started again after putting it in park. I contacted the dealer the next morning. Our salesman is a long-term employee and superb. Within the hour the dealership had involved 6 people including the owner. They asked us to bring the vehicle to them. They put us in a new Edge with only 8 miles in order to drive during a holiday trip and told us they would get this problem fixed. I am really pleased with the dealership. I am also concerned about whether they or Ford can get this problem fixed. Anyone else have the PCM flash and then their Edge stall after the PCM Flash? We have also lost about 3mpg in average mileage since the PCM flash.
×