Jump to content

Search the Community

Showing results for tags 'oil'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Ford Edge Forum
    • Welcome Forum!
    • Forum Help & Site Suggestions
  • Ford Edge Social Forum
    • Lounge
    • Articles, News & Reviews
    • Buying, Leasing & Ordering
    • Dealership & Vendor Experiences
    • Competing Crossovers & Vehicles
    • Facebook Pages
    • Multimedia
    • Owner Impressions
    • Super News Ticker
  • Ford Edge Lincoln MKX Modification and Technical Discussion
    • Accessories & Modifications
    • Ford Edge & MKX Member Builds
    • Alarms, Keyless Entry, Locks & Remote Start
    • Appearance - Detailing, Wash & Wax
    • Audio, Backup, Navigation & SYNC
    • Brakes, Chassis & Suspension
    • Cargo, Hauling, Roof Racks & Towing
    • Exterior & Body
    • Glass, Lenses, Lighting, Mirrors, Sunroof (BAMR), Wipers
    • Interior, A.C., Heat, Interior Trim
    • Recalls, TSBs & Warranty
    • Wheels & Tires
    • Ford Sync Specific Forum
  • Ford Edge & Lincoln MKX: Powertrain
    • 3.5L and 3.7L
    • EcoBoost
    • Edge RS
    • Edge ST
    • All Wheel Drive (AWD)
    • Transaxle (FWD)
  • Ford Edge, MKX Nautilus Model Year Specific
    • 2015+ Edge & MKX Generation II
    • 2007-2014 Edge & MKX Generation I
  • Classifieds
    • Classifieds
  • Test Forum
    • TEST FORUM
  • Ford Edge & Lincoln MKX: Interior
  • Ford Edge & Lincoln MKX: Recalls, TSBs & Warranty

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Found 11 results

  1. echotango

    2019 2.7L Oil Consumption Issue

    Please redirect me if this topic has been discussed. My 2019 Edge ST with the 2.7L ecoboost is consuming oil. It has used about 1.5 quarts in about 2,600 miles. I have done some searching, and while I find the same issue, there only seems to be articles and a Ford TSB for the 2016-2017 Edge/Fusion and Lincoln models as well as the F-150, all with the 2.7l engine from that generation. Does anyone have any knowledge of this with the current engine, or is mine a unique case? Seems a bit too coincidental that mine has the same problem as this previous gen engine. Info is appreciated, thank you! Current mileage about 70,400
  2. I am plagued with the dreaded oil leak. I have the ebay gasket waiting to be put on a new oil pan. I came across these alumnium oil pan on ali express and ebay. Has anyone seen or used these products? https://www.aliexpress.com/i/3256801712267930.html?gatewayAdapt=4itemAdapt https://www.ebay.com/itm/165955245815?hash=item26a3b416f7:g:UdYAAOSwn8BkhrPH&amdata=enc%3AAQAIAAAA4G7hAjNbZX5VB7p6kXLDTENFu%2Fwl47BZC2VT3TR6n6hCpR0AzwI7nUzfUO%2BZ2VEWe5GPl06FoEQiAa5N4S4ffuzzNeqZRo1b5%2BrkQn9R8vixYXAGZ%2F8k%2BlZHS%2FcTO7x7XYC3QFNQ8OyDgnbJCaFQKQVSrnyeO68sT7pFidImFpKISmdRdEd6%2F%2B2esQfxuUobmJ95%2BT5j9HMchLY9RbQScvmyWqEf8vfdIwTuW2K4HlRG9KxXzxqzMK1Jh2nzNk6cFtz5QvyxNO1RMk6bo1T7TURiFWASzTG95rbSo5vS9GAk|tkp%3ABFBMrvjNhMBi https://www.ebay.com/itm/125814640685?hash=item1d4b23102d:g:9zMAAOSw-QlkgaFG&amdata=enc%3AAQAIAAAA8NGWf3oFXW%2BADMsTd%2FWh4IKN0lKJQB0bbeur3tsniDNspBY%2BFdcriFlQVsFKun9kCJaGX6ZrAQrcKfbr8nbNOEmmFO7pkUTxDiuP0znzUcVR2JEaCEo5sZOd%2FbGJsKffBW6vFayWpAyM%2B96e40DYKG2Etfxx8EZzSTf3ZpfVla%2Fhcx69u9qwvtQGLdYsaLSgrssyg4RPI51RtwdKKwIkxqGfyiTUKPYUnOverYKvHERWGkD2MSUCW7HojBpvHlE0QortumxnFucUJVLBdGiAqfK4Qg75xBXVXneNMEBpCBqICj6Hu4Nu4eEs3HHPnxXZkw%3D%3D|tkp%3ABk9SR96DhIXAYg
  3. Changed the oil in the 2.0 Ecoboost. Installed a fumoto valve to make the oil changes easier and no tools.
  4. This is the first of a series of oil testing of virgin oil samples to show the additives in the oils before the oil is used. In some cases used oil samples will be compared to the virgin samples of the same brand and viscosity. The sample presentations will be compared two at a time with approximately twenty brands from house brands to the high end brands. Lube oil for the PTU will also be tested to show the additives in the lube oils. Most of the oil testing will cover oils used in the Duratec and Ecoboost the oils tested will be 5W20 synthetics. Viscosity does not play much of a part as the brands do in the testing. Viscosity will have little affect on the additives in the oils. No conventional or blended oils will be tested. Most used samples will be from a 3.5 Duratec and under severe driving conditions (high idle times and short trips) The other oil testing on a 3.5 will be mostly highway/interstate driving and some idle time. all filters were either AMSOIL high efficiency filters .25 micron or Purolator Boss high efficiency All vehicle used oil testing were Ford Edge Limited 3.5 FWD Most testing is measured in engine hours and not miles.
  5. ellygirl084

    Oil consumption - 2016 Sport

    Hi guys, Having a tough one here! My 16' Sport has been running with a Livernois tune for almost 3 years (mostly on 91 octane tow or performance tune). For the last year, I have also installed a JLT Catch Can (oil separator). It has ALWAYS underperformed, even before tuning when it was still brand new. I have never runned 0-60 below 6 seconds flat even with heavy left foot braking for boost buildup. It has also always smoked quite heavily, especially during winter time or below freezing temperature. It is mostly white smoke while weather is cold. What is bothering me even more is the actual amount of oil being catched in my oil separator. It was completely filled after 2000 miles of softly driven highway. I had to empty it at least 4 times between 2 oil changes. I told the dealer about white smoke (with pictures) and on my oil change, they saw the oil consumption because the level showing on the dipstick was quite low. They made basic checkups, and they filled it, sent me on the road for 1600, and made me come back to have a look. They told me I was inside boundaries fixed by Ford... But I know something is not right with my engine... White smoke (sometimes black), lots of oil being trapped in my catch can, low fuel milleage (especially for the last 20 000 miles). I don't know how if there's anything I can do to have it looked at thoroughly. Suggestion? Normal behaviour (which I guess it isn't)?
  6. I have a 2008 Ford Edge, with roughly 95,000 miles on it. The engine has been riding rough lately and making rattling noise while in drive. Took it to my mechanic and he said that the motor oil burned out and as he checked the stick, there was no oil visible. It took roughly 4 quarts of oil to get it to register on the oil stick. Mechanic said I need a new engine. Has anyone else had this problem? The Check oil light never went on prior to this. My options are to spend $4600 on a used engine, or salvage the car. Any suggestions?
  7. Sorry if this has been posted, but all I could find in this section was PTU threads, lots of them. Where's the Trans oil dip stick and top-up cap on the 2017 Sport ? My handbook shows to move the air filter intake to the side to access it, but I don't see it on mine. I'm looking at taking advantage of a good deal running on a pack of 12 quarts Motocraft Mercon LV, and will exchange the trans oil with this when I reach 50 or 60K miles. Edit: I found it, tucked away under the coolant hose. It would be best to remove the complete air filter box to access it.
  8. I was replacing the spark plugs on my 2011 edge this weekend and found a puddle of oil in the intake tube to throttle body, also found a lot of oil in the upper intake plenum and down inside intake. I know the pcv valve is shot, I removed it and it's nasty, so I am going to replace it. But the oil in the intake tube is from the vent tube on the front valve cover, what would cause this? I've read some stuff about a tsb on the valve cover baffles, but that is just on the eco-boost models right? Or would the bad pcv valve cause that much oil? Any advice is appreciated.
  9. Hello everyone, My car has a knocking problem after it almost ran out of oil from a valve gasket problem. Here is the video of the noise it's making. The high pitch tick has always been there and from what I read is fairly normal. It's the knocking noise like a noisy lifter when the engine RPMs go up. http://youtu.be/LrH7gKXy_v8 I'm hoping someone has had experience with this and can give me some information on where the problem is, and what it would take to repair it. Also, I know it's not a good idea, but how long I would be able to drive it in this condition. Here is the chain of events that put it into this condition: My engine was running fine. I have 45k miles on it. It was a Florida vehicle but I have been up in Chicago for school. The temperature dropped to below zero F, I let my vehicle warm up, then began to drive it into school, a seventy mile trip on the highway. Fifty miles into the drive and I heard a noise under the hood and pulled off to a truck stop, then I saw smoke and oil all over my engine. I checked the oil and nothing was on the dip stick. I put two quarts of oil into my engine, started it and let it run for about 10 seconds, shut it off and checked it again, with still nothing on the dip stick. I then added another quart of oil, turned the engine on again for a few seconds and for the first time my "Low Oil" light came on. Checked the dip stick and oil was only at the bottom so I added two more quarts. With the engine oil up to the proper level I got it to my friends house. Turned out the valve cover gasket went bad in the morning and blew all of my oil out. I replaced the valve cover gasket, and made sure the oil level was good. The engine was running fine, and not leaking. The next day on my way home, about 150 miles from the event, when I stopped for gas I heard the knocking noise that is in the video. The knocking noise happens in low gears. If I am going from 0-40 the knocking noise and loudness and speed match the speed of the engine. If I am in neutral or first and accelerating 1500 - 2000 rpms it's very noticeable. Second gear it's less noticeable. After I get over 45 mph and my engine shifts into the next gear the knock goes away and I wont hear it until I slow back down into the lower gears. Things that might be important: There is no coolant making it into my oil The knocking is quieter while my engine is cool. My engine never overheated It's not burning oil from what I can tell but may be too soon to tell I dont have blue smoke out of my exhaust My engine oil smells normal The knock sounds like it's coming from near the top of the engine or on the side closer to the firewall. I'll be monitoring this thread and will get back as often as I can and will keep everyone informed of updates. I'll be getting it into a mechanic as soon as I get my disability payment from the VA. Thanks everyone!
  10. firemedicman26

    Oil in the Intake

    I'm having this issue currently and I can't find any website that tells you how to fix this issue. Please help! MAY 01 2013 NHTSA Reference #10053358 TSB Reference #ASI-32211 Description: FORD: ON SOME VEHICLES, THE INTAKE AIR SYSTEM COMPONENTS MAY HAVE ENGINE OIL ACCUMULATION, IN LEFT HAND VALVE COVER BAFFLE MIGRATING THROUGH FRESH AIR INTAKE OF POSITIVE CRANKCASE VENTILATION (PCV) SYSTEM. MODELS 2011-2013 EDGE, EXPLORE
  11. 2007Edge

    Oil stains on driveway

    Hi, anyone can figure out what kind of liquid is this? I've checked under the edge but can't see any leaking spot? transmission oil, power staring oil , antifreeze or break fluid? battery acid????
×