Jump to content

Search the Community

Showing results for tags 'relay'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Ford Edge Forum
    • Welcome Forum!
    • Forum Help & Site Suggestions
  • Ford Edge Social Forum
    • Lounge
    • Articles, News & Reviews
    • Buying, Leasing & Ordering
    • Dealership & Vendor Experiences
    • Competing Crossovers & Vehicles
    • Facebook Pages
    • Multimedia
    • Owner Impressions
    • Super News Ticker
  • Ford Edge Lincoln MKX Modification and Technical Discussion
    • Accessories & Modifications
    • Ford Edge & MKX Member Builds
    • Alarms, Keyless Entry, Locks & Remote Start
    • Appearance - Detailing, Wash & Wax
    • Audio, Backup, Navigation & SYNC
    • Brakes, Chassis & Suspension
    • Cargo, Hauling, Roof Racks & Towing
    • Exterior & Body
    • Glass, Lenses, Lighting, Mirrors, Sunroof (BAMR), Wipers
    • Interior, A.C., Heat, Interior Trim
    • Recalls, TSBs & Warranty
    • Wheels & Tires
    • Ford Sync Specific Forum
  • Ford Edge & Lincoln MKX: Powertrain
    • 3.5L and 3.7L
    • EcoBoost
    • Edge RS
    • Edge ST
    • All Wheel Drive (AWD)
    • Transaxle (FWD)
  • Ford Edge, MKX Nautilus Model Year Specific
    • 2015+ Edge & MKX Generation II
    • 2007-2014 Edge & MKX Generation I
  • Classifieds
    • Classifieds
  • Test Forum
    • TEST FORUM
  • Ford Edge & Lincoln MKX: Interior
  • Ford Edge & Lincoln MKX: Recalls, TSBs & Warranty

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Found 3 results

  1. So I got a 2008 Ford Edge given to me by my work to use as a work truck. I live in Maui and have no cold air coming out the vents. Both The high side and low side are charged, don’t see any leaks on the condenser or the lines. The blower motor works and the blend doors cycle properly. The ac clutch turns on when engaged but doesn’t release unless turned off. The line that runs over the motor doesn’t get cold to the touch but it’s cooler then the the rest of the motor. The other line gets so hot it singed my finger when checking it. Any ideas as to what it could be? Checked the fuses swapped a relay and nothing seems to change. Any help would be greatly appreciated because it’s hot as the day is long out here and I need to get some cool air.
  2. Have a 2007 Edge fwd. Have had no problems until recently would not start shortly after being driven a few minutes earlier. Could not find similar thread. Turns over fine, not a battery issue. Fuel pump not making noise. Plenty of fuel in tank. Checked and switched around relays and fuses with no apparent fix. Jiggled wires above fuel tank/pump, with no apparent fix. Tapped (banged) on bottom of tank... seemed to work... turned key, fuel pump comes on, car cranks and runs fine for another week without even a sputter. Same thing again... no fuel pump noise, car not starting after being driven earlier that morning... did all of the above again... relays, fuses, tank wires, banging on tank... and this time reset the inertia switch in the back quarter panel. Nothing. Sits for 2 days, go to put in nuetral and roll back... put key in, turn key on, pump runs, car cranks and runs fine. Trying to avoid removing fuel pump from tank if there is any other possible solution. Any other thoughts or better ways to test relays for intermittent failure? Also, any idea what the fule pump diode is/does? Located with the relays and fuses, but just looks like a small black opaque fuse. I think it keeps power from traveling one way, but not sure if it can fail or how to check. Thanks, cb
  3. Jordangray25

    Help. Signal Relay location. Help.

    I can't locate the relay for my turn signals. Rear passenger turn signal is not blinking and front passer signal is blinking fast. I have checked the fuse and replaced all the bulbs. Anyone have a diagram or picture of where the relay is??? Manual doesn't show and I have taken enough parts off to look under the steering wheel but can't seem to find it. Any and all help is appreciated.
×