Jump to content

Search the Community

Showing results for tags 'repair'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Ford Edge Forum
    • Welcome Forum!
    • Forum Help & Site Suggestions
  • Ford Edge Social Forum
    • Lounge
    • Articles, News & Reviews
    • Buying, Leasing & Ordering
    • Dealership & Vendor Experiences
    • Competing Crossovers & Vehicles
    • Facebook Pages
    • Multimedia
    • Owner Impressions
    • Super News Ticker
  • Ford Edge Lincoln MKX Modification and Technical Discussion
    • Accessories & Modifications
    • Ford Edge & MKX Member Builds
    • Alarms, Keyless Entry, Locks & Remote Start
    • Appearance - Detailing, Wash & Wax
    • Audio, Backup, Navigation & SYNC
    • Brakes, Chassis & Suspension
    • Cargo, Hauling, Roof Racks & Towing
    • Exterior & Body
    • Glass, Lenses, Lighting, Mirrors, Sunroof (BAMR), Wipers
    • Interior, A.C., Heat, Interior Trim
    • Recalls, TSBs & Warranty
    • Wheels & Tires
    • Ford Sync Specific Forum
  • Ford Edge & Lincoln MKX: Powertrain
    • 3.5L and 3.7L
    • EcoBoost
    • Edge RS
    • Edge ST
    • All Wheel Drive (AWD)
    • Transaxle (FWD)
  • Ford Edge, MKX Nautilus Model Year Specific
    • 2015+ Edge & MKX Generation II
    • 2007-2014 Edge & MKX Generation I
  • Classifieds
    • Classifieds
  • Test Forum
    • TEST FORUM
  • Ford Edge & Lincoln MKX: Interior
  • Ford Edge & Lincoln MKX: Recalls, TSBs & Warranty

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Found 7 results

  1. AaronE

    "Rocker Panel" Rust

    Good evening all. Long time lurker, first time poster here with a doozy. I found rust (see attached photo) on my 2010 Ford Edge, that is otherwise in immaculate shape, that is almost all the way through at the bottom of where the rear drivers side door frame and fender meet (Ford parts online number 27840). If I am reading the parts diagram right, this will require removing the entire rear body side panel and installing a new one correct? Is there another way to make this repair that will not be so extensive? My less than educated idea would be to go to the junk yard and cut away a section of car and then weld in this donor piece to replace the rusted area. Any ideas and help would be greatly appreciated.
  2. edge2013own99

    Trouble turning on after refuel

    I have a 2013 Ford Edge Limited with around 100k kms on it, and it seems to be running fine. Though after refuelling, the car has trouble starting up, when turning on the car, the dash will come on but the wheel will remain frozen (as in I can't turn it), after attempting to turn on the car 2-3 times, it will eventually hit a turn on where you will hear the engine cranking for 15-20 seconds and it turns on normally after this. The issue then disappears till next refuel. Any advice is appreciated.
  3. selfmade6288

    Diagnostic/Technician Help Needed

    2010 Edge LIMITED, 120K+/-, owned for <30days. Have driven about 1k miles since purchase. Check Engine light has come on, showed 4 Codes: P0451 U0253 B2290 B1318 2 nights ago I drove <20miles during HEAVY rain, Edge was NOT driven through high water, but there were 3-4 places where water splashed/sprayed up while crossing. (Never heard that ominous of water beating undercarriage!) Parked having no issues. *May be unrelated: Opened remote start fob to change battery, seen the 1pc metal contact was loose on 1 side, put metal back into place, reassembled. (Brand unknown) Yesterday morning was cold maybe 20 degrees Used "repaired" fob to remote start. Rear Brake Aid On/Off & Driver Door Adjar were both lit up. Brake notification went out after taking off, Door note stayed on and int. lights were all on. (Opened/closed all doors 2x). After 4hrs Door notification was gone. This morning CEL was lit. Had codes read *see above*. Have been searching for info related to codes, possible trouble shooting ideas, how to determine which part is throwing which code, HOW TO FIX? Please let me know what will repair all this. Thanks Matt
  4. Our 2015 Ford Edge recently started a rattle noise when we start the engine. The noise goes away when we start driving and comes back again when we stop in a signal or take turns. We thought something not right. So, we took it to the dealership the next day. What dealership told us they think it's a broken flexplate and they gave me an estimate of 6,000$-8,000$ to fix that issue. The dealer asked Ford if they will cover the repair and Ford said they will only cover 1,450$. The edge has 66,000 miles on it, which is just over 6K miles from there 60,000 miles warranty. I have friends who work at Ford. After talking to them and reading a few other forum articles regarding this issue what I found out it is a very common issue for Ford, which is almost always a manufacturing fault. Ford even recalled certain run time Edge for that exact same issue. I asked my dealer why Ford is not covering all which is basically their manufacturing fault and they asked me to call Ford customer care directly. I just called them and they are basically blabbering the same thing saying we support what dealership recommends. If dealership thinks Ford will cover then Ford will otherwise just keep the receipt in case Ford decided to cover that in future. This is insane!!!!!!!!!!! FORD DOESN'T WANT TO TAKE RESPONSIBILITY OF THEIR OWN FAULT". They expect their customer to spend 5,000$ on a repair just after 4 years. Obviously a crack never happens suddenly. If probably started way before 60K miles. It's only large enough now to create a noise. A flexplate crack means there's something else wrong and ford should take responsibility for that. They can't expect their customer to pay expensive repairs on a new car. Should I take my car to a different dealership or a different repair shop to check? I can't afford 5,000$ repair.
  5. Our 2015 Ford Edge recently started a rattle noise when we start the engine. The noise goes away when we start driving and comes back again when we stop in a signal or take turns. We thought something not right. So, we took it to the dealership the next day. What dealership told us they think it's a broken flexplate and they gave me an estimate of 6,000$-8,000$ to fix that issue. The dealer asked Ford if they will cover the repair and Ford said they will only cover 1,450$. The edge has 66,000 miles on it, which is just over 6K miles from there 60,000 miles warranty. I have friends who work at Ford. After talking to them and reading a few other forum articles regarding this issue what I found out it is a very common issue for Ford, which is almost always a manufacturing fault. Ford even recalled certain run time Edge for that exact same issue. I asked my dealer why Ford is not covering all which is basically their manufacturing fault and they asked me to call Ford customer care directly. I just called them and they are basically blabbering the same thing saying we support what dealership recommends. If dealership thinks Ford will cover then Ford will otherwise just keep the receipt in case Ford decided to cover that in future. This is insane!!!!!!!!!!! FORD DOESN'T WANT TO TAKE RESPONSIBILITY OF THEIR OWN FAULT". They expect their customer to spend 5,000$ on a repair just after 4 years. Obviously a crack never happens suddenly. If probably started way before 60K miles. It's only large enough now to create a noise. A flexplate crack means there's something else wrong and ford should take responsibility for that. They can't expect their customer to pay expensive repairs on a new car. Should I take my car to a different dealership or a different repair shop to check? I can't afford 5,000$ repair.
  6. cmhhawaii

    2011 Edge SEL - Rough Idle

    I have been having an issue with my 2011 Edge running rough at idle. The edge has 77,000 miles. Here's the story: I was having trouble with a cylinder misfire under normal driving. The code read "misfire cylinder 5". I took it into the dealer. They told me I had a bad coil on cylinder 2. They would replace it for $800, but recommended replacing all of them for $2,500. I passed on their offer and performed the repair myself. I found a cracked insulator on the spark plug at cylinder 5. I replaced all of the coils and spark plugs anyways - for good measure. The misfiring cylinder was solved. Since I was under the hood and had the intake off, I took the opportunity to swap out my air filter and clean the mass airflow sensor. I bought a nice K&N air filter and installed it and cleaned the mass airflow sensor with CRC mass airflow sensor cleaner. After driving around for a while, I got a check engine light with fuel/air codes. I figured this was due to the increased airflow from the new high-performance filter. I swapped it out for a normal paper filter. The engine codes went away. Well, it seems these things come in threes: The following few weeks, the engine started running very rough at idle. I suspected a vacuum leak somewhere. I removed the intake manifold, to see if I had damaged a gasket , or forgot to connect a line. Everything looked good. Then, I checked the Emissions Vapor Canister Purge Valve and it does not appear to be malfunctioning. All the lines on the intake side appear to be seated correctly. Does anyone have any suggestions on where to look next? -Thank you in advance
  7. kawi137

    front bumper repair

    Hi Guys, I recently was in a minor fender bender and cracked my lower bumper, does any one know of anyway I can repair this if at all possible without dropping $500 on a new one? The crack is on the lower right corner thanks!
×