Jump to content

Search the Community

Showing results for tags 'spark plugs'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Ford Edge Forum
    • Welcome Forum!
    • Forum Help & Site Suggestions
  • Ford Edge Social Forum
    • Lounge
    • Articles, News & Reviews
    • Buying, Leasing & Ordering
    • Dealership & Vendor Experiences
    • Competing Crossovers & Vehicles
    • Facebook Pages
    • Multimedia
    • Owner Impressions
    • Super News Ticker
  • Ford Edge Lincoln MKX Modification and Technical Discussion
    • Accessories & Modifications
    • Ford Edge & MKX Member Builds
    • Alarms, Keyless Entry, Locks & Remote Start
    • Appearance - Detailing, Wash & Wax
    • Audio, Backup, Navigation & SYNC
    • Brakes, Chassis & Suspension
    • Cargo, Hauling, Roof Racks & Towing
    • Exterior & Body
    • Glass, Lenses, Lighting, Mirrors, Sunroof (BAMR), Wipers
    • Interior, A.C., Heat, Interior Trim
    • Recalls, TSBs & Warranty
    • Wheels & Tires
    • Ford Sync Specific Forum
  • Ford Edge & Lincoln MKX: Powertrain
    • 3.5L and 3.7L
    • EcoBoost
    • Edge RS
    • Edge ST
    • All Wheel Drive (AWD)
    • Transaxle (FWD)
  • Ford Edge, MKX Nautilus Model Year Specific
    • 2015+ Edge & MKX Generation II
    • 2007-2014 Edge & MKX Generation I
  • Classifieds
    • Classifieds
  • Test Forum
    • TEST FORUM
  • Ford Edge & Lincoln MKX: Interior
  • Ford Edge & Lincoln MKX: Recalls, TSBs & Warranty

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Found 3 results

  1. Blake Willis Ehret

    New To The Forum! Ecoboost turbo lag?

    Hey Guys, I know many forums require an OP in one of these welcome forums before you can post in certain topic forums so here it goes. just purchased my first FORD and so far I am amazingly pleased. 2012 Ford Edge SEL FWD 2.0L Ecoboost 116xxx miles Purchased for 10.5 which I thought was a steal. did my research and already knew about the common DOOR AJAR issue which I had replaced at the Dealer for about $300. but I got the dealership to knock off $500 for it so I felt very confident about this. i have put 2k miles on it since I purchased in early January 2017 and have had no problems since. I did however have a minor concern that I have noticed. and this might require moving this thread to another region on the website but i have been getting a little engine stutter since i had the spark plugs replaced at the dealership. i am not sure whether to attribute this to turbo lag or if the spark plugs may not have been seated properly by the dealership. this only happens around 1k rpm in first gear. any thoughts or info would be appreciated and I am sorry if this thread is in the wrong area. Best regards, B
  2. Embarrassed but amazed, that I drove 220K miles on the original set of spark plugs. I have attached a picture of one of the 6, but they all looked identical. Maybe with electronic control systems this is expected, but the gap being over twice recommendation, and only about 10% of the electrode, let alone they were pointed (picture attached is of one of the 6, the other 5 looked identical). Gap on the original plugs was average 0.110. The vehicle ran okay, 21.4 mpg, I am hoping to see some improvement with the new plugs (also change the rear injectors, although they were replaced at 80K, only 140K on them. The front injectors have 220K). I have put around 500 miles on the truck since the change, and I definitely feel improved performance. Torque and Fillup (android apps) are showing some improvement on mpg, but will not pass judgement until at least I run through two full tanks. Interested in feedback, is this out of the ordinary, as I have heard that new systems with high quality plugs can go 100K?
×