Jump to content

Search the Community

Showing results for tags 'stink'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Ford Edge Forum
    • Welcome Forum!
    • Forum Help & Site Suggestions
  • Ford Edge Social Forum
    • Lounge
    • Articles, News & Reviews
    • Buying, Leasing & Ordering
    • Dealership & Vendor Experiences
    • Competing Crossovers & Vehicles
    • Facebook Pages
    • Multimedia
    • Owner Impressions
    • Super News Ticker
  • Ford Edge Lincoln MKX Modification and Technical Discussion
    • Accessories & Modifications
    • Ford Edge & MKX Member Builds
    • Alarms, Keyless Entry, Locks & Remote Start
    • Appearance - Detailing, Wash & Wax
    • Audio, Backup, Navigation & SYNC
    • Brakes, Chassis & Suspension
    • Cargo, Hauling, Roof Racks & Towing
    • Exterior & Body
    • Glass, Lenses, Lighting, Mirrors, Sunroof (BAMR), Wipers
    • Interior, A.C., Heat, Interior Trim
    • Recalls, TSBs & Warranty
    • Wheels & Tires
    • Ford Sync Specific Forum
  • Ford Edge & Lincoln MKX: Powertrain
    • 3.5L and 3.7L
    • EcoBoost
    • Edge RS
    • Edge ST
    • All Wheel Drive (AWD)
    • Transaxle (FWD)
  • Ford Edge, MKX Nautilus Model Year Specific
    • 2015+ Edge & MKX Generation II
    • 2007-2014 Edge & MKX Generation I
  • Classifieds
    • Classifieds
  • Test Forum
    • TEST FORUM
  • Ford Edge & Lincoln MKX: Interior
  • Ford Edge & Lincoln MKX: Recalls, TSBs & Warranty

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Found 1 result

  1. I had 2 cylinders misfiring, 2 and 3. Replaced all the spark plugs, and took to a shop to diagnose why it was still misfiring. They replaced 2nd and 3rd ignition coils. Previous shop replaced 2nd fuel injector, swearing that was the problem (didnt help misfire, but have 1 new fuel injector). Drove good for about 100 miles, then Check Engine lights came on with a P2197 code diagnostic. Replaced MAF because shop said that's most common issue with that code. I cleared the code, haven't had a problem since, but it still smells like something's burning under the hood. I'm not too mechanically inclined so I dont have a lot of tools or equipment but I'm trying to save money instead of throwing it into shops all the time. I was going to buy fuel injector cleaner and hope that eliminates the smell, buy does anyone know why it would still smell like burning? Is something still wrong? Edit: Its a sick sweet smell, only noticable in idle.
×