Jump to content

Search the Community

Showing results for tags 'walnut creek ford'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Ford Edge Forum
    • Welcome Forum!
    • Forum Help & Site Suggestions
  • Ford Edge Social Forum
    • Lounge
    • Articles, News & Reviews
    • Buying, Leasing & Ordering
    • Dealership & Vendor Experiences
    • Competing Crossovers & Vehicles
    • Facebook Pages
    • Multimedia
    • Owner Impressions
    • Super News Ticker
  • Ford Edge Lincoln MKX Modification and Technical Discussion
    • Accessories & Modifications
    • Ford Edge & MKX Member Builds
    • Alarms, Keyless Entry, Locks & Remote Start
    • Appearance - Detailing, Wash & Wax
    • Audio, Backup, Navigation & SYNC
    • Brakes, Chassis & Suspension
    • Cargo, Hauling, Roof Racks & Towing
    • Exterior & Body
    • Glass, Lenses, Lighting, Mirrors, Sunroof (BAMR), Wipers
    • Interior, A.C., Heat, Interior Trim
    • Recalls, TSBs & Warranty
    • Wheels & Tires
    • Ford Sync Specific Forum
  • Ford Edge & Lincoln MKX: Powertrain
    • 3.5L and 3.7L
    • EcoBoost
    • Edge RS
    • Edge ST
    • All Wheel Drive (AWD)
    • Transaxle (FWD)
  • Ford Edge, MKX Nautilus Model Year Specific
    • 2015+ Edge & MKX Generation II
    • 2007-2014 Edge & MKX Generation I
  • Classifieds
    • Classifieds
  • Test Forum
    • TEST FORUM
  • Ford Edge & Lincoln MKX: Interior
  • Ford Edge & Lincoln MKX: Recalls, TSBs & Warranty

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Found 1 result

  1. Please forgive the long post here, I've tried to explain things as well as possible... 2013 Ford Edge SEL 3.7 originally purchased from Walnut Creek Ford, August 2013. I have used this car since approx. 3500 miles and have had issues with Walnut Creek Ford Service center, which have either been ignored or not considered. The time alone I have wasted EXPLAINING the issues I've had is enough to just be done with it and sell the car. Issues that include, but are not limited to the following; At approx. 28k miles I brought the car in due to a worrying, persistent noise that was coming from the transmission. Dropping the car off, left it there for a day. Went to collect the car and was told by service technician that when different people drive the car, the car will have to get used to the new driver (I made her REPEAT this to me in front of witnesses) and that the noise is normal under these circumstances (my brother also drove the car occasionally). I left there unsatisfied with the explanation, and less than two weeks later experienced a fire starting from the transmission. The trans was replaced by Ford, at their expense. At that time I had also explained that the passenger side airbag light was on, and could they please fix the problem. Four or five services and 2+ years later (the most recent being mid 2016 in which they had me rent a car because the issue was to take 2-3 days to fix, I paid $100.00 at this time for a 'deductible') and still, passenger side airbag light still on. If this had been my personal daily driver things would have been done differently, as I would have performed work myself. I have done all the oil changes since I've been driving it religiously every 3-5k miles. I'm curious to know if anybody here has had experience with Walnut Creek, California Ford Service center, or does anybody have advice as to how to proceed more effectively to affect a satisfactory outcome? I've spoken with the service manager 2 or 3 times about the issue, and still no passenger side airbag. Thanks, in advance and again sorry for the long post.
×