Jump to content
Sign in to follow this  


Recommended Posts

With my previous MFT version 2.7, I had all the nice album art on my USB stick.


Did the new upgrade this past Friday and now I have no album art from the same USB stick.


Have tried all of the apparent USB setting combinations to no avail.


Tried a master system reset and still no art.


Anyone else have this happen and find a way to restore the display of the album art?


Many thanks in advance.



Edited by flightplannerjim

Share this post

Link to post
Share on other sites

Mine seems hit and miss so I am wondering if there is a limit to the file size or something.

Share this post

Link to post
Share on other sites

If you are still interested... I spent WAY too much time recently adding album art to my MP3 collection (Like 1500 tunes...) to show in the new 2013 Edge. Finally completly successful, but I found a few interesting things... The Edge (MyFort Touch) is somewhat particular as to the album art that it will display, some art is just not liked but a pretty small percentage. I could not pin it down as to either the graphics format (should be .jpg) or the file size, it will display over 500 x 500 pixel files and over 300k bytes in size (most album art is much smaller, like 50K). I found a very cool free program the find art (I have no idea where it looks...) and will embed it in the MP3 by choice quickly and easily...


What threw me was the fact that MyFord Touch actually remembers some aspects of the MP3 setups from Flash Drives. When you put in a new flash drive it categorizes it and then generates voice commands for it all... BUT if I put in a new MP3 file where I had ONLY changed the album art (Same filename, etc) it would NOT show the new art. Drove me crazy... BUT if I removed all files from the flash drive, let MyFord Touch discover the EMPTY flash drive and tell me it was empty, then put all the files back on it and let it refind and load everything again, then all the art would show...


If your art disappearred, remove all the files from the Flash drive (temporarily copy to PC), let the Edge recognize that flash drive as empty. Put all the files back on and let the Edge reload them all, ad I bet they will magically reappear...



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this