Jump to content

Possible fix for stuck at Loading... screen when you browse all channels with Sirius

Recommended Posts

Hello All,


So I had my Edge for less than a week and I have already experienced one MFT lockup. Pulling over and shutting off the car fixed that, hopefully reoccurances will be less versus more. I'm in IT so I understand software will lockup so we'll see.


Anyway a separate problem that I"ve read others having is long "Loading..." screen when you browse Sirius channels and select Browse all Sources as opposed to viewing them by categories. I was just exploring the MFT and tried that, and that screen became stuck there for 3 days. Even after turning the car off and on over that time, of course. I could use the MFT fine, Sirius direct tune, presets, etc. but when I went back to Browse Sirius channels that same loading screen would come up. So I decided to start pushing buttons until I could stop that from happening, below is what seemed to force a reset of the browsing to categories vs. all sources, although I can't 100% say that for sure as the problem could have just resolved itself on it's own while I was playing around.


Go to Sirius


Set Category for Seek/Scan

select a random category and then go back to the one you want.


Then when you go back to Sirius...Browse...it should be back to by category. Maybe if someone else has this problem they can try those steps and see if they help. I'm too much of a wuss to try and lock mine up again.

Share this post

Link to post
Share on other sites

You know, I have this loading problem with my iPod. When I go to browse my playlists, it sits a the loading screen often. Normally, I'll just unplug the device and when MFT switches over to the radio, Ill plug it back in and it works fine. However, sometimes when I unplug the device it reboots MFT!! Screen goes black and it eventually comes up saying Running scheduled system maintenance. This has happened to me 2-3 times this month. My iPod is less than a year old and probably only has about 8gb of songs on it, so nothing intensive.

Share this post

Link to post
Share on other sites

I had the same issue with my new Explorer where it was stuck at loading screen when I tried to browse by categories. I tried to steps below above to fix and it worked and the loading screen is gone and browse by category is working normally now. Thanks for posting so I didn't have to take it into the Ford dealer.

Edited by akirby
changed below to above

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now