Jump to content
Sign in to follow this  
adkinsplace

Door ajar

Recommended Posts

I think they need to recall the driver door mechanism. The door ajar keeps coming on and we have googled it and a lot of people are having the same problem. Ford wants to charge $500 to replace it. NO WAY!

Share this post


Link to post
Share on other sites

If you are handy or a DIY type person, do a search on the forum and see how to replace it yourself. There are many posts which also suggest a way of trying to clean the mechanism by using different sprays.

Share this post


Link to post
Share on other sites

Issue is with the tiny spring the forces the contacts of the door switch sensor back when the door is closed. Seems a combination of spring fatigue and crud confusing the issue. Poor design.

Share this post


Link to post
Share on other sites

HAHA! Replaced all door switches on my Edge under warranty a month or so ago, and the dreaded door ajar light is beginning to return. Crap crap crap!

Share this post


Link to post
Share on other sites

Yes. Complete junk. But at least the engine and tranny seem to be holding up ok. <cross fingers and toes>

Now for the stupid Service Trac System light that occasionally comes on.

  • Like 1

Share this post


Link to post
Share on other sites

I had the "Door Ajar" issue earlier this year. :doh: Glad it was covered by warranty.

  • Like 1

Share this post


Link to post
Share on other sites

I am having the door ajar warning. Just bought my 2013 Edge SEL on the 18th of October...

Share this post


Link to post
Share on other sites

Your 2013 Edge SEL... how many thousand miles or kilometres?

When I test drove mine, it had a bit less than 50,000 km's on it, and from the very first outing the door ajar began. Thought it was my imagination at first. At first it occurred very rarely until a couple thousand below 60,000 km's. Eventually it occurred so much even while driving being set off that it was driving me nuts.

I had to select OK to clear the instrument panel and view the tachometer and petrol gauge. It really was only ever the driver door that caused issue.

Now, I must correct myself. Earlier I posted that the dealership had replaced the switches under the 60,000 warranty. Upon further, um... investigation, the switches were NEVER replaced. ONLY a cleaning ever took place. Clean the contacts, clean the spring, clean the whatever. Bolted back up, and I was on my merry way. That lasted just enough to clear the 60,000, and oh, up until about 65,000. Then it began to creep back in again. This time the ajar warning was mixed with the SERVICE ADVANCE TRAC soon amber, yellow warning patch and lower right red illuminated graphic.

I brought my Edge in. This time the switch(s) in the door latches and the gear selector in the console was replaced. This seems to have solved the problems for now.

My guess it will be BACK again. Maybe in another 50,000 km's or so.

UPDATE:

The transmission and engine seem to be solid still. Should I hold my breath? lol

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×