Jump to content
Mark S Grantom

Wipers won't turn off!

Recommended Posts

I have a 2011 Ford Edge Limited. It has been in the shop twice because the windshield wipers have a mind of their own. These are the non-automatic wipers. When I turn them OFF, they will continue to cycle as if they are on the low intermittent setting. (about every 25 seconds) The dealer replaced the steering column switch, which solved the problem for a while, but they just started coming back on again this week. Does anybody have a suggestion on how to fix this problem? Thanks

  • Like 1

Share this post


Link to post
Share on other sites

I had the exact same problem. I replaced the switch lever on the steering column and the problem was fixed. The parts have a warranty, get it replaced again.

Share this post


Link to post
Share on other sites

I have a 2011 Ford Edge Limited. It has been in the shop twice because the windshield wipers have a mind of their own. These are the non-automatic wipers. When I turn them OFF, they will continue to cycle as if they are on the low intermittent setting. (about every 25 seconds) The dealer replaced the steering column switch, which solved the problem for a while, but they just started coming back on again this week. Does anybody have a suggestion on how to fix this problem? Thanks

HI Mark,

 

Have you had a chance to visit your dealer on this? Please let me know, along with your mileage, and I'll see how to best assist.

 

Meagan

Share this post


Link to post
Share on other sites

I have the same problem. Meagan are you with Ford? Because after the 10 or 11 times I've brought this car in for SYNC problems, the constant un-Ford like rattles and noises, and now this unsafe and out-of-warranty problem, I'm about to give up on this car. This is really unlike any Ford I've ever owned.

 

Anybody have a cure or fix for this intermittent wiper issue?

Share this post


Link to post
Share on other sites

I'm experiencing the same issues. I recently went on travel and had the pleasure of driving two to three hours in rainy weather. Anywho, when I selected the second or third notch on the lever, the wipers worked as advertised for about a minute and then the wipers would speed up extremely fast. I rotated the switch lever on the steering column back to the first notch for the wipers to work as normal. I'm suspecting the wiper switch is fault/intermitting. Any suggestions and or recommendations would be greatly appreciate. Thanks.

Share this post


Link to post
Share on other sites

I'm experiencing the same issues. I recently went on travel and had the pleasure of driving two to three hours in rainy weather. Anywho, when I selected the second or third notch on the lever, the wipers worked as advertised for about a minute and then the wipers would speed up extremely fast. I rotated the switch lever on the steering column back to the first notch for the wipers to work as normal. I'm suspecting the wiper switch is fault/intermitting. Any suggestions and or recommendations would be greatly appreciate. Thanks.

 

Follow the suggestion in post #2

Share this post


Link to post
Share on other sites

My 2013 Edge is experiencing the same wiper problems - will not shut-off until I shut off the engine. My local Ford dealer says they can look into the problem for $100. per hour. They don't have a clue why this is happening. The wipers continue to run on the dry winshield - which almost caused an accident - this is a very dangerous failure - with Ford not willing to fix unless I pay for a huge amount of investigation time.

 

I have had Fords for many years - still have a Ranger as well. I can't believe that I bought the very expensive Edge Limited - and Ford will not fix my problems - because I have 55k miles.

 

I think it is time to move to another auto manufacturer that understands computers and software. My SYNC system is a real pain to work with.

Share this post


Link to post
Share on other sites

My 2013 Edge is experiencing the same wiper problems - will not shut-off until I shut off the engine. My local Ford dealer says they can look into the problem for $100. per hour. They don't have a clue why this is happening. The wipers continue to run on the dry winshield - which almost caused an accident - this is a very dangerous failure - with Ford not willing to fix unless I pay for a huge amount of investigation time.

 

I have had Fords for many years - still have a Ranger as well. I can't believe that I bought the very expensive Edge Limited - and Ford will not fix my problems - because I have 55k miles.

 

I think it is time to move to another auto manufacturer that understands computers and software. My SYNC system is a real pain to work with.

Hi chocobear,

 

Your dealer is a great first step in finding a diagnosis for your wipers. Did you go through with the diagnostic, or did you decline? I can check into some additional assistance.

 

Meagan

Share this post


Link to post
Share on other sites

I too have a 2013 Edge with the intermittent wiper issue. It is dangerous when the wipers continue to come on. I now have 40,000 miles and am out of warranty. The dealer can check it at $90 an hour but it may not even be doing it when I take it as it is intermittent. Very frustrating when it is barely out of warranty on miles. This is my second Edge and previously I owned GM products for over 20 years. Not sure what to do from here.

Share this post


Link to post
Share on other sites

omar302 Thank you so much for this link. Definitely worth a try!

Share this post


Link to post
Share on other sites

I'm new to this forum but wanted to say that my wipers have started to do the same thing and not turn off.... very annoying... We bought ours as certified pre-owned and opted for the extended bumper to bumper warranty, will this be covered by this warranty? If not I see the part is Motorcraft SW-7037. Will replacing this do the trick and make the wipers stop doing whatever they want? How hard is to replace this switch, does anyone know is someone has done a write up on how to replace this?

Share this post


Link to post
Share on other sites

My Edge was also a certified pre-owned but did not cover this repair under warranty.

I did purchase the OEM part on ebay for around $30 and had my local repair guy replace it. Problem solved for around $50. I don't think it was a difficult repair but with an airbag I didn't want to attempt it.

Share this post


Link to post
Share on other sites

I don't see the MFS specifically listed in the CPO warranty, but if nothing else, you could approach it as being a safety concern.attachicon.gifCPO_Warranty.pdf

 

Not sure what an extended B2B warranty is. Closest would be PremiumCare ESP, AFAIK.

 

I believe it is the PremiumCare warranty we purchased or something similar. I will have to look at our paper work again.

Share this post


Link to post
Share on other sites

Good morning everyone

 

for the ones that have this issue with their ford, mine is Ford Edge 2011 AWD SE, I got the same issue and got fixed by replacing the OEM part (the switch) which purchased on ebay, no need to go further details, just replace the switch by yours and that is it, costed 36 USD for me.

Share this post


Link to post
Share on other sites

Good morning everyone

 

for the ones that have this issue with their ford, mine is Ford Edge 2011 AWD SE, I got the same issue and got fixed by replacing the OEM part (the switch) which purchased on ebay, no need to go further details, just replace the switch by yours and that is it, costed 36 USD for me.

here is the ebay link that I bought the switch from:

 

http://www.ebay.com/itm/NEW-OEM-WIPER-AND-WASHER-SWITCH-2011-2013-FORD-EDGE-FORD-EXPLORER-LINCOLN-MKX-/361182161240?fits=Year%3A2011%7CMake%3AFord%7CModel%3AEdge&hash=item5418226958:g:ZCgAAOSwEeFVTnA9&vxp=mtr

  • Like 1

Share this post


Link to post
Share on other sites

I have the same problem with my windshield wipers. Try to shut them entirely off, but the slow intermittent cycle still stays on. How annoying. What is the fix. Can I buy and part and replace it myself. How have you all solved the problem. Thank you.,

Share this post


Link to post
Share on other sites

I have the same problem with my windshield wipers. Try to shut them entirely off, but the slow intermittent cycle still stays on. How annoying. What is the fix. Can I buy and part and replace it myself. How have you all solved the problem. Thank you.,

It seems you missed the post just above yours!

Share this post


Link to post
Share on other sites

Having the same problem and it is driving me nuts. I now have to drive 200 miles with this annoying issue. I have had so many annoying issues with my 2012 Edge that I will definitely not purchase a Ford in the future. I have an appointment scheduled but se this is a known issue with Ford I feel they should be doing something to fix the problem rather than charging customers for this fix.

 

 

 

Between this wiper issue and an coil issue I am having it is now going to cost me $1100 dollars for a car that has less than 55K miles on it. FORDS SUCK!!! Never Again!!!!

Edited by mac66

Share this post


Link to post
Share on other sites

I have the same issue, BUT I have a fix for it....

I am not sure it is the right way, but at least it did stopped..

 

What I have done was, turn the wipers on, any speed should be fine, during that,push the lever downward(the one swipe mode), during in the one swipe mode, turn off the wipers to 0.

 

This had fixed my problems for a couple of times. I do not guarantee it will work, but try it.

  • Like 1

Share this post


Link to post
Share on other sites

Neither of my 2011's have a wiper issue. If I did I most likely would perform swap tronics due to the low cost and ease of replacing the wiper control. IF that did not fix it then diagnostics would be in order.

Share this post


Link to post
Share on other sites

I just wanted to add I have had the same problem with my 2011 Edge for months. Wipers come on when car is started and act as though they are in intermittent mode. Nothing turns them off other than turning the ignition off. I've yet to see much of a concrete answer but there are several forums with dozens who have the same problems. Absolutely frustrating!

Share this post


Link to post
Share on other sites

My wifes started to operate today until I realized they were on Auto and I had just entered the car wash.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×