Jump to content
Edge e DJ

Check Engine Light Ecoboost 2.0

Recommended Posts

Anyone else have this issue? It seems as though I have been plagued by continuous problems on my 2013 Edge Ecoboost. All have been covered by warranty so far, but that will eventually end. The most recent problems I have had were with the Check Engine light. I brought it to the dealer, they ran the diagnostics, and confirmed the O2 sensor in Back 1 Block 1 needed to be replaced. About a month later, the CEL cam on again. Once again brought it to the dealer, they ran the diagnostics, and determined that 4 injectors needed to be replaced. Both of these were done under the Power Train and Emisions warranty, but I am a bit concerned. Should I have noticed if the injectors were faulty? Would the engine not be mis-firing or blowing smoke? None of this was evident. Just the sad little orange light on the dash.

 

Am I worrying about nothing? Did I buy a Lemon?

 

Any suggestions would be helpful!

Share this post


Link to post
Share on other sites

The good news is that it seems ALL the injectors were replaced, so you don't have to worry about one that wasn't replaced :) This should save the catalytic converters considerable grief and improve their longevity. You'd think there would be symptoms though, right, if the injectors are having a problem? Usually symptoms crop up before a CEL gets set. Like fuel smell, lower mpg, hesitation during power delivery, etc. I have seen TSBs on everything in the fuel system but the injectors. So yeah, IDK.

 

What other problems have you experienced with the Edge? So far it does not seem like you got a lemon, but additional history would help shape opinion.

Share this post


Link to post
Share on other sites

History to date:

Drivers door open - this is a 2 step service bulletin. First they lube the mechanism and reset the warning. When (not if) it occurs again, they replace the latching mechanism which fixes the problem

 

Car not in park - this occurs when you put the car in park and then open the door. This was an immediate fix. The dealer installed a new shifter.

 

Check Engine Light (1st time) - The dealer changed the O2 sensor in Bank 1 block 1

 

Check Engine Light (2nd time) - The dealer changed all injectors

 

And NOW 1 day after coming out of the dealer from the previous repair- Tire Pressure Montior Malfunction. The tires are all at the correct pressure, so there is a malfunction on the system somewhere.

 

So far it has all been under warranty, but the TPSM will not be.

 

I bought the vehicle 2nd hand from a dealership 1 year and 1 month ago.

 

I love the car, but fear it may not have a reciprocal love for me!

Share this post


Link to post
Share on other sites

It would definitely get annoying to have these issues! As far as the TPMS, does it come on after 10 miles or so, after having let the car sit & cool down, then driven? That's what it does to me, and re-training has not worked. I HAVE heard that in some cases, if you air down all 4 tires to below 28 psi (let's say 25 psi), let it sit for a while like that, then air the tires back up to the recommended pressure (35 psi?), that might get the TPMS warning to go away.

 

The procedure from a Ford Focus forum:

1) Make sure your tires are inflated to the recommended psi. Mine is 40psi.

2) Turn ignition to the on position. If you have a push button start, push the start button without pressing the brake pedal.

3) Push the hazard light button 6 times. The horn should honk and you should see "Train left front tire" in the LCD display between the tach and speedo.

4) Release air pressure in the front left tire until you hear the horn honk. The LCD display should now read "Train right front tire".

5) Release air pressure in the right front tire until you hear the horn honk.

6) Repeat for the the right rear tire, and then the left rear tire.

7) You should now see "Training Complete" in the LCD display.

8) Fill your tires back up to the recommended pressure.

Edited by WWWPerfA_ZN0W

Share this post


Link to post
Share on other sites

Hi OP, sorry about the problems you are having. I have had mine since March and so far so good.

I hear that TPMS problem goes away after a while. Are you still dealing with that problem?

I got that TPMS warning light too but thats because I purchased a set of 4 wheels that were on Jeep liberty and installed them on mine. I'm just gonna ignore that warning light until when I put the original Ford wheels back on.

Share this post


Link to post
Share on other sites

Well the Check Engine light has returned for a third time!

I brought it in to the dealer, and they diagnosed a code P0219A. This is s fuel to air ration imbalance from what I understand. Anyone ever have a similar code? What did you do to fix it? I have a sneaking suspicion the Catlytic Converter is going bad as the exhaust doesn't smell normal.

 

Recap​

1st check engine light - Dealer changed an O2 sensor in Bank 1 Block 1

2nd check engine light - Dealer changed all 4 injectors

3rd check engine light - Dealers says it is code P0219A and reset the code. Told me to drive it and come back if the light comes on again.

 

This does not seem right to me???

 

Any thoughts?

 

Cheers

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×