Jump to content
Ford Edge Forum
mjonis

Top likes/dislikes about 2016 Edge

Recommended Posts

I've had my '16 Edge for 6 months now and I can't help but really HATE the SYNC 3 system! :rant2: I was never able to make my phone properly with it and neither the dealer. Also there no easy to erase old addresses from the "Previous Adresses" menu, etc… Funny but the older SYNC in my '11 MKX was much more user friendly, my phone used to work in it and I could erase previous addresses as often as I wanted. I find it a big step backwards, not an improvement from the first generation SYNC!

 

Claude. :swear:

 

 

Sync 3 was one of the reasons why I ended up buying the Edge. Why do you need to erase previous addresses? And what kind of phone do you have?

Share this post


Link to post
Share on other sites

If you hate Sync 3, I don't even want to know how badly you will hate Toyota's Entune system. I have that in my Toyota and it is the worst infortainment interface I have ever seen in my life. I have owned the previous Sync system as well in numerous vehicles and really enjoyed it. However I see Sync 3 leaps and bounds better even though it does have a learning curve to it. It is probably the best infortainment interface I have ever experienced

Share this post


Link to post
Share on other sites

I've had my '16 Edge for 6 months now and I can't help but really HATE the SYNC 3 system! :rant2: I was never able to make my phone properly with it and neither the dealer.

What phone do you have?

Here's a website that details which phones and carrier's will work with Sync 3.

https://owner.ford.com/how-tos/sync-technology/all/phone/phones-compatible-with-sync.html#?year=2016&model=Edge&syncGen=sync3&country=us

Edited by enigma-2

Share this post


Link to post
Share on other sites

That site is highly suspect. Both of my Samsung S6 phones have trouble working with Sync3. Trouble with phone contacts and I continuously have to un-pair them and then go through the process....again and again. I never had troubles with MFT or MLT. The dealer has looked at it 4 times now in my Edge....can't fix the issues.

Share this post


Link to post
Share on other sites

 

 

Sync 3 was one of the reasons why I ended up buying the Edge. Why do you need to erase previous addresses? And what kind of phone do you have?

 

It's not really because I have to delete them…but I liked having that option in my previous vehicle.

and

 

What phone do you have?

Here's a website that details which phones and carrier's will work with Sync 3.

https://owner.ford.com/how-tos/sync-technology/all/phone/phones-compatible-with-sync.html#?year=2016&model=Edge&syncGen=sync3&country=us

My phone is a Sonim XP 5520 which worked fine in my '11 MKX.

Edited by 2FAST4U

Share this post


Link to post
Share on other sites

 

 

It's not really because I have to delete them…but I liked having that option in my previous vehicle.

and

 

My phone is a Sonim XP 5520 which worked fine in my '11 MKX.

 

 

A what? I'm guessing that a new phone would solve your issues.

Share this post


Link to post
Share on other sites

Your problem may be the Bluetooth version on your phone. Perhaps it can be updated

Share this post


Link to post
Share on other sites

That phone is over 4 years old and got poor reviews to begin with. I'd say it's the phone and not Sync.

Share this post


Link to post
Share on other sites

That site is highly suspect. Both of my Samsung S6 phones have trouble working with Sync3. Trouble with phone contacts and I continuously have to un-pair them and then go through the process....again and again. I never had troubles with MFT or MLT. The dealer has looked at it 4 times now in my Edge....can't fix the issues.

 

Hey Hermans,

 

If the dealer hasn't found a resolution to your issue, have them contact their Tech Hotline for further assistance.

 

Cara

Share this post


Link to post
Share on other sites

2015 Edge Sport with Pano roof and 21" wheels.

 

Likes:

Effortless power

Looks great

Openness the pano roof makes it feel like

Quiet interior

 

Dislikes:

Pano roof squeeks/creaks

Poor seat back cooling (even with TSB performed)

Seat comfort after 2 hour or longer drive

Coverage of front OEM all-weather floor mats

No 2nd row USB charge ports

Factory trailer hitch not available on Sport

Share this post


Link to post
Share on other sites

 

Hey Hermans,

 

If the dealer hasn't found a resolution to your issue, have them contact their Tech Hotline for further assistance.

 

Cara

They did. Came back and said the system was very buggy. Maybe when there's the first upgrade....we'll see...

  • Like 1

Share this post


Link to post
Share on other sites

They did. Came back and said the system was very buggy. Maybe when there's the first upgrade....we'll see...

Hermans,

 

Keep me posted.

 

Shaay

Share this post


Link to post
Share on other sites

I dislike how much noise my driver side panel makes. I dislike how my back end (Hatch) shakes and rattles. The sound from outside driving is loud. I miss my 2014 Edge so much. This 2016 Edge sucks. I want my money back. Take it to the dealer and they hear nothing. Acting like I am crazy ..

  • Like 1

Share this post


Link to post
Share on other sites

What do you mean sound from outside driving? This new generation Edge is really quiet.

 

That driver side panel noise may be that coin drawer thing under the light switch. That should be an easy fix for the dealer. Do you have the panoramic roof?

Share this post


Link to post
Share on other sites

If you hate Sync 3, I don't even want to know how badly you will hate Toyota's Entune system. I have that in my Toyota and it is the worst infortainment interface I have ever seen in my life. I have owned the previous Sync system as well in numerous vehicles and really enjoyed it. However I see Sync 3 leaps and bounds better even though it does have a learning curve to it. It is probably the best infortainment interface I have ever experienced

 

My 4Runner had the Entune and you're right. That system was absolutely horrible. In the span of a year that system would randomly wipe itself back to all factory settings atleast 3 times for no reason. Not to mention the interface selections were so small and the screen itself so small, that I always hit the wrong thing.

 

I still hate touch screens in cars but the interface on the Sync 3 is better than most. I do wish there was an option for it to go back to home screen after maybe 10-15 seconds. That's one thing the Entune had that I miss.

 

I also still hate the fact that IA doesn't unlock the rear doors if the ignition is on and you try to open it from the outside. I do this alot to let my kids out and always have to remember to unlock the doors. They're too little to open them from the inside.

Share this post


Link to post
Share on other sites

I also still hate the fact that IA doesn't unlock the rear doors if the ignition is on and you try to open it from the outside. I do this alot to let my kids out and always have to remember to unlock the doors. They're too little to open them from the inside.

 

Can you expand on the use case here? The engine is running, you're outside the car with the fob and you try to open the rear doors?

 

I do wish there was an option for it to go back to home screen after maybe 10-15 seconds. That's one thing the Entune had that I miss.

 

I prefer for it to stay on the screen I selected which is almost always the Audio screen. I hated that every time you started the car MFT would start on the home screen. Of course an option would let you do it either way.

Share this post


Link to post
Share on other sites

I just tried opening the rear door, key fob in pocket, engine running, drivers door open.

Before I tried I was sitting in car motor running with doors locked.

Rear door opened I first pull.

Share this post


Link to post
Share on other sites

 

Can you expand on the use case here? The engine is running, you're outside the car with the fob and you try to open the rear doors?

 

 

I prefer for it to stay on the screen I selected which is almost always the Audio screen. I hated that every time you started the car MFT would start on the home screen. Of course an option would let you do it either way.

 

Yeah - optional. So those that wanted it to stay can, those that want it to revert can.

 

The IA thing is random and drives me nuts.

 

Example: Taking my kid to school. She's not quite old enough to open the door on her own.

So I pull into the parking spot and put it in Park.

Key is in my pocket.

I get out and close my door. (vehicle is running)

I attempt to open the driver's rear door, it is locked.

I try again, no such luck. Door remains locked.

After a random number of attempts, the door unlocks and I can open it.

or

It remains locked and I have to re-open my door and unlock all locks via the door button.

 

Please note, there are other days where doing the same exact steps and the rear door immediately unlocks.

 

I've now reverted to telling my kid to pull on the handle twice and so far that's worked.

 

To me, it's the IA not properly detecting the key. I'm standing in the same spot each time.

Share this post


Link to post
Share on other sites

I just tried opening the rear door, key fob in pocket, engine running, drivers door open.

Before I tried I was sitting in car motor running with doors locked.

Rear door opened I first pull.

 

Hence my insanity.

 

Try it with the drivers door being closed before opening the rear door.

Share this post


Link to post
Share on other sites

So when the doors are all locked and you walk up and grab the rear door handle on the driver's side - does that unlock the vehicle every time?

Share this post


Link to post
Share on other sites

So when the doors are all locked and you walk up and grab the rear door handle on the driver's side - does that unlock the vehicle every time?

 

Yes.

Share this post


Link to post
Share on other sites

Is it possible you're standing in a different position when getting out of the driver's door causing the fob to be too far away from the sensor sometimes?

Share this post


Link to post
Share on other sites

It might have something with the engine running and the rear door locked. Are there child protective locks in the rear?

When you exit the car with the motor running and close the front door does the horn blow?

Edited by oldtreker

Share this post


Link to post
Share on other sites

I just tested it and even with child lock setting on, you should be able to get out with the car running (key in pocket) and open the rear doors. You can hear them unlock. Sounds like a door sensor issue. I even tried "stickin' my butt out" haha just to see if a little more distance from my pocket with the key to the door made a difference, and it did not. Worked every time.

Share this post


Link to post
Share on other sites

I just tested it and even with child lock setting on, you should be able to get out with the car running (key in pocket) and open the rear doors. You can hear them unlock. Sounds like a door sensor issue. I even tried "stickin' my butt out" haha just to see if a little more distance from my pocket with the key to the door made a difference, and it did not. Worked every time.

 

I know - again, hence my insanity on the issue.

 

Some times it works exactly as described. Other times, I can stand there and pull on the handle 10 times and it's locked. It's completely inconsistent behavior which is my big pet peeve with IA.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×