Jump to content
jonesboys310

2011 Edge 3.5l non eco-boost oil in the intake system

Recommended Posts

I was replacing the spark plugs on my 2011 edge this weekend and found a puddle of oil in the intake tube to throttle body, also found a lot of oil in the upper intake plenum and down inside intake. I know the pcv valve is shot, I removed it and it's nasty, so I am going to replace it. But the oil in the intake tube is from the vent tube on the front valve cover, what would cause this? I've read some stuff about a tsb on the valve cover baffles, but that is just on the eco-boost models right? Or would the bad pcv valve cause that much oil? Any advice is appreciated.

Share this post


Link to post
Share on other sites

AFAIK, the oil in the intake tube could just be from a clogged PCV valve. OR it could mean that you need a new rear (bank 1) valve cover to solve the issue that afflicts some of this MY Edge and Explorer vehicles.

Share this post


Link to post
Share on other sites

while reading around the interwebs, it looks as if the valve cover in question is the front or left side as referred to by ford, for the fresh air intake on the PCV system, i looked at some photos of the rear or right valve cover and it is empty inside, i do not see any baffles, does this seem correct?

Share this post


Link to post
Share on other sites

Good question. The dirty side, or bank 1, definitely has a baffle, not sure on the clean side, or bank 2.

Share this post


Link to post
Share on other sites

I don't know. All I know it is the cover of the bank facing the front of the Edge (with oil fill cap). It was replaced on my MKX under warranty for the same issue & I can clearly see the new cover.

Edited by omar302
  • Like 1

Share this post


Link to post
Share on other sites

Ok, so Bank 2 then. Thanks! Can you take a pic & post please (even if it doesn't look any different)? Part number handy? TIA.

Edited by WWWPerfA_ZN0W

Share this post


Link to post
Share on other sites

Just ordered the valve cover and pcv valve. So we will see how it looks, I'll get photos of the old part and the new part to see if there is any physical difference. It has been superseded 3 times so I am guessing it is updated for sure.

  • Like 2

Share this post


Link to post
Share on other sites

Interesting. Hope it works. I have two 2011's and not experiencing much of any oil issues. I have a little bit of oil in one Edge but it is far easier to just wipe the oil out and clean it with MAF cleaner and be done with it.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×