Jump to content
DD2000GT

Edge Shift to Park Warning Message

Recommended Posts

Replaced the switch today. The second time is easier . We'll see how long this one last. If this one only last a couple years, I'll order the one from Ford. I'll have an extra switch if the Ford one goes bad is a couple years :)

Share this post


Link to post
Share on other sites

I had to look up my old post to get the part numbers again as one of the microswitch posts broke allowing the switch to pivot when placed into park and causing this message to appear again after two years since last fixed. Looks like quite a few people have had this issue since my initial post - glad to have saved so many people money and frustration from this little switch. Buy extras and keep them under the console cover for the next time this switch goes out you will already have them on hand.

 

Oh, and the Omran rep I talked to originally could not "confirm" the part they have is the exact same as Ford's, but hinted it was and Ford bought them from them. So, the $23 Ford part mentioned above is probably the same $5 microswitch from Mouser Electronics - just with the unique shaped switch arm if your gets bent or broken.

 

Dan

Edited by DD2000GT
  • Like 4

Share this post


Link to post
Share on other sites

It looks like I have this issue too on my 2015 Sport, and it drained my battery. The message popped up and wouldn’t let me even depress the brake to shift out of park and back in. The battery is currently charging.

 

Will I be able to depress the break and clear this shift when the battery is charged fully, and if not, what can I do?

Share this post


Link to post
Share on other sites
6 hours ago, OoSockMonkeyoO said:

It looks like I have this issue too on my 2015 Sport, and it drained my battery. The message popped up and wouldn’t let me even depress the brake to shift out of park and back in. The battery is currently charging.

 

Will I be able to depress the break and clear this shift when the battery is charged fully, and if not, what can I do?

 

 

Try wiggling the shifter to get the warning off. Try several times. You have to move the shifter down to remove everything to get to the bad switch (not sure on your 2015). Should be an 'over ride' for the shifter. A hidden button with a cover over it. Look at your owners manual, it should say something about it :)

  • Like 1

Share this post


Link to post
Share on other sites
3 hours ago, WWWPerfA_ZN0W said:

first incidence I have seen on a gen 2.

 

 

I wonder if the switch is the same one or what the difference is. I would search it just for fun but I just mowed my yard and about to die :(. Not really die but tired, old age :(

  • Like 1

Share this post


Link to post
Share on other sites
On 11/13/2020 at 2:06 PM, David Young said:

I would search it just for fun but I just mowed my yard and about to die :(. Not really die but tired, old age :(

That's what they make neighbor kids and riding mowers for!

 

TSB 17-2219 does cover gen 2 Edges, so I suspect yes.  GT4Z-3F988-B

https://drive.google.com/file/d/1Fd9AruEDRLarbrLUFPUsHTma_sjLyGpY/view?usp=sharing

prices have gone up substantially since the intial release.  May be time to get your own Omron switch lol.

Edited by WWWPerfA_ZN0W
  • Like 2

Share this post


Link to post
Share on other sites

I have the 2013 for edge front wheel drive and the other day I stopped at a friends house and put the car in park but the vehicle never came out of gear, i had to drive it home with the shifter in the park position and just turn it off.  Now the car's shifter is in park but the car still rolls when shut off.  I am looking for any guidance.

Share this post


Link to post
Share on other sites

a) use the parking brake when parked :)

b) search the forum for shift switch issues.  Ford has issued an updated switch to fix the "shift to park" warning, which can also drain the battery over time.

  • Like 1

Share this post


Link to post
Share on other sites

Our 2014 Edge Limited with 60,000 miles was giving the same message: "Transmission not in Park. "

Bought the Mouser electronics part (bought two of them just in case) and swapped out the old switch with the new one. Tested it a few times before I put everything back together. Thanks for the post and great step by step instructions!! 

Share this post


Link to post
Share on other sites

Has anyone had this issue, with key start ignition? Or only push to start? I called Ford today they said the TSB is only relevant for push to start ignitions.  But I am having the same exact issues, as that TSB states shift to park, shift indicator lights remain on when I exit the vehicle. Key gets stuck in the ignition. I was told I would have to replace the whole shifter probably, or it may be the gear selector on the side of the transmission. But it won't have anything to do with this switch. Somebody please chime in to help me.. Thank you..

Share this post


Link to post
Share on other sites
8 hours ago, Scott'sSEL said:

Has anyone had this issue, with key start ignition? Or only push to start? I called Ford today they said the TSB is only relevant for push to start ignitions.  But I am having the same exact issues, as that TSB states shift to park, shift indicator lights remain on when I exit the vehicle. Key gets stuck in the ignition. I was told I would have to replace the whole shifter probably, or it may be the gear selector on the side of the transmission. But it won't have anything to do with this switch. Somebody please chime in to help me.. Thank you..

 

The TSB (Link to the TSB), also states "or unable to remove the integrated keyhead transmitter (IKT)", so it does include vehicles with key start ignition.

  • Like 3

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×