Jump to content
Sign in to follow this  
Blake Willis Ehret

New To The Forum! Ecoboost turbo lag?

Recommended Posts

Hey Guys,

 

I know many forums require an OP in one of these welcome forums before you can post in certain topic forums so here it goes.

 

just purchased my first FORD and so far I am amazingly pleased.

 

2012 Ford Edge SEL

FWD

2.0L Ecoboost

116xxx miles

 

Purchased for 10.5 which I thought was a steal.

 

did my research and already knew about the common DOOR AJAR issue which I had replaced at the Dealer for about $300. but I got the dealership to knock off $500 for it so I felt very confident about this.

 

i have put 2k miles on it since I purchased in early January 2017 and have had no problems since.

 

I did however have a minor concern that I have noticed. and this might require moving this thread to another region on the website but i have been getting a little engine stutter since i had the spark plugs replaced at the dealership. i am not sure whether to attribute this to turbo lag or if the spark plugs may not have been seated properly by the dealership. this only happens around 1k rpm in first gear.

 

any thoughts or info would be appreciated and I am sorry if this thread is in the wrong area.

 

Best regards,

 

B

 

 

Share this post


Link to post
Share on other sites

Welcome! Please start a new thread in the appropriate section for the stutter. It isn't turbo lag.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×