Jump to content
Sign in to follow this  

2013 Ford Edge Limited Navigation Issues After Dead Battery

Recommended Posts

First time poster.


I'm having some issues that seemed to start after my battery died several times over the winter. I'm trying to avoid going to the dealer as much as possible because I am on a limited income and have a disability.


Battery Issue: My battery was dying quite regularly over the winter, I believe because of the close proximity to my key fobs (in apartment), and limited vehicle use (once a week average). My key fob batteries seem to be end of life, because I have to put them in the center console to start the vehicle. But I'm holding back replacing the batteries until I find a good faraday cage to put my keys in.


Does anyone have any suggestions for keyfob faraday cages?


Navigation Issue: I don't know exactly when the navigation issue started, but it seemed to happen after my battery stopped dying on me. My GPS position is fixed at the location where my GPS last worked (my apartment). My compass direction does not change when driving.


On the navigation screen below, you can see that I am not receiving a signal.




I also entered the diagnostic menu via Eject + Seek Forward combination and the results are below incase the picture can't be opened.

GPS Diagnostic Information Screen
UTC Time: 24:60:60 UTC Date: 02/19/10

Latitude: XXX.XXXX (Fixated on last acquired) Compass Direction: N (incorrect, vehicle is facing West)

Longitude: XX.XXXX (Fixated on last acquired) Heading: 0.00

Altitude: 30000 (obviously wrong) Speed: 255 (obviously wrong)


# Satellites: 255 H DOP: 1000.0

Dimension: 0 P DOP: 1000.0

Position: 1 V DOP: 1000.0



Steps I've tried to troubleshoot

- My Ford Touch master reset

- Disconnect battery (brief 5 minute, and overnight 8+ hours)

- Vehicle Health Report (no GPS related issues in report)

- Fuse check

- Disconnected GPS-enabled dash cam to eliminate possible signal interference

- Ensured latest firmware is installed

- Re-flashed firmware


I've tried to look for documentation beyond the owner's manual on the navigation system, but haven't had much luck.


Is there anything else I can do to avoid taking it to the dealer? I'm comfortable replacing parts, so I'd rather avoid the high cost of going to the dealer, but I'm at a loss as to where the actual problem is. Is this indicative of a bad antenna, a short or loose wire, a separate module, an abstract component or fuse I'm missing, is it the head unit?


I'd appreciate any suggestions. I'd really like to avoid going to the dealer if possible.



Share this post

Link to post
Share on other sites

You have tried so much already, I would guess that your problem is actually a non-functioning GPS module. I suggest checking fuse #26 (5a) to see if it's blown.

Share this post

Link to post
Share on other sites

There are some TSBs related to the GPS, but I will have to look at the specifics. As far as a Faraday cage, usually tin foil is enough, try a mylar bag.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this