Jump to content
ben senise

Comprehensive List of Possible Forscan Mods?

Recommended Posts

Perfect!Gadjetjq 

I did save asbuilt to a thumb drive just to have a backup.

Thanks again as always

Share this post


Link to post
Share on other sites
On 2/18/2020 at 2:55 PM, Gadgetjq said:


You could certainly give it a try.  If it doesn't work then nothing gained but nothing lost either. 
Using FORScan go to the following address. Write down your current settings before making any changes:

 

Change Power Point Time Out (H/M/S)

BCM

726-39-01 **** xxxx xxxx Power Point MaxTime Cfg (seconds converted to hex)

 

Use this spreadsheet link. Adjust the timeout you want in line 3, note hex in first column, change BCM **** accordingly.


 

 

 

Tried that out but I it was very bad idea.

Unfortunately this way didn't work and  now I can't return it to the factory values!

I keep getting error when I hit “Write”:  "[17:12:41:891] Service procedure has been interrupted".

After communicating with FORScan Support they replied;
 

Quote

 

Hello,

It was very bad idea to manage 2014- Edge configuration using 2015 F-150 spreadsheets as their BdyCM module configurations are *completely* different. 2015+ F-150 has the same BdyCM configuration and 2015+ Edge, and 2014- Edge has the same configuration as 2014- F150 but these 2 BdyCM are completely different. Recommended way to manage module configuration in FORScan is Module Configuration function that allows to manage module configuration in human friendly form (list of parameters). Last version of FORScan has Power Point configuration parameter available for your car this way.

 

As for the parameter you actually changed, it is PATS Timed method. You have disabled PATS TIMED method so now FORScan or any other scanner, including dealerhsip, will be unable to program PATS in your car. This parameter can be changed in only one direction and cannot be changed back by security purpose (BdyCM returns security error when you try to return it back). It is not a drama if you are not going to program keys. Unfortunatley, at this moment we don't know how to fix this kind of problems (hope get this knowledge in the future).

 


 

 

 :(

Share this post


Link to post
Share on other sites

Found something new in ForScan, not sure if it was there before v2.3.32, but it is nice. In IPC configuration, you replace the Instant Fuel Economy Bar to an actual reading. Also it can enable a "per Hour" display when the engine is idling. In US units, it'll show g/h and metric will be L/h. But I did notice that the instate numerical display doesn't work very good when in miles/gallon units or Km/L. When coasting, there would be no fuel consumption, so the reading would go to 999.9 Mpg (or km/h), but then it would take a long time for it to adjust to a realistic reading. But when in L/100km, the reading is realistic. Anyway, it is still better than a useless bar & the per hour view when idling is also good. Found out that when stopped, the engine uses more fuel when in "D" than in "P".

 

Another thing I found is the Speedometer "Calibration". There is a EU and US setting. Mine was EU and my speedometer always read about 5km/h higher than the GPS speed. Also the displayed speed would be higher than what was displayed in the Engineering menu. When I changed the calibration to US, the speedo now became within 1 km/h of the GPS speed and Engineering mode's display.

 

 

Fuel Economy History.JPG

IMG_20200417_095710.jpg

IMG_20200419_065435.jpg

IMG_20200419_065830.jpg

IMG_20200419_065943.jpg

IMG_20200419_070127.jpg

IMG_20200419_071309.jpg

IMG_20200422_071001.jpg

  • Like 2

Share this post


Link to post
Share on other sites
On 4/22/2020 at 7:11 AM, omar302 said:

Found something new in ForScan, not sure if it was there before v2.3.32, but it is nice. In IPC configuration, you replace the Instant Fuel Economy Bar to an actual reading. Also it can enable a "per Hour" display when the engine is idling. In US units, it'll show g/h and metric will be L/h. But I did notice that the instate numerical display doesn't work very good when in miles/gallon units or Km/L. When coasting, there would be no fuel consumption, so the reading would go to 999.9 Mpg (or km/h), but then it would take a long time for it to adjust to a realistic reading. But when in L/100km, the reading is realistic. Anyway, it is still better than a useless bar & the per hour view when idling is also good. Found out that when stopped, the engine uses more fuel when in "D" than in "P".

 

Another thing I found is the Speedometer "Calibration". There is a EU and US setting. Mine was EU and my speedometer always read about 5km/h higher than the GPS speed. Also the displayed speed would be higher than what was displayed in the Engineering menu. When I changed the calibration to US, the speedo now became within 1 km/h of the GPS speed and Engineering mode's display.

 

 

Fuel Economy History.JPG

 

 

 

 

 

 

 

 

Great finding! It would be interesting to find out what changes are in IPC as-built config. Unfortunately, all those direct configs available are vehicle specific and not always work as intended corrupting something else along with the changes applied. Those direct changes have mostly been tested on Kuga/Focus platform.

Share this post


Link to post
Share on other sites

Does anyone know if there's a way to control the individual diodes in the signature lights through forscan? 

There are 4 diodes inside, I can swap 2 of them out with amber diodes. But I need to be able to address them individually through the software. Otherwise, to turn them to switchbacks, I'd have to replace the entire board with a custom setup. That may be the better option anyways, but I'm just taking a look and seeing what my options are. 

TIA! 

IMG_20200503_170857.jpg

Share this post


Link to post
Share on other sites

I've never seen anything like that in FORScan.  You 'do' have the option to switch the DRL from socket to socket in front but not fine tuning down to the diode level.  The good news is, Switchbacks are fairly inexpensive (around $20 gets you a set of bulbs and a harness).  If you have the tools you could take apart the sockets to access circuitry and transplant it to your other housing. 

 

Share this post


Link to post
Share on other sites
2 hours ago, Gadgetjq said:

I've never seen anything like that in FORScan.  You 'do' have the option to switch the DRL from socket to socket in front but not fine tuning down to the diode level. 

 

 

Thats about what i expected, thanks for confirming.
 

Quote

The good news is, Switchbacks are fairly inexpensive (around $20 gets you a set of bulbs and a harness).  If you have the tools you could take apart the sockets to access circuitry and transplant it to your other housing. 

 

Thats definitely a reasonable option. I was thinking thats probably what id have to do to get it where i want it. pulling the board out and putting some small switchback LEDs in and wiring them myself is something i feel i'm capable of. Will take some planning though. Thanks for the help!

Share this post


Link to post
Share on other sites
On 9/29/2017 at 6:11 PM, enigma-2 said:

This the one I use with my Android.

 

ScanTool 426101 OBDLink MX Bluetooth: Professional OBD-II Scan Tool for Android & Windows https://www.amazon.com/dp/B006NZTZLQ/ref=cm_sw_r_cp_apa_GhTZzbR0P8B0F

 

Can't modify the car's internal settings (need laptop for that), but you can monitor hundreds of values.

You need this OBDII adapter to make any changes.

https://www.amazon.com/stores/OBDLink/page/6AB05129-8520-4122-BBD6-31712037F639?ref_=ast_bln

Edited by ToeNuttz

Share this post


Link to post
Share on other sites

Hey guys. I thought j had asked this somewhere awhile back, but can’t find it if I did.

I starting to use the remote start here in MI and remembering a problem I have. When using remote start, the climate control doesn’t run. Heated seats don’t turn on. I can enter the remote start menu and change duration and check system on or off, but climate control and seats are grayed out. And I get nothing but a warm engine, frozen windshield, and cold ass when I get in after 15 minutes. Anyone know the location in forscan?

32391D49-E358-4987-BF1B-A74255E92066.jpeg

Edited by tmarsh

Share this post


Link to post
Share on other sites

Tried the IPC config. Disabled and enabled all of these and no change. 

A40EE029-D6D5-4D8D-ACCC-69C71EE83DF1.jpeg

Share this post


Link to post
Share on other sites
6 hours ago, tmarsh said:

Tried the IPC config. Disabled and enabled all of these and no change. 

A40EE029-D6D5-4D8D-ACCC-69C71EE83DF1.jpeg

 

I'm on my phone now, but remember there was a TSB on this that involved a software update to correct it. Try to also look for similar options under the BCM , body control module or FCIM. Greyed out options in IPC usually mean they are enabled for selection in the target module.

  • Like 1

Share this post


Link to post
Share on other sites

Ahh yes I do remember a TSB now that you say that. Did some quick digging now that I have time. FCIM 7A7-01-02 xxxx-xXxx-xxxx needs to be changed from 0 to 2. I’ll give it a go later. 

 

 

Edited by tmarsh
  • Like 2

Share this post


Link to post
Share on other sites
21 hours ago, tmarsh said:

Hey guys. I thought j had asked this somewhere awhile back, but can’t find it if I did.

I starting to use the remote start here in MI and remembering a problem I have. When using remote start, the climate control doesn’t run. Heated seats don’t turn on. I can enter the remote start menu and change duration and check system on or off, but climate control and seats are grayed out. And I get nothing but a warm engine, frozen windshield, and cold ass when I get in after 15 minutes. Anyone know the location in forscan?

-->To prevent getting into the car with a warm engine but a frozen windshield and cold leather seats, the best way is to turn them on before turning the car off. Then later on, when you re-start it the previous settings should be there.

Claude.

Edited by 2FAST4U

Share this post


Link to post
Share on other sites
1 hour ago, 2FAST4U said:

-->To prevent getting into the car with a warm engine but a frozen windshield and cold leather seats, the best way is to turn them on before turning the car off. Then later on, when you re-start it the previous settings should be there.

Claude.

I think the IPC has to be flashed.  ie. firmware update to the module which you can't do with forscan that I know.  When I installed remote start I had to go to the stealership to have it updated.  Sorry, maybe someone else  can come up with a solution.  Good luck.  

Share this post


Link to post
Share on other sites

One other thing... I think it depends on what year the car is... I have a '19 Edge Titanium and when I remote-start the car, most settings like the heated seats, heated steering wheel, heater (or a/c) is set the same way as they were when I last turned the car off.

 

Claude.

Share this post


Link to post
Share on other sites

Update- I checked in forscan from my above post for the FCIM. 

7A7-01-02 was correct, xxxx-x2xx-xxxx. Confused, as it wasn’t working and everything else is correct in other modules. 
I changed the 2 to a 0 which is backwards from what the guy said. And it worked!

I now have the menu options back. Tested, set to auto for climate and seats and it is working. 
 

For the record, it didn’t matter what I left the heat on when I got out, auto or manual. The seats and climate did not turn on until I pushed the start button when I got in. 

Edited by tmarsh
  • Like 2

Share this post


Link to post
Share on other sites
20 hours ago, tmarsh said:

Update- I checked in forscan from my above post for the FCIM. 

7A7-01-02 was correct, xxxx-x2xx-xxxx. Confused, as it wasn’t working and everything else is correct in other modules. 
I changed the 2 to a 0 which is backwards from what the guy said. And it worked!

I now have the menu options back. Tested, set to auto for climate and seats and it is working. 
 

For the record, it didn’t matter what I left the heat on when I got out, auto or manual. The seats and climate did not turn on until I pushed the start button when I got in. 

 

There are configurable settings for the remote start climate on the left IPC screen, did you check those?

Share this post


Link to post
Share on other sites
2 hours ago, redden18 said:

 

There are configurable settings for the remote start climate on the left IPC screen, did you check those?

Yes, further up on this page. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×