Jump to content
jmr061

Official Release of V3.0 for SYNC3 Has Begun

Recommended Posts

Check your owner site to see if you have an update pending. Not all vehicles may have it yet.

Share this post


Link to post
Share on other sites

Thanks, looks like it's available for my Edge. I'd like to know what is different, sometimes if it aint' broke don't fix it. My sync V 2.2 is running pretty good and doing what I need. I think I'll wait until we get some feedback. Ford owner site not very specific about what the update does.

 

img0_7.jpg

Share this post


Link to post
Share on other sites

interesting. the unofficial zip file i downloaded a while back was JL1T-14G381-AJ. The one available to me on the ford website is now JL3T-14G381-AJ. I wonder how much of a difference there is.

 

thanks jmr061

Share this post


Link to post
Share on other sites

interesting. the unofficial zip file i downloaded a while back was JL1T-14G381-AJ. The one available to me on the ford website is now JL3T-14G381-AJ. I wonder how much of a difference there is.

 

thanks jmr061

JL1T was V2.3

Share this post


Link to post
Share on other sites

Also are you sure its JL3T you are seeing for 3.0 and not JR3T?

Share this post


Link to post
Share on other sites

I'm glad they are doing direct updates via usb. I could not get sync to update with wifi at all. It would start then fail.. Ironically enough the only update that was available was 2.3. Hopefully I'll be able to get 3.0 sooner or later.

  • Like 1

Share this post


Link to post
Share on other sites

JL1T was V2.3

 

ah. i may have made a mistake. don't know why i have the 2.3 update zip file on my PC. thanks for letting me know.

Share this post


Link to post
Share on other sites

And I had already updated to 3.0, v18025 from an earlier post and when I downloaded the "official" 3.0 from Ford Owner site, went to update and system told me I already had the most current version. So, nothing changed from earlier? Interesting.

Share this post


Link to post
Share on other sites

 

 

What's included in this update?
JR3T-14G381-AL SYNC3 v3.0

This software release is the latest update in our continued efforts to improve system performance, device connectivity, and the overall SYNC experience.

This software contains all previous enhancements, so there is no need to install any other updates. The installation of this update will take up to 60 minutes to complete. DO NOT remove your USB drive or turn off your vehicle. You must wait until Installation Complete is displayed on the center screen before removing your drive or turning your vehicle off.

While the update is loading, SYNC will not recognize your mobile phone or media device. Be sure your vehicle engine is running (not in accessory mode) throughout the entire installation process. Although your vehicle must be in park when you initiate the installation process, once the download process has begun, you may drive your vehicle.

 

 

For the 2.3 update I left my engine running - this requirement is crazy, and I'll give it a try with just the ignition on.

Share this post


Link to post
Share on other sites

I checked this morning to see what version I have and it showed 2.2. I then clicked on "check for updates" and a bar showed an update in progress, around 20% complete. I guess it's updating automatically while by vehicle is parked at work. It's connected to my workplace wifi. I checked it later and now it's showing around 80% complete. Don't know what version it's updating to, I assume V 3.0

Share this post


Link to post
Share on other sites

 

For the 2.3 update I left my engine running - this requirement is crazy, and I'll give it a try with just the ignition on.

 

I think the reason they say to leave the engine running is that the accessory power will not stay on for 30 minutes without the engine running. If Sync3 shuts down during an update, that could result in a botched update. You can still drive while the update is in progress, it just needs to be in park to start the update. Once the update is started, you can drive the vehicle. Ideally, start the update just before a 30+ minute drive.

Share this post


Link to post
Share on other sites

Well, my update completed via Wifi, version 2.3. I guess updates via wifi are delayed as opposed to USB updates.

Share this post


Link to post
Share on other sites

I used 8gb flash drive.. and it's already 70 minutes being updated... I'm not sure it's stuck or there any progress... just keep waiting

Share this post


Link to post
Share on other sites

I just updated mine using a 4GB USB stick - it took 25 minutes and I just kept the engine idling with my garage door open.

 

I cant detect any changes.

Edited by 1004ron

Share this post


Link to post
Share on other sites

8gb flash drive - took 90 minutes ;[

 

did you notice any interesting new change/update?

Share this post


Link to post
Share on other sites

I downloaded the 3.0 update but I can't get the car to recognize the USB stick. I have formatted it every way I could think and nothing at all. I'll stop at the store and get a new one later. Funny, but the 2.3 update went on like a charm, but using a different USB stick.

Share this post


Link to post
Share on other sites

It can take 10 mins or a bit more before the update actually begins.

Share this post


Link to post
Share on other sites

Updated my 2017 Ford Edge Titanium today to revision V3.0 using a USB stick. Installation took about 18 minutes.

 

Fixed - When using a USB to play MP3 the display of source's now shows the actual USB name instead of the long multi character name.

The indexing seemed a lot faster and upon several restarts the music played starting where it left off.

 

UnFixed - It still takes about 12 minutes to reindex the USB each time there is a restart even though the USB plays the songs OK. I have the same type USB and exact number of songs and playlists on my 2014 Ford Taurus with Sync2 MFT and it only takes about 1 minute for the reindex upon a restart. (3600 songs)

Share this post


Link to post
Share on other sites

The only thing I detect different is the WifI notice on every start - I'll just go and disable WiFi in the settings.

post-44162-0-07475800-1521570752_thumb.jpg

Edited by 1004ron

Share this post


Link to post
Share on other sites
SSM 47049 - 2018 Various Vehicles - SYNC 3 - SYNC WiFi Update Message Displayed Every Key Cycle
Some 2018 Ford and Lincoln vehicles equipped with SYNC 3 and a 6, 8, or 10 inchscreen may show a pop up message every key cycle that states "SYNC can check for updates when connected to a WiFi network". To remove the inconvenience of the pop up the customer can either connect to a trusted WiFi network to complete theset up process or turn off WiFi in the WiFi settings located under the Settingsmenu. Adjusting the setting for the customer is not a warrantable defect.

Share this post


Link to post
Share on other sites

The only thing I detect different is the WifI notice on every start - I'll just go and disable WiFi in the settings.

I have my Ford Edge connected to my house wi-fi and therefore do not get that message.

Share this post


Link to post
Share on other sites

For those that have updated to version 3.0 do you see any difference in performance from v2.3. My edge recently did an auto update from 2.2 to 2.3 and since then I experience screen lockups that last 20-30 seconds at random when switching between functions. Didn't have that before 2.3. Does 3.0 solve this? Are there any issues with V3.0? I have downloaded it onto a flash drive but have yet to install it.

Share this post


Link to post
Share on other sites

For those that have updated to version 3.0 do you see any difference in performance from v2.3. My edge recently did an auto update from 2.2 to 2.3 and since then I experience screen lockups that last 20-30 seconds at random when switching between functions. Didn't have that before 2.3. Does 3.0 solve this? Are there any issues with V3.0? I have downloaded it onto a flash drive but have yet to install it.

I never had any such issues going to 2.3 and neither with 3.0

Share this post


Link to post
Share on other sites

I have my Ford Edge connected to my house wi-fi and therefore do not get that message.

Mine was connected to my home WiFi and it did when in range at home and in the parking lot at work.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×