Jump to content
Ford Edge Forum
Dave33

2013 Edge 2.0 with small evap leak P0456.

Recommended Posts

My daughter's car has code P0456 small evap leak. Doing some research most issues are with the purge valve however there is no such valve on the 2.0 turbo. There is a part called evap canister valve which is much more expensive than a normal purge valve. Has anyone experienced this with a possible fix. Thanks.

Share this post


Link to post
Share on other sites

There is a purge valve I think, but Ford probably lists it as a "hose assembly". Seen that a LOT lately. On the 3.5 EB, you can actually find the purge valve as a separate part. But on smaller engines, assemblies are much more common.

post-23566-0-29679300-1525440341_thumb.jpg

Edited by WWWPerfA_ZN0W

Share this post


Link to post
Share on other sites

Thanks for the reply and diagram. I guess it's called a canister vent solenoid and not a purge valve and It's about $100. I'll have to have the system smoked to see if I can find a leak. I don't want to throw parts at it at that price. If it were a $25 purge valve I would take the chance.

Share this post


Link to post
Share on other sites

Edit: I had the vent solenoid valve or "purge valve" checked and it wasn't holding a vacuum. I replaced the valve which comes with all the hoses with an OEM from the dealership. All was fine for about 800 miles and the light came back on. I then cleaned the fuel filler door flap but again the light came back on after about 500 miles. Now I'm at a loss. I have also sprayed all connections with soapy water but have found nothing.

 

Anyone have any ideas or suggestions?

Edited by Dave33

Share this post


Link to post
Share on other sites

the vent solenoid valve is underneath the vehicle, the purge valve is at the firewall. Which one did you replace?

Share this post


Link to post
Share on other sites

I replaced the assembly from your picture above which was the valve and all the hoses. It comes as a complete assembly.

Share this post


Link to post
Share on other sites

The part number for my car is BB5Z-9G271-B. Cost was around $90. It didn't fix the problem. CEL is still coming on so I'll probably take it to our local shop to be smoked. I'm not throwing any more money at until I know exactly what the problem is.

Edited by Dave33

Share this post


Link to post
Share on other sites

Dave... Mines just got this code. Did you ever get it fixed? I have the 2015 ecoboost model. 

Share this post


Link to post
Share on other sites
On 5/4/2018 at 6:24 AM, WWWPerfA_ZN0W said:

There is a purge valve I think, but Ford probably lists it as a "hose assembly". Seen that a LOT lately. On the 3.5 EB, you can actually find the purge valve as a separate part. But on smaller engines, assemblies are much more common.

post-23566-0-29679300-1525440341_thumb.jpg

 

Is this diagram valid for the 2015 2.0L model? 

 

Also, if you remove this Valve... Can you do the mouth blow test? :)

Edited by 2011edgese

Share this post


Link to post
Share on other sites
On 5/5/2019 at 2:24 PM, 2011edgese said:

Dave... Mines just got this code. Did you ever get it fixed? I have the 2015 ecoboost model. 

No not yet. It stayed off all winter but now that the warmer weather is here it's on almost all the time. I'm thinking it may be the filler neck or capless fill port. I'll be making an appointment soon to have it smoked because the inspection is due in a couple of months.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×