Jump to content
Ford Edge Forum
omar302

Liftgate Weatherstrip Defects?

Recommended Posts

Could someone with a 2015+ Edge confirm if this is normal or not? The weatherstrip for the lift gate has 2 places were it seems like a small piece is cut off. This is on the outer edge. Please see the photos. 1 cut is at the bottom right the other is at the left tailight.

post-24673-0-35918000-1528810311_thumb.jpg

post-24673-0-97039700-1528810324_thumb.jpg

Share this post


Link to post
Share on other sites

What possible purpose would it serve? Just judging by looking at the photos, it looks like it was ripped out.

Share this post


Link to post
Share on other sites

I'd say normal. 2016 SEL

post-41964-0-93443100-1528846151_thumb.jpg

post-41964-0-64355900-1528846161_thumb.jpg

  • Like 2

Share this post


Link to post
Share on other sites

@lildisco

Thanks for the pictures, do you get the exhaust odor under hard acceleration with climate on recirculating?

 

Also, it seems the cut-offs on your liftgate are symmetrical on both sides? Location is not very clear on the first pic.

 

Can someone else confirm? Especially on a year other than 2016? Maybe a bad batch?

Edited by omar302

Share this post


Link to post
Share on other sites

Never get exhaust smell inside on any acceleration & recirculating. 1st pic is drivers side 2nd is passenger side. Both are approximately same location on each side of the hatch

  • Like 1

Share this post


Link to post
Share on other sites

I'd say normal. 2016 SEL

Thats surprising. What purpose, drain slots?

Share this post


Link to post
Share on other sites

@lildisco

Thanks for the pictures, do you get the exhaust odor under hard acceleration with climate on recirculating?

 

Also, it seems the cut-offs on your liftgate are symmetrical on both sides? Location is not very clear on the first pic.

 

Can someone else confirm? Especially on a year other than 2016? Maybe a bad batch?

Omar,

 

There's a TSB for the exhaust smell. Detail can be found on this thread

 

http://www.fordedgeforum.com/topic/22596-tsb-17-0035-exhaust-odor-in-the-vehicle-while-the-climate-control-system-is-in-auto-or-recirculation-m

  • Like 2

Share this post


Link to post
Share on other sites

I already took it in for it, but the odor is still there. Our dealer is not a competent one, but we don't any other one here, so I have no other choice.

  • Like 1

Share this post


Link to post
Share on other sites

Update, like what @lildisco stated in post #3, it seems to be normal, checked another 2016 and had the same cut-outs. Difference only that on my Edge the cut-offs aren't positioned symmetrical (as if the weatherstrip had moved), i'll try to align it correctly. Also the part's picture on fordpartsonline has the same cut-out.

 

 

post-24673-0-05409700-1529867654_thumb.jpg

  • Like 1

Share this post


Link to post
Share on other sites

I just saw this post and thought that I would check my 17 Sport. It too has the small (approximately 1") sections of weather stripping removed. I say removed because it looks as though the material was removed after the weather stripping was installed. Possibly done with a razor knife. On mine, it would appear as though the paint is scarred on what would be the lower edge of the gap.

  • Like 2

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×