Jump to content
Sign in to follow this  
13 edge

2013 Edge speedometer needle moving bacwards.

Recommended Posts

Hello all.  The speedometer needle on my 2013 edge is moving backwards. This is happening with engine off and key out of ignition. I was wondering if anyone else has seen this problem. Thanks for your input. 

Share this post


Link to post
Share on other sites

I had this problem start to occur about two months before the battery had to be replaced. It is one of the many signs of when the battery is going bad. I would have the battery tested and see what is said before it leaves you stranded. If it is over three years old it may be time to replace it. 

  • Like 1

Share this post


Link to post
Share on other sites

Thanks for the reply. Funny thing is that I noticed this after I replaced the battery. I took the battery back and they replaced it with a new one. And I still have the same problem. Took it to dealer. They diagnosed that it needs a new cluster. 

Share this post


Link to post
Share on other sites

Sounds to me like a recalibration of the cluster would be enough, since it does coincide with battery issues.

Share this post


Link to post
Share on other sites

Can you tell me how I can get that done? I mentioned it to the dealer and it seems like they just ignored my question. Thanks. 

 

Share this post


Link to post
Share on other sites
6 hours ago, WWWPerfA_ZN0W said:

Sounds to me like a recalibration of the cluster would be enough, since it does coincide with battery issues.

Can you tell me how I can get that done? I mentioned it to the dealer and it seems like they just ignored my question. Thanks

 

Share this post


Link to post
Share on other sites

I would go to another dealer then.  TSBs have been issued to update the cluster before, so this should not be unfamiliar territory.  Try a Lincoln (standalone) dealer if available, if Ford dealers do not pan out.  Maybe talk to the shop foreman directly, you are more likely to get a straightup answer from him/her than the service advisor.

Share this post


Link to post
Share on other sites

Thanks for the info. I'll try a different dealer. I actually had the shop foreman come out to the car with me, to show him the problem. And also mentioned it to him. His response was I've never seen anything like this before. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×